summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-08-01 20:49:12 +0000
committerMike Frysinger <vapier@gentoo.org>2004-08-01 20:49:12 +0000
commit43c25cdd920d59c3d4202deed82f84c2cb7a765a (patch)
tree13ad763271ef9357e903b8cf55d364324f0cb382 /sys-libs/gdbm/gdbm-1.8.3-r1.ebuild
parentfixed #44412 (Manifest recommit) (diff)
downloadgentoo-2-43c25cdd920d59c3d4202deed82f84c2cb7a765a.tar.gz
gentoo-2-43c25cdd920d59c3d4202deed82f84c2cb7a765a.tar.bz2
gentoo-2-43c25cdd920d59c3d4202deed82f84c2cb7a765a.zip
dont copy over old library if it is 0 bytes
Diffstat (limited to 'sys-libs/gdbm/gdbm-1.8.3-r1.ebuild')
-rw-r--r--sys-libs/gdbm/gdbm-1.8.3-r1.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/sys-libs/gdbm/gdbm-1.8.3-r1.ebuild b/sys-libs/gdbm/gdbm-1.8.3-r1.ebuild
new file mode 100644
index 000000000000..388225c6b182
--- /dev/null
+++ b/sys-libs/gdbm/gdbm-1.8.3-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/gdbm/gdbm-1.8.3-r1.ebuild,v 1.3 2004/08/01 20:49:12 vapier Exp $
+
+inherit gnuconfig flag-o-matic
+
+DESCRIPTION="Standard GNU database libraries included for compatibility with Perl"
+HOMEPAGE="http://www.gnu.org/software/gdbm/gdbm.html"
+SRC_URI="mirror://gnu/gdbm/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~mips ~alpha arm ~hppa amd64 ~ia64 ppc64 ~s390"
+IUSE="berkdb static"
+
+DEPEND="virtual/libc
+ berkdb? ( =sys-libs/db-1* )"
+RDEPEND="virtual/libc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ gnuconfig_update
+}
+
+src_compile() {
+ append-flags -fomit-frame-pointer
+ econf || die
+ use berkdb || sed -i '/HAVE_LIBNDBM/s:.*::' autoconf.h
+ emake || die
+}
+
+src_install() {
+ make INSTALL_ROOT=${D} install || die
+
+ make \
+ includedir=/usr/include/gdbm \
+ INSTALL_ROOT=${D} \
+ install-compat || die
+
+ dodoc ChangeLog NEWS README
+
+ # temp backwards support #32510
+ if [ -s ${ROOT}/usr/lib/libgdbm.so.2 ] ; then
+ cp ${ROOT}/usr/lib/libgdbm.so.2 ${D}/usr/lib/
+ touch ${D}/usr/lib/libgdbm.so.2
+ fi
+}
+
+pkg_postinst() {
+ ewarn "Please run revdep-rebuild --soname libgdbm.so.2"
+ ewarn "Packages compiled against the previous version will not work"
+}