summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-04-28 17:55:59 +0000
committerMichał Górny <mgorny@gentoo.org>2014-04-28 17:55:59 +0000
commitccb9141d8f58aefd2a297dc564635e4678e65873 (patch)
tree1b73409578f948b79fdba99dc756b1fbc0e959bb /sys-libs/gdbm
parentReplace multilib_build_binaries with multilib_is_native_abi, in order to put ... (diff)
downloadgentoo-2-ccb9141d8f58aefd2a297dc564635e4678e65873.tar.gz
gentoo-2-ccb9141d8f58aefd2a297dc564635e4678e65873.tar.bz2
gentoo-2-ccb9141d8f58aefd2a297dc564635e4678e65873.zip
Replace multilib_build_binaries with multilib_is_native_abi, in order to put an end to the confusion introduced by having two functions, the proper one suggesting it is just for binaries.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'sys-libs/gdbm')
-rw-r--r--sys-libs/gdbm/ChangeLog8
-rw-r--r--sys-libs/gdbm/gdbm-1.10-r1.ebuild6
-rw-r--r--sys-libs/gdbm/gdbm-1.11.ebuild4
3 files changed, 12 insertions, 6 deletions
diff --git a/sys-libs/gdbm/ChangeLog b/sys-libs/gdbm/ChangeLog
index 78cd364d4253..5d2d2b712c59 100644
--- a/sys-libs/gdbm/ChangeLog
+++ b/sys-libs/gdbm/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-libs/gdbm
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/gdbm/ChangeLog,v 1.69 2014/04/21 07:42:26 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/gdbm/ChangeLog,v 1.70 2014/04/28 17:55:59 mgorny Exp $
+
+ 28 Apr 2014; Michał Górny <mgorny@gentoo.org> gdbm-1.10-r1.ebuild,
+ gdbm-1.11.ebuild:
+ Replace multilib_build_binaries with multilib_is_native_abi, in order to put
+ an end to the confusion introduced by having two functions, the proper one
+ suggesting it is just for binaries.
21 Apr 2014; Michał Górny <mgorny@gentoo.org> gdbm-1.11.ebuild:
Use the new multilib_native_use* functions.
diff --git a/sys-libs/gdbm/gdbm-1.10-r1.ebuild b/sys-libs/gdbm/gdbm-1.10-r1.ebuild
index 940fe153a7ba..d02155e96087 100644
--- a/sys-libs/gdbm/gdbm-1.10-r1.ebuild
+++ b/sys-libs/gdbm/gdbm-1.10-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/gdbm/gdbm-1.10-r1.ebuild,v 1.3 2014/01/18 03:55:06 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/gdbm/gdbm-1.10-r1.ebuild,v 1.4 2014/04/28 17:55:59 mgorny Exp $
EAPI="4"
@@ -33,7 +33,7 @@ multilib_src_configure() {
# gdbm doesn't appear to use either of these libraries
export ac_cv_lib_dbm_main=no ac_cv_lib_ndbm_main=no
- if multilib_build_binaries && use exporter ; then
+ if multilib_is_native_abi && use exporter ; then
pushd "${EX_S}" >/dev/null
append-lfs-flags
econf --disable-shared
@@ -46,7 +46,7 @@ multilib_src_configure() {
--with-gdbm183-libdir="${EX_S}/.libs" \
--with-gdbm183-includedir="${EX_S}" \
$(use_enable berkdb libgdbm-compat) \
- $(multilib_build_binaries && use_enable exporter gdbm-export) \
+ $(multilib_is_native_abi && use_enable exporter gdbm-export) \
$(use_enable nls) \
$(use_enable static-libs static)
}
diff --git a/sys-libs/gdbm/gdbm-1.11.ebuild b/sys-libs/gdbm/gdbm-1.11.ebuild
index 67a746dae646..dfb2d3195892 100644
--- a/sys-libs/gdbm/gdbm-1.11.ebuild
+++ b/sys-libs/gdbm/gdbm-1.11.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/gdbm/gdbm-1.11.ebuild,v 1.3 2014/04/21 07:42:26 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/gdbm/gdbm-1.11.ebuild,v 1.4 2014/04/28 17:55:59 mgorny Exp $
EAPI="4"
@@ -33,7 +33,7 @@ multilib_src_configure() {
# gdbm doesn't appear to use either of these libraries
export ac_cv_lib_dbm_main=no ac_cv_lib_ndbm_main=no
- if multilib_build_binaries && use exporter ; then
+ if multilib_is_native_abi && use exporter ; then
pushd "${EX_S}" >/dev/null
append-lfs-flags
econf --disable-shared