summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTravis Tilley <lv@gentoo.org>2004-10-13 17:31:46 +0000
committerTravis Tilley <lv@gentoo.org>2004-10-13 17:31:46 +0000
commit517ab47144f1d7bfdad84be4cd503cf5e6b7a782 (patch)
tree37c20b09e73b7a2764dd992d7bd03f5fe19cd9c6 /sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild
parent+ quick assuan fix, closing bug #66362 (diff)
downloadgentoo-2-517ab47144f1d7bfdad84be4cd503cf5e6b7a782.tar.gz
gentoo-2-517ab47144f1d7bfdad84be4cd503cf5e6b7a782.tar.bz2
gentoo-2-517ab47144f1d7bfdad84be4cd503cf5e6b7a782.zip
it seems the strange libpthread-not-installed bug was an ebuild quirk and not a portage quirk. it should hopefully be fixed now. i've also added a safety function to 2.3.4.20040808 and 2.3.4.20041006 that will prevent glibc from installing if libpthread is missing, which will likely be expanded further in the future.
Diffstat (limited to 'sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild')
-rw-r--r--sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild14
1 files changed, 11 insertions, 3 deletions
diff --git a/sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild b/sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild
index 111862fff961..9da45cef8ec2 100644
--- a/sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild
+++ b/sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild,v 1.6 2004/10/13 17:16:12 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild,v 1.7 2004/10/13 17:31:46 lv Exp $
inherit eutils flag-o-matic gcc
@@ -602,9 +602,9 @@ src_install() {
install || die
# now, strip everything but the thread libs #46186
mkdir ${T}/thread-backup
- mv ${D}/lib/lib{pthread,thread_db}* ${T}/thread-backup/
+ mv ${D}/$(get_libdir)/lib{pthread,thread_db}* ${T}/thread-backup/
env -uRESTRICT prepallstrip
- mv ${T}/thread-backup/* ${D}/lib/
+ mv ${T}/thread-backup/* ${D}/$(get_libdir)/ || die
# If librt.so is a symlink, change it into linker script (Redhat)
if [ -L "${D}/usr/lib/librt.so" -a "${LIBRT_LINKERSCRIPT}" = "yes" ]; then
@@ -692,6 +692,8 @@ EOF
insinto /etc
doins ${FILESDIR}/locales.build
+ must_exist /$(get_libdir)/ libpthread.so.0
+
# this whole section is useless, it fails if sandbox is LOADED, not if it's
# enabled. but forcing sandbox not to load isnt an option...
if use makecheck; then
@@ -783,3 +785,9 @@ pkg_postinst() {
/sbin/init U &> /dev/null
fi
}
+
+
+must_exist() {
+ test -e ${D}/${1}/${2} || die "${1}/${2} was not installed"
+}
+