summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-09-16 05:51:57 +0000
committerMike Frysinger <vapier@gentoo.org>2005-09-16 05:51:57 +0000
commit692da8352cfe84f8531b0a5409e9e0e93e085bbb (patch)
treec5802fdf12f93e685b262345a1306b8b830d0975 /sys-libs/glibc/glibc-2.3.4.20041102-r2.ebuild
parentVersion bump, closes bug 102191. (diff)
downloadgentoo-2-692da8352cfe84f8531b0a5409e9e0e93e085bbb.tar.gz
gentoo-2-692da8352cfe84f8531b0a5409e9e0e93e085bbb.tar.bz2
gentoo-2-692da8352cfe84f8531b0a5409e9e0e93e085bbb.zip
touchup status output while building
(Portage version: 2.0.52-r1 http://ronaldmcnightrider.ytmnd.com/ )
Diffstat (limited to 'sys-libs/glibc/glibc-2.3.4.20041102-r2.ebuild')
-rw-r--r--sys-libs/glibc/glibc-2.3.4.20041102-r2.ebuild91
1 files changed, 49 insertions, 42 deletions
diff --git a/sys-libs/glibc/glibc-2.3.4.20041102-r2.ebuild b/sys-libs/glibc/glibc-2.3.4.20041102-r2.ebuild
index 18205539ea3b..8be73075ac86 100644
--- a/sys-libs/glibc/glibc-2.3.4.20041102-r2.ebuild
+++ b/sys-libs/glibc/glibc-2.3.4.20041102-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20041102-r2.ebuild,v 1.4 2005/09/16 05:03:17 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20041102-r2.ebuild,v 1.5 2005/09/16 05:51:57 vapier Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -946,7 +946,7 @@ glibc_do_configure() {
--host=${CTARGET_OPT:-${CTARGET}}
--disable-profile
--without-gd
- --with-headers=$(alt_headers)
+ --with-headers=${ROOT}$(alt_headers)
--prefix=$(alt_prefix)
--mandir=$(alt_prefix)/share/man
--infodir=$(alt_prefix)/share/info
@@ -958,7 +958,7 @@ glibc_do_configure() {
GBUILDDIR=${WORKDIR}/build-${ABI}-${CTARGET}-$1
mkdir -p ${GBUILDDIR}
cd ${GBUILDDIR}
- einfo "Configuring GLIBC for $1 with: ${myconf}"
+ einfo "Configuring GLIBC for $1 with: ${myconf// /\n\t\t}"
${S}/configure ${myconf} || die "failed to configure glibc"
}
@@ -1239,20 +1239,22 @@ src_unpack() {
src_compile() {
crosscompile_setup
- # MULTILIB-CLEANUP: Fix this when FEATURES=multilib-pkg is in portage
- local MLTEST=$(type dyn_unpack)
- if has_multilib_profile && [ -z "${OABI}" -a "${MLTEST/set_abi}" = "${MLTEST}" ] ; then
- OABI="${ABI}"
- for ABI in $(get_install_abis); do
- export ABI
- einfo "Compiling ${ABI} glibc"
- src_compile
- done
- ABI="${OABI}"
- unset OABI
- return 0
+ if [[ -z ${OABI} ]] && has_multilib_profile ; then
+ # MULTILIB-CLEANUP: Fix this when FEATURES=multilib-pkg is in portage
+ local MLTEST=$(type dyn_unpack)
+ if [[ ${MLTEST/set_abi} == "${MLTEST}" ]] ; then
+ OABI=${ABI}
+ einfo "Building multilib glibc for ABIs: $(get_install_abis)"
+ for ABI in $(get_install_abis) ; do
+ export ABI=${ABI}
+ src_compile
+ done
+ ABI=${OABI}
+ unset OABI
+ return 0
+ fi
+ unset MLTEST
fi
- unset MLTEST
ABI=${ABI:-default}
toolchain-glibc_src_compile
@@ -1261,20 +1263,23 @@ src_compile() {
src_test() {
crosscompile_setup
- # MULTILIB-CLEANUP: Fix this when FEATURES=multilib-pkg is in portage
- local MLTEST=$(type dyn_unpack)
- if has_multilib_profile && [ -z "${OABI}" -a "${MLTEST/set_abi}" = "${MLTEST}" ] ; then
- OABI="${ABI}"
- for ABI in $(get_install_abis); do
- export ABI
- einfo "Testing ${ABI} glibc"
- src_test
- done
- ABI="${OABI}"
- unset OABI
- return 0
+ if [[ -z ${OABI} ]] && has_multilib_profile ; then
+ # MULTILIB-CLEANUP: Fix this when FEATURES=multilib-pkg is in portage
+ local MLTEST=$(type dyn_unpack)
+ if [[ ${MLTEST/set_abi} == "${MLTEST}" ]] ; then
+ OABI=${ABI}
+ einfo "Testing multilib glibc for ABIs: $(get_install_abis)"
+ for ABI in $(get_install_abis) ; do
+ export ABI
+ einfo " Testing ${ABI} glibc"
+ src_test
+ done
+ ABI=${OABI}
+ unset OABI
+ return 0
+ fi
+ unset MLTEST
fi
- unset MLTEST
ABI=${ABI:-default}
toolchain-glibc_src_test
@@ -1283,20 +1288,22 @@ src_test() {
src_install() {
crosscompile_setup
- # MULTILIB-CLEANUP: Fix this when FEATURES=multilib-pkg is in portage
- local MLTEST=$(type dyn_unpack)
- if has_multilib_profile && [ -z "${OABI}" -a "${MLTEST/set_abi}" = "${MLTEST}" ] ; then
- OABI="${ABI}"
- for ABI in $(get_install_abis); do
- export ABI
- einfo "Installing ${ABI} glibc"
- src_install
- done
- ABI="${OABI}"
- unset OABI
- return 0
+ if [[ -z ${OABI} ]] && has_multilib_profile ; then
+ # MULTILIB-CLEANUP: Fix this when FEATURES=multilib-pkg is in portage
+ local MLTEST=$(type dyn_unpack)
+ if [[ ${MLTEST/set_abi} == "${MLTEST}" ]] ; then
+ OABI=${ABI}
+ einfo "Installing multilib glibc for ABIs: $(get_install_abis)"
+ for ABI in $(get_install_abis) ; do
+ export ABI
+ src_install
+ done
+ ABI=${OABI}
+ unset OABI
+ return 0
+ fi
+ unset MLTEST
fi
- unset MLTEST
ABI=${ABI:-default}