summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <rhill@gentoo.org>2014-06-14 08:07:10 +0000
committerRyan Hill <rhill@gentoo.org>2014-06-14 08:07:10 +0000
commitcd10d332445c2f87bfb8cf4cfcea88bcbca3febd (patch)
tree984ea836de9a77e4f188367fe3fe66cc73e1064f /sys-libs/glibc
parentAdd CHOST-prefixing to nspr-config. Clean up. Add 32-bit arches to the ${ABI}... (diff)
downloadgentoo-2-cd10d332445c2f87bfb8cf4cfcea88bcbca3febd.tar.gz
gentoo-2-cd10d332445c2f87bfb8cf4cfcea88bcbca3febd.tar.bz2
gentoo-2-cd10d332445c2f87bfb8cf4cfcea88bcbca3febd.zip
Strip -fstack-protector*. These flags are now enabled by default so we can
consider them supported. And even on systems where gcc-specs-ssp is true, having -fstack-protector in CFLAGS causes a failure because flags added here end up getting /pre/pended to user flags. Signed-off-by: Ryan Hill <rhill@gentoo.org> (Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 957A8463)
Diffstat (limited to 'sys-libs/glibc')
-rw-r--r--sys-libs/glibc/ChangeLog8
-rw-r--r--sys-libs/glibc/files/eblits/common.eblit9
2 files changed, 14 insertions, 3 deletions
diff --git a/sys-libs/glibc/ChangeLog b/sys-libs/glibc/ChangeLog
index 90eea870829e..dfee6e900505 100644
--- a/sys-libs/glibc/ChangeLog
+++ b/sys-libs/glibc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-libs/glibc
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.992 2014/04/05 16:05:07 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.993 2014/06/14 08:07:10 rhill Exp $
+
+ 14 Jun 2014; Ryan Hill <rhill@gentoo.org> files/eblits/common.eblit:
+ Strip -fstack-protector*. These flags are now enabled by default so we can
+ consider them supported. And even on systems where gcc-specs-ssp is true,
+ having -fstack-protector in CFLAGS causes a failure because flags added
+ here end up getting /pre/pended to user flags.
05 Apr 2014; Mike Frysinger <vapier@gentoo.org> glibc-2.17.ebuild,
glibc-2.18-r1.ebuild, glibc-2.19.ebuild, glibc-9999.ebuild:
diff --git a/sys-libs/glibc/files/eblits/common.eblit b/sys-libs/glibc/files/eblits/common.eblit
index 91df3f24546f..c2ce4aafb81c 100644
--- a/sys-libs/glibc/files/eblits/common.eblit
+++ b/sys-libs/glibc/files/eblits/common.eblit
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/files/eblits/common.eblit,v 1.34 2014/01/16 17:38:31 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/files/eblits/common.eblit,v 1.35 2014/06/14 08:07:10 rhill Exp $
alt_prefix() {
is_crosscompile && echo /usr/${CTARGET}
@@ -183,7 +183,12 @@ setup_flags() {
# building glibc with SSP is fraught with difficulty, especially
# due to __stack_chk_fail_local which would mean significant changes
# to the glibc build process. See bug #94325 #293721
- gcc-specs-ssp && append-cflags $(test-flags-CC -fno-stack-protector)
+ # Note we have to handle both user-given CFLAGS and gcc defaults via
+ # spec rules here. We can't simply add -fno-stack-protector as it gets
+ # added before user flags, and we can't just filter-flags because
+ # _filter_hardened doesn't support globs.
+ filter-flags -fstack-protector*
+ gcc-specs-ssp && append-flags $(test-flags -fno-stack-protector)
if use hardened && gcc-specs-pie ; then
# Force PIC macro definition for all compilations since they're all