summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2003-10-11 17:39:31 +0000
committerMartin Schlemmer <azarah@gentoo.org>2003-10-11 17:39:31 +0000
commit3bb8c4b8398dacf1412bb1b9d61c158f47147c4f (patch)
tree9ddba2a885cbcd14553e112e5f23745b04f8ff62 /sys-libs/lib-compat/lib-compat-1.2-r1.ebuild
parentCleanup the filenames to be a bit more uniform, and fix warning with (diff)
downloadgentoo-2-3bb8c4b8398dacf1412bb1b9d61c158f47147c4f.tar.gz
gentoo-2-3bb8c4b8398dacf1412bb1b9d61c158f47147c4f.tar.bz2
gentoo-2-3bb8c4b8398dacf1412bb1b9d61c158f47147c4f.zip
Cleanup the filenames to be a bit more uniform, and fix warning with
ldconfig from glibc-2.3.3.
Diffstat (limited to 'sys-libs/lib-compat/lib-compat-1.2-r1.ebuild')
-rw-r--r--sys-libs/lib-compat/lib-compat-1.2-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sys-libs/lib-compat/lib-compat-1.2-r1.ebuild b/sys-libs/lib-compat/lib-compat-1.2-r1.ebuild
new file mode 100644
index 000000000000..6cb6f3236aaf
--- /dev/null
+++ b/sys-libs/lib-compat/lib-compat-1.2-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/lib-compat/lib-compat-1.2-r1.ebuild,v 1.1 2003/10/11 17:39:20 azarah Exp $
+
+IUSE=
+
+S="${WORKDIR}/${P}/${ARCH}"
+DESCRIPTION="Compatibility C++ and libc5 and libc6 libraries for programs new and old"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+
+DEPEND="virtual/glibc"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ # Rather install this with the proper filename
+ mv -f libstdc++-libc6.2-2.so.3 libstdc++-3-libc6.2-2-2.10.0.so
+ # libstdc++-2-libc6.1-1-2.9.0.so provides this one ...
+ rm -f libstdc++-libc6.1-1.so.2
+ # No package installs this one, so no need for the .dummy
+ mv -f libstdc++.so.2.9.dummy libstdc++.so.2.9.0
+}
+
+src_install() {
+ into /usr
+ dolib.so *.so*
+ preplib /usr
+}
+