summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-10-26 07:44:56 +0000
committerMike Frysinger <vapier@gentoo.org>2009-10-26 07:44:56 +0000
commite7efb84e43e21e91645f91728d1f1206bc0e939d (patch)
treef1c1709498e4b56be9485652593b704635342ba9 /sys-libs/libcap-ng
parentBug #289519: Fixup for Firebird compile. Bug #256411: Fix for Oracle compile.... (diff)
downloadgentoo-2-e7efb84e43e21e91645f91728d1f1206bc0e939d.tar.gz
gentoo-2-e7efb84e43e21e91645f91728d1f1206bc0e939d.tar.bz2
gentoo-2-e7efb84e43e21e91645f91728d1f1206bc0e939d.zip
Version bump.
(Portage version: 2.2_rc46/cvs/Linux x86_64)
Diffstat (limited to 'sys-libs/libcap-ng')
-rw-r--r--sys-libs/libcap-ng/ChangeLog7
-rw-r--r--sys-libs/libcap-ng/libcap-ng-0.6.2.ebuild36
2 files changed, 42 insertions, 1 deletions
diff --git a/sys-libs/libcap-ng/ChangeLog b/sys-libs/libcap-ng/ChangeLog
index e2ca63046919..cf9c33acbac3 100644
--- a/sys-libs/libcap-ng/ChangeLog
+++ b/sys-libs/libcap-ng/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/libcap-ng
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcap-ng/ChangeLog,v 1.2 2009/09/30 08:36:38 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcap-ng/ChangeLog,v 1.3 2009/10/26 07:44:56 vapier Exp $
+
+*libcap-ng-0.6.2 (26 Oct 2009)
+
+ 26 Oct 2009; Mike Frysinger <vapier@gentoo.org> +libcap-ng-0.6.2.ebuild:
+ Version bump.
30 Sep 2009; Christian Faulhammer <fauli@gentoo.org>
libcap-ng-0.6.1.ebuild:
diff --git a/sys-libs/libcap-ng/libcap-ng-0.6.2.ebuild b/sys-libs/libcap-ng/libcap-ng-0.6.2.ebuild
new file mode 100644
index 000000000000..bcde9c68e70f
--- /dev/null
+++ b/sys-libs/libcap-ng/libcap-ng-0.6.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcap-ng/libcap-ng-0.6.2.ebuild,v 1.1 2009/10/26 07:44:56 vapier Exp $
+
+EAPI="2"
+
+inherit eutils autotools
+
+DESCRIPTION="POSIX 1003.1e capabilities"
+HOMEPAGE="http://people.redhat.com/sgrubb/libcap-ng/"
+SRC_URI="http://people.redhat.com/sgrubb/libcap-ng/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="python"
+
+RDEPEND="sys-apps/attr
+ python? ( dev-lang/python )"
+DEPEND="${RDEPEND}
+ sys-kernel/linux-headers
+ python? ( dev-lang/swig )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-gentoo.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable python) || die "econf failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+ dodoc ChangeLog README
+}