summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2008-11-24 04:10:22 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2008-11-24 04:10:22 +0000
commitca2a53194788981a60bf8b525dd389a5ffc63214 (patch)
treeeffa159f170108091468664704ed218018ccf0df /sys-libs/libsafe
parentBump virt-manager to 0.6.0 (diff)
downloadgentoo-2-ca2a53194788981a60bf8b525dd389a5ffc63214.tar.gz
gentoo-2-ca2a53194788981a60bf8b525dd389a5ffc63214.tar.bz2
gentoo-2-ca2a53194788981a60bf8b525dd389a5ffc63214.zip
Fixed CFLAGS issue, bug #242034. Removed prelude USE flag, bug #248428.
(Portage version: 2.2_rc15/cvs/Linux 2.6.27-gentoo-r2 x86_64)
Diffstat (limited to 'sys-libs/libsafe')
-rw-r--r--sys-libs/libsafe/ChangeLog9
-rw-r--r--sys-libs/libsafe/libsafe-2.0_p16-r2.ebuild62
2 files changed, 69 insertions, 2 deletions
diff --git a/sys-libs/libsafe/ChangeLog b/sys-libs/libsafe/ChangeLog
index d09dd8c07709..97e90aa5ab98 100644
--- a/sys-libs/libsafe/ChangeLog
+++ b/sys-libs/libsafe/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/libsafe
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libsafe/ChangeLog,v 1.8 2007/05/14 06:20:09 bangert Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libsafe/ChangeLog,v 1.9 2008/11/24 04:10:22 matsuu Exp $
+
+*libsafe-2.0_p16-r2 (24 Nov 2008)
+
+ 24 Nov 2008; MATSUU Takuto <matsuu@gentoo.org> +libsafe-2.0_p16-r2.ebuild:
+ Fixed CFLAGS issue, bug #242034. Removed prelude USE flag, bug #248428.
14 May 2007; Thilo Bangert <bangert@gentoo.org> metadata.xml:
add <herd>no-herd</herd>
diff --git a/sys-libs/libsafe/libsafe-2.0_p16-r2.ebuild b/sys-libs/libsafe/libsafe-2.0_p16-r2.ebuild
new file mode 100644
index 000000000000..821ab9fdefe4
--- /dev/null
+++ b/sys-libs/libsafe/libsafe-2.0_p16-r2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libsafe/libsafe-2.0_p16-r2.ebuild,v 1.1 2008/11/24 04:10:22 matsuu Exp $
+
+inherit flag-o-matic toolchain-funcs multilib
+
+MY_P="${P/_p/-}"
+DESCRIPTION="Protection against buffer overflow vulnerabilities"
+HOMEPAGE="http://www.research.avayalabs.com/gcm/usa/en-us/initiatives/all/nsr.htm&Filter=ProjectTitle:Libsafe&Wrapper=LabsProjectDetails&View=LabsProjectDetails"
+SRC_URI="http://www.research.avayalabs.com/project/libsafe/src/${MY_P}.tgz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ filter-flags -fomit-frame-pointer
+
+ sed -i \
+ -e "s:gcc:$(tc-getCC):" \
+ -e "/^CCFLAGS/s:-O2:${CFLAGS}:" \
+ -e "/^LDFLAGS/s:= := ${LDFALGS}:" \
+ -e "s:\$(LIBPRELUDE_CFLAGS)::" \
+ -e "s:\$(LIBPRELUDE_LIBS)::" \
+ src/Makefile || die
+}
+
+src_compile() {
+ emake libsafe || die
+}
+
+src_install() {
+ # libsafe stuff
+ into /
+ dolib.so src/libsafe.so.${PV/_p/.} || die
+ # dodir /lib
+ dosym libsafe.so.${PV/_p/.} /$(get_libdir)/libsafe.so || die
+ dosym libsafe.so.${PV/_p/.} /$(get_libdir)/libsafe.so.${PV%%.*} || die
+
+ # Documentation
+ doman doc/libsafe.8
+ dohtml doc/libsafe.8.html
+
+ dodoc README
+ # use prelude && dodoc LIBPRELUDE
+ # use mta && dodoc EMAIL_NOTIFICATION
+}
+
+pkg_postinst() {
+ einfo
+ einfo "To use this you have to put the library as one of the variables"
+ einfo "in LD_PRELOAD."
+ einfo "Example in bash:"
+ einfo "export LD_PRELOAD=libsafe.so.${PV%%.*}"
+ einfo
+}