summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris PeBenito <pebenito@gentoo.org>2008-10-03 03:23:41 +0000
committerChris PeBenito <pebenito@gentoo.org>2008-10-03 03:23:41 +0000
commit66707ad11cb1ba8766a2c92c159d8926cd772cf0 (patch)
tree5148b17b6721f40d372b42d561e9032111f7d8e6 /sys-libs/libselinux
parentInitial commit of 2.0 libsepol. (diff)
downloadgentoo-2-66707ad11cb1ba8766a2c92c159d8926cd772cf0.tar.gz
gentoo-2-66707ad11cb1ba8766a2c92c159d8926cd772cf0.tar.bz2
gentoo-2-66707ad11cb1ba8766a2c92c159d8926cd772cf0.zip
Initial commit of 2.0 libselinux.
(Portage version: 2.2_rc11/cvs/Linux 2.6.24-gentoo-r3 x86_64)
Diffstat (limited to 'sys-libs/libselinux')
-rw-r--r--sys-libs/libselinux/ChangeLog8
-rw-r--r--sys-libs/libselinux/libselinux-2.0.71.ebuild71
2 files changed, 78 insertions, 1 deletions
diff --git a/sys-libs/libselinux/ChangeLog b/sys-libs/libselinux/ChangeLog
index 39a779f1fc85..5f4f9dde13d9 100644
--- a/sys-libs/libselinux/ChangeLog
+++ b/sys-libs/libselinux/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-libs/libselinux
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libselinux/ChangeLog,v 1.60 2008/05/29 18:08:46 hawking Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libselinux/ChangeLog,v 1.61 2008/10/03 03:23:41 pebenito Exp $
+
+*libselinux-2.0.71 (03 Oct 2008)
+
+ 03 Oct 2008; Chris PeBenito <pebenito@gentoo.org>
+ +libselinux-2.0.71.ebuild:
+ Initial commit of 2.0 libselinux.
29 May 2008; Ali Polatel <hawking@gentoo.org> libselinux-1.34.14.ebuild:
python_mod_optimize is ROOT aware. Fixed python_mod_cleanup.
diff --git a/sys-libs/libselinux/libselinux-2.0.71.ebuild b/sys-libs/libselinux/libselinux-2.0.71.ebuild
new file mode 100644
index 000000000000..a15e84b0cbec
--- /dev/null
+++ b/sys-libs/libselinux/libselinux-2.0.71.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libselinux/libselinux-2.0.71.ebuild,v 1.1 2008/10/03 03:23:41 pebenito Exp $
+
+IUSE="ruby"
+RUBY_OPTIONAL="yes"
+
+inherit eutils multilib python ruby
+
+#BUGFIX_PATCH="${FILESDIR}/libselinux-1.30.3.diff"
+
+SEPOL_VER="2.0"
+
+DESCRIPTION="SELinux userland library"
+HOMEPAGE="http://userspace.selinuxproject.org"
+SRC_URI="http://userspace.selinuxproject.org/releases/current/devel/${P}.tar.gz"
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~mips ~ppc ~sparc ~x86"
+
+DEPEND="=sys-libs/libsepol-${SEPOL_VER}*
+ dev-lang/swig
+ ruby? ( dev-lang/ruby )"
+
+RDEPEND="=sys-libs/libsepol-${SEPOL_VER}*
+ ruby? ( dev-lang/ruby )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ [ ! -z "${BUGFIX_PATCH}" ] && epatch "${BUGFIX_PATCH}"
+
+ # fix up paths for multilib
+ sed -i -e "/^LIBDIR/s/lib/$(get_libdir)/" "${S}/src/Makefile" \
+ || die "Fix for multilib LIBDIR failed."
+ sed -i -e "/^SHLIBDIR/s/lib/$(get_libdir)/" "${S}/src/Makefile" \
+ || die "Fix for multilib SHLIBDIR failed."
+}
+
+src_compile() {
+ python_version
+ emake LDFLAGS="-fPIC ${LDFLAGS}" all || die
+ emake PYLIBVER="python${PYVER}" LDFLAGS="-fPIC ${LDFLAGS}" pywrap || die
+
+ if use ruby; then
+ emake rubywrap || die
+ fi
+
+ # add compatability aliases to swig wrapper
+ cat "${FILESDIR}/compat.py" >> "${S}/src/selinux.py" || die
+}
+
+src_install() {
+ python_version
+ make DESTDIR="${D}" PYLIBVER="python${PYVER}" install install-pywrap || die
+
+ if use ruby; then
+ emake DESTDIR="${D}" install-rubywrap || die
+ fi
+}
+
+pkg_postinst() {
+ python_version
+ python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages
+}
+
+pkg_postrm() {
+ python_version
+ python_mod_cleanup /usr/$(get_libdir)/python${PYVER}/site-packages
+}