summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris PeBenito <pebenito@gentoo.org>2008-01-29 15:12:57 +0000
committerChris PeBenito <pebenito@gentoo.org>2008-01-29 15:12:57 +0000
commitb42f61ed0a2c5cda97caee4522bb4c9a7dd346e1 (patch)
tree1503c98a29ce2773d5f1cf8c4256d90fc8da11c1 /sys-libs/libselinux
parentalpha/ia64/sparc stable wrt #207634 (diff)
downloadgentoo-2-b42f61ed0a2c5cda97caee4522bb4c9a7dd346e1.tar.gz
gentoo-2-b42f61ed0a2c5cda97caee4522bb4c9a7dd346e1.tar.bz2
gentoo-2-b42f61ed0a2c5cda97caee4522bb4c9a7dd346e1.zip
sys-apps/libselinux: new upstream bugfix release.
(Portage version: 2.1.4)
Diffstat (limited to 'sys-libs/libselinux')
-rw-r--r--sys-libs/libselinux/ChangeLog10
-rw-r--r--sys-libs/libselinux/files/digest-libselinux-1.34.143
-rw-r--r--sys-libs/libselinux/libselinux-1.34.14.ebuild58
3 files changed, 69 insertions, 2 deletions
diff --git a/sys-libs/libselinux/ChangeLog b/sys-libs/libselinux/ChangeLog
index 58420dbdb043..6a7efdd4b695 100644
--- a/sys-libs/libselinux/ChangeLog
+++ b/sys-libs/libselinux/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-libs/libselinux
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libselinux/ChangeLog,v 1.56 2007/10/18 19:17:25 pebenito Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libselinux/ChangeLog,v 1.57 2008/01/29 15:12:56 pebenito Exp $
+
+*libselinux-1.34.14 (29 Jan 2008)
+
+ 29 Jan 2008; Chris PeBenito <pebenito@gentoo.org>
+ +libselinux-1.34.14.ebuild:
+ New upstream bugfix release.
*libselinux-1.34.13 (18 Oct 2007)
diff --git a/sys-libs/libselinux/files/digest-libselinux-1.34.14 b/sys-libs/libselinux/files/digest-libselinux-1.34.14
new file mode 100644
index 000000000000..b7104d340fde
--- /dev/null
+++ b/sys-libs/libselinux/files/digest-libselinux-1.34.14
@@ -0,0 +1,3 @@
+MD5 91a74229be4e9a1cfc15ab03e5d5ce5a libselinux-1.34.14.tgz 135588
+RMD160 8d5556f83fca6a1aa725e36ad7f77546e7cf6be7 libselinux-1.34.14.tgz 135588
+SHA256 b515495bfe185b1e11c64b68e94a895141b98af59c6e7b2de36ec202fd911a91 libselinux-1.34.14.tgz 135588
diff --git a/sys-libs/libselinux/libselinux-1.34.14.ebuild b/sys-libs/libselinux/libselinux-1.34.14.ebuild
new file mode 100644
index 000000000000..b1c4081da1f9
--- /dev/null
+++ b/sys-libs/libselinux/libselinux-1.34.14.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libselinux/libselinux-1.34.14.ebuild,v 1.1 2008/01/29 15:12:56 pebenito Exp $
+
+IUSE=""
+
+inherit eutils multilib python
+
+#BUGFIX_PATCH="${FILESDIR}/libselinux-1.30.3.diff"
+
+SEPOL_VER="1.16"
+
+DESCRIPTION="SELinux userland library"
+HOMEPAGE="http://www.nsa.gov/selinux"
+SRC_URI="http://www.nsa.gov/selinux/archives/${P}.tgz"
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~mips ~ppc ~sparc ~x86"
+
+DEPEND="=sys-libs/libsepol-${SEPOL_VER}*
+ dev-lang/swig"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ [ ! -z "${BUGFIX_PATCH}" ] && epatch "${BUGFIX_PATCH}"
+
+ # fix up paths for multilib
+ sed -i -e "/^LIBDIR/s/lib/$(get_libdir)/" ${S}/src/Makefile \
+ || die "Fix for multilib LIBDIR failed."
+ sed -i -e "/^SHLIBDIR/s/lib/$(get_libdir)/" ${S}/src/Makefile \
+ || die "Fix for multilib SHLIBDIR failed."
+}
+
+src_compile() {
+ python_version
+ emake LDFLAGS="-fPIC ${LDFLAGS}" all || die
+ emake PYLIBVER="python${PYVER}" LDFLAGS="-fPIC ${LDFLAGS}" pywrap || die
+
+ # add compatability aliases to swig wrapper
+ cat ${FILESDIR}/compat.py >> ${S}/src/selinux.py || die
+}
+
+src_install() {
+ python_version
+ make DESTDIR="${D}" PYLIBVER="python${PYVER}" install install-pywrap || die
+}
+
+pkg_postinst() {
+ python_version
+ python_mod_optimize ${ROOT}usr/lib/python${PYVER}/site-packages
+}
+
+pkg_postrm() {
+ python_version
+ python_mod_cleanup ${ROOT}usr/lib/python${PYVER}/site-packages
+}