summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris PeBenito <pebenito@gentoo.org>2005-12-09 00:49:52 +0000
committerChris PeBenito <pebenito@gentoo.org>2005-12-09 00:49:52 +0000
commit516f2a45343d0284332f351014ab70ee73a94c8d (patch)
tree11d3a0d15a013cd19dbb9a3a18b15189530a7fb2 /sys-libs/libsemanage/libsemanage-1.4.ebuild
parentFix crash without ipod use flag enabled. Closes bug #114930. (diff)
downloadgentoo-2-516f2a45343d0284332f351014ab70ee73a94c8d.tar.gz
gentoo-2-516f2a45343d0284332f351014ab70ee73a94c8d.tar.bz2
gentoo-2-516f2a45343d0284332f351014ab70ee73a94c8d.zip
initial commit.
(Portage version: 2.0.53)
Diffstat (limited to 'sys-libs/libsemanage/libsemanage-1.4.ebuild')
-rw-r--r--sys-libs/libsemanage/libsemanage-1.4.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/sys-libs/libsemanage/libsemanage-1.4.ebuild b/sys-libs/libsemanage/libsemanage-1.4.ebuild
new file mode 100644
index 000000000000..9dc31c6f380a
--- /dev/null
+++ b/sys-libs/libsemanage/libsemanage-1.4.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libsemanage/libsemanage-1.4.ebuild,v 1.1 2005/12/09 00:49:52 pebenito Exp $
+
+IUSE=""
+
+SEPOL_VER="1.10"
+SELNX_VER="1.28"
+
+inherit eutils multilib
+
+DESCRIPTION="SELinux kernel and policy management library"
+HOMEPAGE="http://www.nsa.gov/selinux"
+SRC_URI="http://www.nsa.gov/selinux/archives/${P}.tgz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~amd64 ~mips"
+
+DEPEND=">=sys-libs/libsepol-${SEPOL_VER}
+ >=sys-libs/libselinux-${SELNX_VER}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # make portage CFLAGS work
+ sed -i -e "s:-Wall:-Wall ${CFLAGS}:g" ${S}/src/Makefile \
+ || die "src Makefile CFLAGS fix failed."
+
+ # fix up paths for multilib
+ sed -i -e "/^LIBDIR/s/lib/$(get_libdir)/" ${S}/src/Makefile \
+ || die "Fix for multilib LIBDIR failed."
+ sed -i -e "/^SHLIBDIR/s/lib/$(get_libdir)/" ${S}/src/Makefile \
+ || die "Fix for multilib SHLIBDIR failed."
+}
+
+src_compile() {
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install
+
+ # remove config file. the appropriate
+ # policy will install this file.
+ rm -fR ${D}/etc
+}