summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2007-05-25 16:30:12 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2007-05-25 16:30:12 +0000
commit8b909606d2e78348967c5a62c9ce2a76566ca46c (patch)
tree06b800056ad330430ab2c4c4fbd2e88b4a20c7e6 /sys-libs/libtrash
parentVersion bumped. (diff)
downloadgentoo-2-8b909606d2e78348967c5a62c9ce2a76566ca46c.tar.gz
gentoo-2-8b909606d2e78348967c5a62c9ce2a76566ca46c.tar.bz2
gentoo-2-8b909606d2e78348967c5a62c9ce2a76566ca46c.zip
Version bumped.
(Portage version: 2.1.2.7)
Diffstat (limited to 'sys-libs/libtrash')
-rw-r--r--sys-libs/libtrash/ChangeLog7
-rw-r--r--sys-libs/libtrash/files/digest-libtrash-2.83
-rw-r--r--sys-libs/libtrash/libtrash-2.8.ebuild67
3 files changed, 76 insertions, 1 deletions
diff --git a/sys-libs/libtrash/ChangeLog b/sys-libs/libtrash/ChangeLog
index d5a90f6e72c2..0736cd57b04f 100644
--- a/sys-libs/libtrash/ChangeLog
+++ b/sys-libs/libtrash/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/libtrash
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libtrash/ChangeLog,v 1.10 2007/05/14 06:21:53 bangert Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libtrash/ChangeLog,v 1.11 2007/05/25 16:30:12 matsuu Exp $
+
+*libtrash-2.8 (25 May 2007)
+
+ 25 May 2007; MATSUU Takuto <matsuu@gentoo.org> +libtrash-2.8.ebuild:
+ Version bumped.
14 May 2007; Thilo Bangert <bangert@gentoo.org> metadata.xml:
add <herd>no-herd</herd>
diff --git a/sys-libs/libtrash/files/digest-libtrash-2.8 b/sys-libs/libtrash/files/digest-libtrash-2.8
new file mode 100644
index 000000000000..46a9d8094d3d
--- /dev/null
+++ b/sys-libs/libtrash/files/digest-libtrash-2.8
@@ -0,0 +1,3 @@
+MD5 6a88ee49f47610005befc8ce28d3985f libtrash-2.8.tgz 95336
+RMD160 4026d9a4873eb0a36d23526706336f95c3e1efb9 libtrash-2.8.tgz 95336
+SHA256 6303507f163f424bb64e40af78f8221456bc5caf7da766dbc7c03141819014e5 libtrash-2.8.tgz 95336
diff --git a/sys-libs/libtrash/libtrash-2.8.ebuild b/sys-libs/libtrash/libtrash-2.8.ebuild
new file mode 100644
index 000000000000..f4e0b0760b70
--- /dev/null
+++ b/sys-libs/libtrash/libtrash-2.8.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libtrash/libtrash-2.8.ebuild,v 1.1 2007/05/25 16:30:12 matsuu Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="provides a trash can by intercepting certain calls to glibc"
+HOMEPAGE="http://pages.stern.nyu.edu/~marriaga/software/libtrash/"
+SRC_URI="http://pages.stern.nyu.edu/~marriaga/software/libtrash/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="virtual/libc
+ dev-lang/perl"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-2.4-gentoo.patch
+ sed -i \
+ -e "/^INSTLIBDIR/s/lib/$(get_libdir)/" \
+ -e "/^CFLAGS/s/$/ ${CFLAGS}/" \
+ ${S}/src/Makefile || die
+
+ # now let's unpack strash too in cash anyone is interested
+ cd cleanTrash
+ tar -zxf ./strash-0.9.tar.gz
+}
+
+src_compile() {
+ make CC="$(tc-getCC)" || die "Error Making Source...Exiting"
+}
+
+src_install() {
+ dodir /etc /usr/$(get_libdir)
+ make DESTDIR="${D}" install || die "Error Installing ${P}...Exiting"
+
+ dosbin cleanTrash/ct2.pl
+ exeinto /etc/cron.daily
+ doexe "${FILESDIR}"/cleanTrash.cron
+
+ dodoc CHANGE.LOG README libtrash.conf TODO config.txt
+
+ docinto cleanTrash
+ dodoc cleanTrash/README cleanTrash/cleanTrash
+
+ # new strash installation stuff
+ dosbin cleanTrash/strash-0.9/strash
+ docinto strash
+ dodoc cleanTrash/strash-0.9/README
+ doman cleanTrash/strash-0.9/strash.8
+}
+
+pkg_postinst() {
+ einfo
+ einfo "To use this you have to put the trash library as one"
+ einfo "of the variables in LD_PRELOAD."
+ einfo "Example in bash:"
+ einfo "export LD_PRELOAD=/usr/$(get_libdir)/libtrash.so"
+ einfo
+ einfo "Also, see /etc/cron.daily/cleanTrash.cron if you'd like to turn on"
+ einfo "daily trash cleanup."
+ einfo
+}