summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2011-08-28 14:17:43 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2011-08-28 14:17:43 +0000
commitc6c48dee8cd496dbb2228b416f8f736c00919176 (patch)
treeccfdabed568296e3c04e67df31e935412f0037fe /sys-libs/libunwind
parentAdd ~x86-fbsd, bug #379449 (diff)
downloadgentoo-2-c6c48dee8cd496dbb2228b416f8f736c00919176.tar.gz
gentoo-2-c6c48dee8cd496dbb2228b416f8f736c00919176.tar.bz2
gentoo-2-c6c48dee8cd496dbb2228b416f8f736c00919176.zip
Version bump; port disable-setjmp patch (and simplify); add debug USE flag.
(Portage version: 2.2.0_alpha51/cvs/Linux x86_64)
Diffstat (limited to 'sys-libs/libunwind')
-rw-r--r--sys-libs/libunwind/ChangeLog8
-rw-r--r--sys-libs/libunwind/files/libunwind-1.0-disable-setjmp.patch42
-rw-r--r--sys-libs/libunwind/libunwind-1.0.ebuild49
3 files changed, 98 insertions, 1 deletions
diff --git a/sys-libs/libunwind/ChangeLog b/sys-libs/libunwind/ChangeLog
index 6af0a679f72b..ce2793a8bf6a 100644
--- a/sys-libs/libunwind/ChangeLog
+++ b/sys-libs/libunwind/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-libs/libunwind
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libunwind/ChangeLog,v 1.14 2011/08/04 14:01:47 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libunwind/ChangeLog,v 1.15 2011/08/28 14:17:43 flameeyes Exp $
+
+*libunwind-1.0 (28 Aug 2011)
+
+ 28 Aug 2011; Diego E. Pettenò <flameeyes@gentoo.org> +libunwind-1.0.ebuild,
+ +files/libunwind-1.0-disable-setjmp.patch:
+ Version bump; port disable-setjmp patch (and simplify); add debug USE flag.
04 Aug 2011; Samuli Suominen <ssuominen@gentoo.org> libunwind-0.99-r1.ebuild:
USE="static-libs" and remove unnecessary libtool files
diff --git a/sys-libs/libunwind/files/libunwind-1.0-disable-setjmp.patch b/sys-libs/libunwind/files/libunwind-1.0-disable-setjmp.patch
new file mode 100644
index 000000000000..6b83dbbd780a
--- /dev/null
+++ b/sys-libs/libunwind/files/libunwind-1.0-disable-setjmp.patch
@@ -0,0 +1,42 @@
+http://cvs.fedoraproject.org/viewvc/rpms/libunwind/devel/libunwind-disable-setjmp.patch?revision=1.1&view=markup
+http://bugs.gentoo.org/show_bug.cgi?id=299344
+
+At least x86_64 version cannot work, src/setjmp/setjmp.c and
+src/setjmp/sigsetjmp.c are not even compiled, src/x86_64/longjmp.S does not
+match src/setjmp/setjmp.c + include/tdep-x86_64/jmpbuf.h .
+
+Index: libunwind-1.0/src/Makefile.am
+===================================================================
+--- libunwind-1.0.orig/src/Makefile.am
++++ libunwind-1.0/src/Makefile.am
+@@ -9,7 +9,7 @@ lib_LIBRARIES =
+ lib_LTLIBRARIES =
+ if !REMOTE_ONLY
+ lib_LIBRARIES += libunwind-ptrace.a
+-lib_LTLIBRARIES += libunwind.la libunwind-setjmp.la
++lib_LTLIBRARIES += libunwind.la #libunwind-setjmp.la
+ endif
+
+ noinst_HEADERS =
+Index: libunwind-1.0/tests/Makefile.am
+===================================================================
+--- libunwind-1.0.orig/tests/Makefile.am
++++ libunwind-1.0/tests/Makefile.am
+@@ -27,7 +27,7 @@ if ARCH_IA64
+ Gia64-test-nat Lia64-test-nat \
+ Gia64-test-rbs Lia64-test-rbs \
+ Gia64-test-readonly Lia64-test-readonly \
+- ia64-test-setjmp ia64-test-sig
++ ia64-test-sig
+ else
+ if ARCH_PPC64
+ if USE_ALTIVEC
+@@ -44,7 +44,7 @@ endif #ARCH_IA64
+ Gtest-dyn1 Ltest-dyn1 \
+ Gtest-trace Ltest-trace \
+ test-async-sig test-flush-cache test-init-remote \
+- test-mem test-setjmp test-ptrace \
++ test-mem test-ptrace \
+ Ltest-nomalloc Ltest-nocalloc rs-race
+ noinst_PROGRAMS_cdep = forker mapper test-ptrace-misc \
+ Gperf-simple Lperf-simple
diff --git a/sys-libs/libunwind/libunwind-1.0.ebuild b/sys-libs/libunwind/libunwind-1.0.ebuild
new file mode 100644
index 000000000000..bc432dd2a9f3
--- /dev/null
+++ b/sys-libs/libunwind/libunwind-1.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libunwind/libunwind-1.0.ebuild,v 1.1 2011/08/28 14:17:43 flameeyes Exp $
+
+EAPI=4
+inherit autotools eutils
+
+DESCRIPTION="Portable and efficient API to determine the call-chain of a program"
+HOMEPAGE="http://savannah.nongnu.org/projects/libunwind"
+SRC_URI="http://download.savannah.nongnu.org/releases/libunwind/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="7"
+KEYWORDS="~amd64 ~ia64 ~x86"
+IUSE="static-libs debug"
+
+RESTRICT="test" # https://savannah.nongnu.org/bugs/?22368
+ # https://bugs.gentoo.org/273372
+
+DOCS=( AUTHORS ChangeLog NEWS README TODO )
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-disable-setjmp.patch
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=
+
+ # do not $(use_enable) because the configure.in is broken and parses
+ # --disable-debug the same as --enable-debug.
+ use debug && myconf+=" --enable-debug"
+
+ econf $(use_enable static-libs static) \
+ ${myconf}
+}
+
+src_test() {
+ # explicitly allow parallel build of tests
+ emake check
+}
+
+src_install() {
+ default
+ # libunwind-ptrace.a (and libunwind-ptrace.h) is separate API and without
+ # shared library, so we keep it in any case
+ use static-libs || rm -f "${D}"usr/lib*/libunwind{-generic.a,*.la}
+}