summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-12-17 03:43:40 +0000
committerMike Frysinger <vapier@gentoo.org>2005-12-17 03:43:40 +0000
commit0fcd34fab9270490a2a1f41f6e975bc63a2c1301 (patch)
tree6328837b02b08efceb7f9b71e6d1092964882845 /sys-libs/pwdb
parenttouchup patch (diff)
downloadgentoo-2-0fcd34fab9270490a2a1f41f6e975bc63a2c1301.tar.gz
gentoo-2-0fcd34fab9270490a2a1f41f6e975bc63a2c1301.tar.bz2
gentoo-2-0fcd34fab9270490a2a1f41f6e975bc63a2c1301.zip
fix install target so we dont need preplib
(Portage version: 2.0.53)
Diffstat (limited to 'sys-libs/pwdb')
-rw-r--r--sys-libs/pwdb/files/pwdb-0.62-build.patch11
-rw-r--r--sys-libs/pwdb/pwdb-0.62.ebuild21
2 files changed, 20 insertions, 12 deletions
diff --git a/sys-libs/pwdb/files/pwdb-0.62-build.patch b/sys-libs/pwdb/files/pwdb-0.62-build.patch
new file mode 100644
index 000000000000..4ed83a380ca9
--- /dev/null
+++ b/sys-libs/pwdb/files/pwdb-0.62-build.patch
@@ -0,0 +1,11 @@
+--- libpwdb/Makefile
++++ libpwdb/Makefile
+@@ -69,7 +69,7 @@
+ $(INSTALL) -m 644 radius.h $(INCLUDED)/radius.h
+ $(INSTALL) -m 644 _pwdb_macros.h $(INCLUDED)/_pwdb_macros.h
+ $(INSTALL) -m 755 $(LIBFILENAME) $(LIBDIR)
+- $(LDCONFIG)
++ ln -sf $(LIBFILENAME) $(LIBDIR)/$(LIBSONAME)
+ ln -sf $(LIBFILENAME) $(LIBDIR)/$(LIBDYNAME)
+ $(INSTALL) -m 644 $(LIBSTATIC) $(LIBDIR)
+
diff --git a/sys-libs/pwdb/pwdb-0.62.ebuild b/sys-libs/pwdb/pwdb-0.62.ebuild
index 25973cd01f67..965a8b4b44f5 100644
--- a/sys-libs/pwdb/pwdb-0.62.ebuild
+++ b/sys-libs/pwdb/pwdb-0.62.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/pwdb/pwdb-0.62.ebuild,v 1.21 2005/10/08 12:50:35 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/pwdb/pwdb-0.62.ebuild,v 1.22 2005/12/17 03:43:40 vapier Exp $
inherit eutils flag-o-matic
@@ -13,17 +13,17 @@ SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 s390 sh sparc x86"
IUSE="selinux"
-DEPEND="virtual/libc
- selinux? ( sys-libs/libselinux )"
+DEPEND="selinux? ( sys-libs/libselinux )"
src_unpack () {
unpack ${A}
- cd ${S}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-build.patch
# Uses gcc as linker needed for hppa, but good idea in general.
- epatch ${FILESDIR}/${P}-use-gcc-as-linker.patch
+ epatch "${FILESDIR}"/${P}-use-gcc-as-linker.patch
- use selinux && epatch ${FILESDIR}/${P}-selinux.patch
+ use selinux && epatch "${FILESDIR}"/${P}-selinux.patch
sed -i \
-e "s/^DIRS = .*/DIRS = libpwdb/" \
@@ -46,15 +46,12 @@ src_compile() {
src_install() {
dodir /$(get_libdir) /usr/$(get_libdir) /usr/include/pwdb
make \
- INCLUDED=${D}/usr/include/pwdb \
- LIBDIR=${D}/$(get_libdir) \
+ INCLUDED="${D}"/usr/include/pwdb \
+ LIBDIR="${D}"/$(get_libdir) \
LDCONFIG="echo" \
install || die
- preplib /
- mv ${D}/$(get_libdir)/*.a ${D}/usr/$(get_libdir)
-
- # See bug #4411 for more info
+ mv "${D}"/$(get_libdir)/*.a "${D}"/usr/$(get_libdir)/ || die
gen_usr_ldscript libpwdb.so
insinto /etc