summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Duft <mduft@gentoo.org>2011-05-09 08:30:52 +0000
committerMarkus Duft <mduft@gentoo.org>2011-05-09 08:30:52 +0000
commit975bd70b219ba407bdf526d4226f4b64a3a71fe2 (patch)
treeb8ed377d7ef1fa7b56a4de0c1b347bbbbbc11df1 /sys-libs/suacomp
parentx86 stable per bug 354033 (diff)
downloadgentoo-2-975bd70b219ba407bdf526d4226f4b64a3a71fe2.tar.gz
gentoo-2-975bd70b219ba407bdf526d4226f4b64a3a71fe2.tar.bz2
gentoo-2-975bd70b219ba407bdf526d4226f4b64a3a71fe2.zip
new suacomp 0.6.7
(Portage version: 2.2.00.15754-prefix/cvs/Interix x86)
Diffstat (limited to 'sys-libs/suacomp')
-rw-r--r--sys-libs/suacomp/suacomp-0.6.7.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/sys-libs/suacomp/suacomp-0.6.7.ebuild b/sys-libs/suacomp/suacomp-0.6.7.ebuild
new file mode 100644
index 000000000000..655d9c997417
--- /dev/null
+++ b/sys-libs/suacomp/suacomp-0.6.7.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/suacomp/suacomp-0.6.7.ebuild,v 1.1 2011/05/09 08:30:52 mduft Exp $
+
+EAPI=3
+
+inherit toolchain-funcs
+
+DESCRIPTION="library wrapping the interix lib-c to make it less buggy."
+HOMEPAGE="http://suacomp.sf.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="BEER-WARE"
+SLOT="0"
+KEYWORDS="-* ~x86-interix"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+get_opts() {
+ local shlibc=
+ local stlibc=
+
+ for dir in /usr/lib /usr/lib/x86; do
+ [[ -f ${dir}/libc.a ]] && stlibc=${dir}/libc.a
+
+ for name in libc.so.5.2 libc.so.3.5; do
+ [[ -f ${dir}/${name} ]] && { shlibc=${dir}/${name}; break; }
+ done
+
+ [[ -f ${shlibc} && -f ${stlibc} ]] && break
+ done
+
+ echo "SHARED_LIBC=${shlibc} STATIC_LIBC=${stlibc}"
+}
+
+src_compile() {
+ local mycflags=
+ [[ ${CHOST} == *-interix3* ]] && mycflags="-DINTERIX3"
+
+ emake all CC=$(tc-getCC) CFLAGS="${CFLAGS} ${mycflags}" $(get_opts) || die "emake failed"
+}
+
+src_install() {
+ emake install PREFIX="${EPREFIX}/usr" DESTDIR="${D}" $(get_opts) || die "emake install failed"
+}
+
+src_test() {
+ emake check $(get_opts) || die "emake check failed"
+}