summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2007-07-14 23:51:47 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2007-07-14 23:51:47 +0000
commit1b6206d52d2b1623767eeb28b6ebf0622305d7f9 (patch)
tree785e530fc338df05fbd8db8a9826114efeb2b486 /sys-libs/system-config-base
parentdigest fix (diff)
downloadgentoo-2-1b6206d52d2b1623767eeb28b6ebf0622305d7f9.tar.gz
gentoo-2-1b6206d52d2b1623767eeb28b6ebf0622305d7f9.tar.bz2
gentoo-2-1b6206d52d2b1623767eeb28b6ebf0622305d7f9.zip
Bump for compat with new pam. Stop using pam_timestamp.
(Portage version: 2.1.3_rc8)
Diffstat (limited to 'sys-libs/system-config-base')
-rw-r--r--sys-libs/system-config-base/ChangeLog10
-rw-r--r--sys-libs/system-config-base/files/1-r1-pam-0.99.8.0-r2-compat.patch11
-rw-r--r--sys-libs/system-config-base/files/digest-system-config-base-1-r10
-rw-r--r--sys-libs/system-config-base/system-config-base-1-r1.ebuild40
4 files changed, 59 insertions, 2 deletions
diff --git a/sys-libs/system-config-base/ChangeLog b/sys-libs/system-config-base/ChangeLog
index 41c237b7c06a..58906621c675 100644
--- a/sys-libs/system-config-base/ChangeLog
+++ b/sys-libs/system-config-base/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-libs/system-config-base
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/system-config-base/ChangeLog,v 1.2 2006/09/06 19:47:21 flameeyes Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/system-config-base/ChangeLog,v 1.3 2007/07/14 23:51:47 dberkholz Exp $
+
+*system-config-base-1-r1 (14 Jul 2007)
+
+ 14 Jul 2007; Donnie Berkholz <dberkholz@gentoo.org>;
+ +files/1-r1-pam-0.99.8.0-r2-compat.patch, +system-config-base-1-r1.ebuild:
+ Bump for compat with new pam. Stop using pam_timestamp.
06 Sep 2006; Diego Pettenò <flameeyes@gentoo.org>
system-config-base-1.ebuild:
diff --git a/sys-libs/system-config-base/files/1-r1-pam-0.99.8.0-r2-compat.patch b/sys-libs/system-config-base/files/1-r1-pam-0.99.8.0-r2-compat.patch
new file mode 100644
index 000000000000..821bc7e29f5e
--- /dev/null
+++ b/sys-libs/system-config-base/files/1-r1-pam-0.99.8.0-r2-compat.patch
@@ -0,0 +1,11 @@
+--- config-util.orig 2007-07-14 12:56:13.000000000 -0700
++++ config-util 2007-07-14 12:56:18.000000000 -0700
+@@ -1,8 +1,6 @@
+ #%PAM-1.0
+ auth sufficient pam_rootok.so
+-auth sufficient pam_timestamp.so
+ auth include system-auth
+ account required pam_permit.so
+ session required pam_permit.so
+ session optional pam_xauth.so
+-session optional pam_timestamp.so
diff --git a/sys-libs/system-config-base/files/digest-system-config-base-1-r1 b/sys-libs/system-config-base/files/digest-system-config-base-1-r1
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/sys-libs/system-config-base/files/digest-system-config-base-1-r1
diff --git a/sys-libs/system-config-base/system-config-base-1-r1.ebuild b/sys-libs/system-config-base/system-config-base-1-r1.ebuild
new file mode 100644
index 000000000000..2a90f3344a92
--- /dev/null
+++ b/sys-libs/system-config-base/system-config-base-1-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/system-config-base/system-config-base-1-r1.ebuild,v 1.1 2007/07/14 23:51:47 dberkholz Exp $
+
+inherit eutils pam
+
+DESCRIPTION="system-config-* layout package"
+SRC_URI=""
+HOMEPAGE="http://www.gentoo.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+IUSE=""
+
+RDEPEND="virtual/pam"
+
+S=${WORKDIR}
+
+src_unpack() {
+ cp ${FILESDIR}/config-util . || die "failed to copy config-util"
+ epatch ${FILESDIR}/${PVR}-pam-0.99.8.0-r2-compat.patch
+}
+
+src_install() {
+ dopamd config-util
+}
+
+pkg_postinst() {
+ if [ "$(stat -c%a ${ROOT}etc/default/useradd)" != "644" ] ; then
+ echo
+ ewarn
+ ewarn "Your ${ROOT}etc/default/useradd file must be world-readable"
+ ewarn " for the system-config-* utilities to work properly."
+ ewarn " If you did not change them on purpose, consider running:"
+ ewarn
+ echo -e "\tchmod 0644 ${ROOT}etc/default/useradd"
+ echo
+ fi
+}