summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-06-13 03:07:04 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-06-13 03:07:04 +0000
commit5203446dd894ba3af011540e68278d917e740b8c (patch)
tree76dca1c0c591d8939eb101eec9674ea5facb1a7b /sys-libs/tdb/tdb-1.2.12.ebuild
parentBump (diff)
downloadgentoo-2-5203446dd894ba3af011540e68278d917e740b8c.tar.gz
gentoo-2-5203446dd894ba3af011540e68278d917e740b8c.tar.bz2
gentoo-2-5203446dd894ba3af011540e68278d917e740b8c.zip
Bump
(Portage version: 2.2.0_alpha179/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'sys-libs/tdb/tdb-1.2.12.ebuild')
-rw-r--r--sys-libs/tdb/tdb-1.2.12.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/sys-libs/tdb/tdb-1.2.12.ebuild b/sys-libs/tdb/tdb-1.2.12.ebuild
new file mode 100644
index 000000000000..0439225ef2ec
--- /dev/null
+++ b/sys-libs/tdb/tdb-1.2.12.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/tdb/tdb-1.2.12.ebuild,v 1.1 2013/06/13 03:07:04 patrick Exp $
+
+EAPI=3
+PYTHON_DEPEND="python? 2"
+RESTRICT_PYTHON_ABIS="3.* *-jython 2.7-pypy-*"
+
+inherit waf-utils python
+
+DESCRIPTION="A simple database API"
+HOMEPAGE="http://tdb.samba.org/"
+SRC_URI="http://samba.org/ftp/tdb/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux"
+IUSE="python"
+
+RDEPEND=""
+DEPEND="|| ( dev-lang/python:2.7 dev-lang/python:2.6 )
+ app-text/docbook-xml-dtd:4.2"
+
+WAF_BINARY="${S}/buildtools/bin/waf"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_configure() {
+ local extra_opts=""
+ use python || extra_opts+=" --disable-python"
+ waf-utils_src_configure \
+ ${extra_opts}
+}
+
+src_test() {
+ # the default src_test runs 'make test' and 'make check', letting
+ # the tests fail occasionally (reason: unknown)
+ emake check || die "emake check failed"
+}