summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2012-02-12 12:28:08 +0000
committerMaxim Koltsov <maksbotan@gentoo.org>2012-02-12 12:28:08 +0000
commit98ad670e0678883c5d9d7e69dff3c442d434bbf8 (patch)
tree86b75ff6050c3d2545ee4e712c6f424f12e78379 /sys-libs/tevent
parentVersion bump hg-git to 0.3.2, remove old versions. (diff)
downloadgentoo-2-98ad670e0678883c5d9d7e69dff3c442d434bbf8.tar.gz
gentoo-2-98ad670e0678883c5d9d7e69dff3c442d434bbf8.tar.bz2
gentoo-2-98ad670e0678883c5d9d7e69dff3c442d434bbf8.zip
Add patches to 0.9.14, fix bug 403239. Thanks to slepnoga
(Portage version: 2.1.10.44/cvs/Linux x86_64)
Diffstat (limited to 'sys-libs/tevent')
-rw-r--r--sys-libs/tevent/ChangeLog9
-rw-r--r--sys-libs/tevent/files/add-py-file-0.9.14.patch32
-rw-r--r--sys-libs/tevent/files/tevent-version.patch27
-rw-r--r--sys-libs/tevent/tevent-0.9.14-r1.ebuild (renamed from sys-libs/tevent/tevent-0.9.14.ebuild)22
4 files changed, 86 insertions, 4 deletions
diff --git a/sys-libs/tevent/ChangeLog b/sys-libs/tevent/ChangeLog
index 7115c8b8a279..932b80fc9d39 100644
--- a/sys-libs/tevent/ChangeLog
+++ b/sys-libs/tevent/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-libs/tevent
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/tevent/ChangeLog,v 1.10 2012/02/12 11:43:28 maksbotan Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/tevent/ChangeLog,v 1.11 2012/02/12 12:28:08 maksbotan Exp $
+
+*tevent-0.9.14-r1 (12 Feb 2012)
+
+ 12 Feb 2012; Maxim Koltsov <maksbotan@gentoo.org>
+ +files/add-py-file-0.9.14.patch, +files/tevent-version.patch,
+ +tevent-0.9.14-r1.ebuild, -tevent-0.9.14.ebuild:
+ Add patches to 0.9.14, fix bug 403239. Thanks to slepnoga
*tevent-0.9.15 (12 Feb 2012)
diff --git a/sys-libs/tevent/files/add-py-file-0.9.14.patch b/sys-libs/tevent/files/add-py-file-0.9.14.patch
new file mode 100644
index 000000000000..32708160ea36
--- /dev/null
+++ b/sys-libs/tevent/files/add-py-file-0.9.14.patch
@@ -0,0 +1,32 @@
+--- /dev/null
++++ /tevent.py
+@@ -0,0 +1,29 @@
++#!/usr/bin/python
++#
++# Python integration for tevent
++#
++# Copyright (C) Jelmer Vernooij 2011
++#
++# ** NOTE! The following LGPL license applies to the tevent
++# ** library. This does NOT imply that all of Samba is released
++# ** under the LGPL
++#
++# This library is free software; you can redistribute it and/or
++# modify it under the terms of the GNU Lesser General Public
++# License as published by the Free Software Foundation; either
++# version 3 of the License, or (at your option) any later version.
++#
++# This library is distributed in the hope that it will be useful,
++# but WITHOUT ANY WARRANTY; without even the implied warranty of
++# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
++# Lesser General Public License for more details.
++#
++# You should have received a copy of the GNU Lesser General Public
++# License along with this library; if not, see <http://www.gnu.org/licenses/>.
++
++from _tevent import (
++ __version__,
++ backend_list,
++ Context,
++ Signal,
++ )
diff --git a/sys-libs/tevent/files/tevent-version.patch b/sys-libs/tevent/files/tevent-version.patch
new file mode 100644
index 000000000000..2042ec58add1
--- /dev/null
+++ b/sys-libs/tevent/files/tevent-version.patch
@@ -0,0 +1,27 @@
+--- a/pytevent.c
++++ b/pytevent.c
+@@ -761,4 +761,6 @@ void init_tevent(void)
+
+ Py_INCREF(&TeventFd_Type);
+ PyModule_AddObject(m, "Fd", (PyObject *)&TeventFd_Type);
++
++ PyModule_AddObject(m, "__version__", PyString_FromString(PACKAGE_VERSION));
+ }
+--- a/wscript
++++ b/wscript
+@@ -92,7 +92,14 @@
+ 'pytevent.c',
+ deps='tevent',
+ enabled=True,
+- realname='_tevent.so')
++ realname='_tevent.so',
++ cflags='-DPACKAGE_VERSION=\"%s\"' % VERSION)
++ # install out various python scripts for use by make test
++ bld.SAMBA_SCRIPT('tevent_python',
++ pattern='tevent.py',
++ installdir='python')
++
++ bld.INSTALL_WILDCARD('${PYTHONDIR}', 'tevent.py', flat=False)
+
+
+ def test(ctx):
diff --git a/sys-libs/tevent/tevent-0.9.14.ebuild b/sys-libs/tevent/tevent-0.9.14-r1.ebuild
index ff67e5ca6de5..5ff20d03bad8 100644
--- a/sys-libs/tevent/tevent-0.9.14.ebuild
+++ b/sys-libs/tevent/tevent-0.9.14-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/tevent/tevent-0.9.14.ebuild,v 1.2 2011/10/31 16:02:11 vostorga Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/tevent/tevent-0.9.14-r1.ebuild,v 1.1 2012/02/12 12:28:08 maksbotan Exp $
-EAPI=3
+EAPI=4
PYTHON_DEPEND="2"
inherit waf-utils python
@@ -22,9 +22,25 @@ RDEPEND=">=dev-lang/python-2.4.2
DEPEND="${RDEPEND}
dev-util/pkgconfig"
+PATCHES=( "${FILESDIR}"/add-py-file-${PV}.patch
+ "${FILESDIR}"/tevent-version.patch )
WAF_BINARY="${S}/buildtools/bin/waf"
pkg_setup() {
python_set_active_version 2
python_pkg_setup
}
+
+src_install() {
+ waf-utils_src_install
+ insinto $(python_get_sitedir)
+ doins tevent.py
+}
+
+pkg_postinst() {
+ python_mod_optimize tevent.py
+}
+
+pkg_postrm() {
+ python_mod_cleanup tevent.py
+}