summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-03-13 22:14:01 +0000
committerMike Frysinger <vapier@gentoo.org>2007-03-13 22:14:01 +0000
commita6edd0db6732a4fc050bc0076d5a6f2c84bf04b1 (patch)
tree9e53985a062c0b6eab1e7ffbcd75d8285ad36ebe /sys-libs/timezone-data
parentold (diff)
downloadgentoo-2-a6edd0db6732a4fc050bc0076d5a6f2c84bf04b1.tar.gz
gentoo-2-a6edd0db6732a4fc050bc0076d5a6f2c84bf04b1.tar.bz2
gentoo-2-a6edd0db6732a4fc050bc0076d5a6f2c84bf04b1.zip
Respect TIMEZONE="" and switch to elog.
(Portage version: 2.1.2.2)
Diffstat (limited to 'sys-libs/timezone-data')
-rw-r--r--sys-libs/timezone-data/ChangeLog6
-rw-r--r--sys-libs/timezone-data/timezone-data-2007c.ebuild17
2 files changed, 15 insertions, 8 deletions
diff --git a/sys-libs/timezone-data/ChangeLog b/sys-libs/timezone-data/ChangeLog
index 9e31bcb18b6b..faad7c4c195c 100644
--- a/sys-libs/timezone-data/ChangeLog
+++ b/sys-libs/timezone-data/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-libs/timezone-data
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/timezone-data/ChangeLog,v 1.67 2007/03/08 17:55:42 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/timezone-data/ChangeLog,v 1.68 2007/03/13 22:14:01 vapier Exp $
+
+ 13 Mar 2007; Mike Frysinger <vapier@gentoo.org>
+ timezone-data-2007c.ebuild:
+ Respect TIMEZONE="" and switch to elog.
08 Mar 2007; Tobias Scherbaum <dertobi123@gentoo.org>
timezone-data-2007c.ebuild:
diff --git a/sys-libs/timezone-data/timezone-data-2007c.ebuild b/sys-libs/timezone-data/timezone-data-2007c.ebuild
index 327c221c38cb..202f0bd5c606 100644
--- a/sys-libs/timezone-data/timezone-data-2007c.ebuild
+++ b/sys-libs/timezone-data/timezone-data-2007c.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/timezone-data/timezone-data-2007c.ebuild,v 1.9 2007/03/10 23:30:53 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/timezone-data/timezone-data-2007c.ebuild,v 1.10 2007/03/13 22:14:01 vapier Exp $
inherit eutils toolchain-funcs flag-o-matic
@@ -52,19 +52,22 @@ src_install() {
pkg_config() {
# make sure the /etc/localtime file does not get stale #127899
- local tz=$(source "${ROOT}"/etc/conf.d/clock ; echo ${TIMEZONE})
- if [[ -z ${tz} ]] ; then
+ local tz=$(unset TIMEZONE ; source "${ROOT}"/etc/conf.d/clock ; echo ${TIMEZONE-FOOKABLOIE})
+ [[ -z ${tz} ]] && return 0
+ if [[ ${tz} == "FOOKABLOIE" ]] ; then
+ elog "You do not have TIMEZONE set in /etc/conf.d/clock."
if [[ ! -e ${ROOT}/etc/localtime ]] ; then
cp -f "${ROOT}"/usr/share/zoneinfo/Factory "${ROOT}"/etc/localtime
+ elog "Setting /etc/localtime to Factory."
+ else
+ elog "Skipping auto-update of /etc/localtime."
fi
- ewarn "You do not have TIMEZONE set in /etc/conf.d/clock."
- ewarn "Skipping auto-update of /etc/localtime."
return 0
fi
if [[ ! -e ${ROOT}/usr/share/zoneinfo/${tz} ]] ; then
- eerror "You have an invalid TIMEZONE setting in /etc/conf.d/clock."
- eerror "Your /etc/localtime has been reset to Factory; enjoy!"
+ elog "You have an invalid TIMEZONE setting in /etc/conf.d/clock."
+ elog "Your /etc/localtime has been reset to Factory; enjoy!"
tz="Factory"
fi
einfo "Updating /etc/localtime with /usr/share/zoneinfo/${tz}"