summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-07-08 04:28:06 +0000
committerMike Frysinger <vapier@gentoo.org>2010-07-08 04:28:06 +0000
commit2337197d7e68a83d837e2788b9509347cf214e37 (patch)
treedc9cfffbaef533665f765b30a36c3ff5d1b396b7 /sys-libs/zlib
parentRDEPEND on virtual/cron and virtual/mailx thanks to p0 (bug #301707). (diff)
downloadgentoo-2-2337197d7e68a83d837e2788b9509347cf214e37.tar.gz
gentoo-2-2337197d7e68a83d837e2788b9509347cf214e37.tar.bz2
gentoo-2-2337197d7e68a83d837e2788b9509347cf214e37.zip
Update by Alon Bar-Lev for mingw support #310307 by Nathan Phillip Brink.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sys-libs/zlib')
-rw-r--r--sys-libs/zlib/ChangeLog5
-rw-r--r--sys-libs/zlib/zlib-1.2.5-r2.ebuild36
2 files changed, 30 insertions, 11 deletions
diff --git a/sys-libs/zlib/ChangeLog b/sys-libs/zlib/ChangeLog
index 9a55405b49de..6ee43ebdb9d5 100644
--- a/sys-libs/zlib/ChangeLog
+++ b/sys-libs/zlib/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-libs/zlib
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/zlib/ChangeLog,v 1.82 2010/07/07 21:24:14 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/zlib/ChangeLog,v 1.83 2010/07/08 04:28:06 vapier Exp $
+
+ 08 Jul 2010; Mike Frysinger <vapier@gentoo.org> zlib-1.2.5-r2.ebuild:
+ Update by Alon Bar-Lev for mingw support #310307 by Nathan Phillip Brink.
07 Jul 2010; Mike Frysinger <vapier@gentoo.org> zlib-1.2.5-r2.ebuild,
files/zlib-1.2.5-fbsd_chosts.patch, +files/zlib-1.2.5-ldflags.patch,
diff --git a/sys-libs/zlib/zlib-1.2.5-r2.ebuild b/sys-libs/zlib/zlib-1.2.5-r2.ebuild
index 467396873b1e..1c0674677b87 100644
--- a/sys-libs/zlib/zlib-1.2.5-r2.ebuild
+++ b/sys-libs/zlib/zlib-1.2.5-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/zlib/zlib-1.2.5-r2.ebuild,v 1.3 2010/07/07 21:24:14 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/zlib/zlib-1.2.5-r2.ebuild,v 1.4 2010/07/08 04:28:06 vapier Exp $
inherit eutils toolchain-funcs
@@ -19,7 +19,6 @@ RDEPEND="!<dev-libs/libxml2-2.7.7" #309623
src_unpack() {
unpack ${A}
cd "${S}"
- epatch "${FILESDIR}"/${PN}-1.2.3-mingw-implib.patch #288212
# trust exit status of the compiler rather than stderr #55434
# -if test "`(...) 2>&1`" = ""; then
# +if (...) 2>/dev/null; then
@@ -33,9 +32,17 @@ src_unpack() {
src_compile() {
case ${CHOST} in
*-mingw*|mingw*)
- emake -f win32/Makefile.gcc prefix=/usr STRIP= PREFIX=${CHOST}- || die
+ emake -f win32/Makefile.gcc STRIP=true PREFIX=${CHOST}- || die
+ sed \
+ -e 's|@prefix@|/usr|g' \
+ -e 's|@exec_prefix@|${prefix}|g' \
+ -e 's|@libdir@|${exec_prefix}/'$(get_libdir)'|g' \
+ -e 's|@sharedlibdir@|${exec_prefix}/'$(get_libdir)'|g' \
+ -e 's|@includedir@|${prefix}/include|g' \
+ -e 's|@VERSION@|'${PV}'|g' \
+ zlib.pc.in > zlib.pc || die
;;
- *) # not an autoconf script, so cant use econf
+ *) # not an autoconf script, so can't use econf
./configure --shared --prefix=/usr --libdir=/usr/$(get_libdir) || die
emake || die
;;
@@ -43,14 +50,23 @@ src_compile() {
}
src_install() {
- emake install DESTDIR="${D}" LDCONFIG=: || die
- dodoc FAQ README ChangeLog doc/*.txt
-
case ${CHOST} in
*-mingw*|mingw*)
- dobin zlib1.dll || die
- dolib libz.dll.a || die
+ emake -f win32/Makefile.gcc install \
+ BINARY_PATH="${D}/usr/bin" \
+ LIBRARY_PATH="${D}/usr/$(get_libdir)" \
+ INCLUDE_PATH="${D}/usr/include" \
+ SHARED_MODE=1 \
+ || die
+ insinto /usr/share/pkgconfig
+ doins zlib.pc || die
+ ;;
+
+ *)
+ emake install DESTDIR="${D}" LDCONFIG=: || die
+ gen_usr_ldscript -a z
;;
- *) gen_usr_ldscript -a z ;;
esac
+
+ dodoc FAQ README ChangeLog doc/*.txt
}