summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris PeBenito <pebenito@gentoo.org>2006-04-07 04:02:47 +0000
committerChris PeBenito <pebenito@gentoo.org>2006-04-07 04:02:47 +0000
commit1e484ee6c4307df4852ce593416135fcfddabbbc (patch)
tree0d57f7f76c77fb6b8b9718186d590d7c1d111e3b /sys-libs
parent(#129072) Change xorg-server dep to minimum 1.0.2 for randrstr.h. Fix by Albe... (diff)
downloadgentoo-2-1e484ee6c4307df4852ce593416135fcfddabbbc.tar.gz
gentoo-2-1e484ee6c4307df4852ce593416135fcfddabbbc.tar.bz2
gentoo-2-1e484ee6c4307df4852ce593416135fcfddabbbc.zip
fix for bug #129074.
(Portage version: 2.1_pre7-r4)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/libselinux/ChangeLog6
-rw-r--r--sys-libs/libselinux/libselinux-1.30.ebuild5
2 files changed, 8 insertions, 3 deletions
diff --git a/sys-libs/libselinux/ChangeLog b/sys-libs/libselinux/ChangeLog
index 8dc3a7cb56ce..c2add5ba8f58 100644
--- a/sys-libs/libselinux/ChangeLog
+++ b/sys-libs/libselinux/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-libs/libselinux
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libselinux/ChangeLog,v 1.46 2006/03/22 22:44:44 pebenito Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libselinux/ChangeLog,v 1.47 2006/04/07 04:02:47 pebenito Exp $
+
+ 07 Apr 2006; Chris PeBenito <pebenito@gentoo.org> libselinux-1.30.ebuild:
+ Split python wrapper compile into a separate emake to ensure the main
+ library is built before trying to build the wrapper. Fixes bug #129074.
22 Mar 2006; Chris PeBenito <pebenito@gentoo.org> -libselinux-1.24.ebuild,
-libselinux-1.28.ebuild, libselinux-1.28-r1.ebuild:
diff --git a/sys-libs/libselinux/libselinux-1.30.ebuild b/sys-libs/libselinux/libselinux-1.30.ebuild
index e1f2d5c090bf..7a172e43e640 100644
--- a/sys-libs/libselinux/libselinux-1.30.ebuild
+++ b/sys-libs/libselinux/libselinux-1.30.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libselinux/libselinux-1.30.ebuild,v 1.2 2006/03/18 15:32:06 pebenito Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libselinux/libselinux-1.30.ebuild,v 1.3 2006/04/07 04:02:47 pebenito Exp $
IUSE=""
@@ -30,7 +30,8 @@ src_unpack() {
src_compile() {
python_version
- emake PYLIBVER="python${PYVER}" LDFLAGS="-fPIC ${LDFLAGS}" all pywrap || die
+ emake LDFLAGS="-fPIC ${LDFLAGS}" all || die
+ emake PYLIBVER="python${PYVER}" LDFLAGS="-fPIC ${LDFLAGS}" pywrap || die
# add compatability aliases to swig wrapper
cat ${FILESDIR}/compat.py >> ${S}/src/selinux.py || die