summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Vermeulen <swift@gentoo.org>2011-11-12 16:58:49 +0000
committerSven Vermeulen <swift@gentoo.org>2011-11-12 16:58:49 +0000
commit226813851a9b412cd5e93ec0606783d6604007ac (patch)
tree22407d144ea28a8b491a668636856062196ae49d /sys-libs
parentFixes bug 363227 (diff)
downloadgentoo-2-226813851a9b412cd5e93ec0606783d6604007ac.tar.gz
gentoo-2-226813851a9b412cd5e93ec0606783d6604007ac.tar.bz2
gentoo-2-226813851a9b412cd5e93ec0606783d6604007ac.zip
Remove deprecated ebuilds
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/libsemanage/ChangeLog6
-rw-r--r--sys-libs/libsemanage/libsemanage-2.0.45.ebuild121
-rw-r--r--sys-libs/libsemanage/libsemanage-2.0.46.ebuild123
3 files changed, 5 insertions, 245 deletions
diff --git a/sys-libs/libsemanage/ChangeLog b/sys-libs/libsemanage/ChangeLog
index 43859a1505ee..36c1fd911a25 100644
--- a/sys-libs/libsemanage/ChangeLog
+++ b/sys-libs/libsemanage/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-libs/libsemanage
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libsemanage/ChangeLog,v 1.43 2011/10/23 12:39:35 swift Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libsemanage/ChangeLog,v 1.44 2011/11/12 16:58:49 swift Exp $
+
+ 12 Nov 2011; <swift@gentoo.org> -libsemanage-2.0.45.ebuild,
+ -libsemanage-2.0.46.ebuild:
+ Remove deprecated ebuilds
23 Oct 2011; <swift@gentoo.org> libsemanage-2.1.0.ebuild:
Stabilization (tracker #384231)
diff --git a/sys-libs/libsemanage/libsemanage-2.0.45.ebuild b/sys-libs/libsemanage/libsemanage-2.0.45.ebuild
deleted file mode 100644
index d97cce02fb73..000000000000
--- a/sys-libs/libsemanage/libsemanage-2.0.45.ebuild
+++ /dev/null
@@ -1,121 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libsemanage/libsemanage-2.0.45.ebuild,v 1.8 2011/09/17 12:57:34 swift Exp $
-
-EAPI="2"
-PYTHON_DEPEND="python? 2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython"
-
-inherit multilib python toolchain-funcs
-
-SEPOL_VER="2.0.41"
-SELNX_VER="2.0.94"
-
-DESCRIPTION="SELinux kernel and policy management library"
-HOMEPAGE="http://userspace.selinuxproject.org"
-SRC_URI="http://userspace.selinuxproject.org/releases/20100525/devel/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="python ruby"
-
-RDEPEND=">=sys-libs/libsepol-${SEPOL_VER}
- >=sys-libs/libselinux-${SELNX_VER}
- dev-libs/ustr
- ruby? ( dev-lang/ruby )"
-DEPEND="${RDEPEND}
- sys-devel/bison
- sys-devel/flex
- ruby? ( dev-lang/swig )"
-
-# tests are not meant to be run outside of the
-# full SELinux userland repo
-RESTRICT="test"
-
-pkg_setup() {
- if use python; then
- python_pkg_setup
- fi
-}
-
-src_prepare() {
- echo "# Set this to true to save the linked policy." >> "${S}/src/semanage.conf"
- echo "# This is normally only useful for analysis" >> "${S}/src/semanage.conf"
- echo "# or debugging of policy." >> "${S}/src/semanage.conf"
- echo "save-linked=false" >> "${S}/src/semanage.conf"
- echo >> "${S}/src/semanage.conf"
- echo "# Set this to 0 to disable assertion checking." >> "${S}/src/semanage.conf"
- echo "# This should speed up building the kernel policy" >> "${S}/src/semanage.conf"
- echo "# from policy modules, but may leave you open to" >> "${S}/src/semanage.conf"
- echo "# dangerous rules which assertion checking" >> "${S}/src/semanage.conf"
- echo "# would catch." >> "${S}/src/semanage.conf"
- echo "expand-check=1" >> "${S}/src/semanage.conf"
- echo >> "${S}/src/semanage.conf"
- echo "# Modules in the module store can be compressed" >> "${S}/src/semanage.conf"
- echo "# with bzip2. Set this to the bzip2 blocksize" >> "${S}/src/semanage.conf"
- echo "# 1-9 when compressing. The higher the number," >> "${S}/src/semanage.conf"
- echo "# the more memory is traded off for disk space." >> "${S}/src/semanage.conf"
- echo "# Set to 0 to disable bzip2 compression." >> "${S}/src/semanage.conf"
- echo "bzip-blocksize=0" >> "${S}/src/semanage.conf"
- echo >> "${S}/src/semanage.conf"
- echo "# Reduce memory usage for bzip2 compression and" >> "${S}/src/semanage.conf"
- echo "# decompression of modules in the module store." >> "${S}/src/semanage.conf"
- echo "bzip-small=true" >> "${S}/src/semanage.conf"
-}
-
-src_compile() {
- emake AR="$(tc-getAR)" CC="$(tc-getCC)" all || die
-
- if use python; then
- python_copy_sources src
- building() {
- emake CC="$(tc-getCC)" PYLIBVER="python$(python_get_version)" pywrap
- }
- python_execute_function -s --source-dir src building
- fi
-
- if use ruby; then
- emake -C src CC="$(tc-getCC)" rubywrap || die
- fi
-}
-
-src_install() {
- emake \
- DESTDIR="${D}" \
- LIBDIR="${D}usr/$(get_libdir)" \
- SHLIBDIR="${D}$(get_libdir)" \
- install || die
- dosym "../../$(get_libdir)/libsemanage.so.1" "/usr/$(get_libdir)/libsemanage.so" || die
-
- if use python; then
- installation() {
- emake \
- DESTDIR="${D}" \
- PYLIBVER="python$(python_get_version)" \
- LIBDIR="${D}usr/$(get_libdir)" \
- install-pywrap
- }
- python_execute_function -s --source-dir src installation
- fi
-
- if use ruby; then
- emake -C src \
- DESTDIR="${D}" \
- LIBDIR="${D}usr/$(get_libdir)" \
- install-rubywrap || die
- fi
-}
-
-pkg_postinst() {
- if use python; then
- python_mod_optimize semanage.py
- fi
-}
-
-pkg_postrm() {
- if use python; then
- python_mod_cleanup semanage.py
- fi
-}
diff --git a/sys-libs/libsemanage/libsemanage-2.0.46.ebuild b/sys-libs/libsemanage/libsemanage-2.0.46.ebuild
deleted file mode 100644
index d0613749bca7..000000000000
--- a/sys-libs/libsemanage/libsemanage-2.0.46.ebuild
+++ /dev/null
@@ -1,123 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libsemanage/libsemanage-2.0.46.ebuild,v 1.2 2011/09/17 12:57:34 swift Exp $
-
-EAPI="3"
-# Support for 4 depends on python.eclass
-PYTHON_DEPEND="python? *"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="*-jython"
-
-inherit multilib python toolchain-funcs
-
-SEPOL_VER="2.0.42"
-SELNX_VER="2.0.98"
-
-DESCRIPTION="SELinux kernel and policy management library"
-HOMEPAGE="http://userspace.selinuxproject.org"
-SRC_URI="http://userspace.selinuxproject.org/releases/20101221/devel/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="python ruby"
-
-RDEPEND=">=sys-libs/libsepol-${SEPOL_VER}
- >=sys-libs/libselinux-${SELNX_VER}
- dev-libs/ustr
- ruby? ( dev-lang/ruby )"
-DEPEND="${RDEPEND}
- sys-devel/bison
- sys-devel/flex
- ruby? ( dev-lang/swig )"
-
-# tests are not meant to be run outside of the
-# full SELinux userland repo
-RESTRICT="test"
-
-pkg_setup() {
- if use python; then
- python_pkg_setup
- fi
-}
-
-src_prepare() {
- echo "# Set this to true to save the linked policy." >> "${S}/src/semanage.conf"
- echo "# This is normally only useful for analysis" >> "${S}/src/semanage.conf"
- echo "# or debugging of policy." >> "${S}/src/semanage.conf"
- echo "save-linked=false" >> "${S}/src/semanage.conf"
- echo >> "${S}/src/semanage.conf"
- echo "# Set this to 0 to disable assertion checking." >> "${S}/src/semanage.conf"
- echo "# This should speed up building the kernel policy" >> "${S}/src/semanage.conf"
- echo "# from policy modules, but may leave you open to" >> "${S}/src/semanage.conf"
- echo "# dangerous rules which assertion checking" >> "${S}/src/semanage.conf"
- echo "# would catch." >> "${S}/src/semanage.conf"
- echo "expand-check=1" >> "${S}/src/semanage.conf"
- echo >> "${S}/src/semanage.conf"
- echo "# Modules in the module store can be compressed" >> "${S}/src/semanage.conf"
- echo "# with bzip2. Set this to the bzip2 blocksize" >> "${S}/src/semanage.conf"
- echo "# 1-9 when compressing. The higher the number," >> "${S}/src/semanage.conf"
- echo "# the more memory is traded off for disk space." >> "${S}/src/semanage.conf"
- echo "# Set to 0 to disable bzip2 compression." >> "${S}/src/semanage.conf"
- echo "bzip-blocksize=0" >> "${S}/src/semanage.conf"
- echo >> "${S}/src/semanage.conf"
- echo "# Reduce memory usage for bzip2 compression and" >> "${S}/src/semanage.conf"
- echo "# decompression of modules in the module store." >> "${S}/src/semanage.conf"
- echo "bzip-small=true" >> "${S}/src/semanage.conf"
-}
-
-src_compile() {
- emake AR="$(tc-getAR)" CC="$(tc-getCC)" all || die
-
- if use python; then
- python_copy_sources src
- building() {
- emake CC="$(tc-getCC)" PYLIBVER="python$(python_get_version)" "$@"
- }
- python_execute_function -s --source-dir src building -- swigify
- python_execute_function -s --source-dir src building -- pywrap
- fi
-
- if use ruby; then
- emake -C src CC="$(tc-getCC)" rubywrap || die
- fi
-}
-
-src_install() {
- emake \
- DESTDIR="${D}" \
- LIBDIR="${D}usr/$(get_libdir)" \
- SHLIBDIR="${D}$(get_libdir)" \
- install || die
- dosym "../../$(get_libdir)/libsemanage.so.1" "/usr/$(get_libdir)/libsemanage.so" || die
-
- if use python; then
- installation() {
- emake \
- DESTDIR="${D}" \
- PYLIBVER="python$(python_get_version)" \
- LIBDIR="${D}usr/$(get_libdir)" \
- install-pywrap
- }
- python_execute_function -s --source-dir src installation
- fi
-
- if use ruby; then
- emake -C src \
- DESTDIR="${D}" \
- LIBDIR="${D}usr/$(get_libdir)" \
- install-rubywrap || die
- fi
-}
-
-pkg_postinst() {
- if use python; then
- python_mod_optimize semanage.py
- fi
-}
-
-pkg_postrm() {
- if use python; then
- python_mod_cleanup semanage.py
- fi
-}