summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-03-25 20:25:51 +0000
committerMike Frysinger <vapier@gentoo.org>2008-03-25 20:25:51 +0000
commit245be7f8f17e7d1da877f1648bcb0fd10541d666 (patch)
tree01ead8f5e45ae566a8a9d3d84ffaf28da756f9d2 /sys-libs
parentBumped to latest release, updated deps, added gconf, gnome, and xfce USE flag... (diff)
downloadgentoo-2-245be7f8f17e7d1da877f1648bcb0fd10541d666.tar.gz
gentoo-2-245be7f8f17e7d1da877f1648bcb0fd10541d666.tar.bz2
gentoo-2-245be7f8f17e7d1da877f1648bcb0fd10541d666.zip
looks like version bump lost some pieces
(Portage version: 2.2_pre5)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/timezone-data/timezone-data-2008b.ebuild32
1 files changed, 20 insertions, 12 deletions
diff --git a/sys-libs/timezone-data/timezone-data-2008b.ebuild b/sys-libs/timezone-data/timezone-data-2008b.ebuild
index d0cf96b53908..1deb9ef388a0 100644
--- a/sys-libs/timezone-data/timezone-data-2008b.ebuild
+++ b/sys-libs/timezone-data/timezone-data-2008b.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/timezone-data/timezone-data-2008b.ebuild,v 1.1 2008/03/24 19:42:07 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/timezone-data/timezone-data-2008b.ebuild,v 1.2 2008/03/25 20:25:51 vapier Exp $
inherit eutils toolchain-funcs flag-o-matic
@@ -52,21 +52,29 @@ src_install() {
pkg_config() {
# make sure the /etc/localtime file does not get stale #127899
- local tz=$(unset TIMEZONE ; source "${ROOT}"/etc/conf.d/clock ; echo ${TIMEZONE-FOOKABLOIE})
- [[ -z ${tz} ]] && return 0
- if [[ ${tz} == "FOOKABLOIE" ]] ; then
- elog "You do not have TIMEZONE set in /etc/conf.d/clock."
- if [[ ! -e ${ROOT}/etc/localtime ]] ; then
- cp -f "${ROOT}"/usr/share/zoneinfo/Factory "${ROOT}"/etc/localtime
- elog "Setting /etc/localtime to Factory."
- else
- elog "Skipping auto-update of /etc/localtime."
+ local tz src
+
+ if [[ -e ${ROOT}/etc/timezone ]] ; then
+ src="/etc/timezone"
+ tz=$(<"${ROOT}"/etc/timezone)
+ else
+ src="/etc/conf.d/clock"
+ tz=$(unset TIMEZONE ; source "${ROOT}"/etc/conf.d/clock ; echo ${TIMEZONE-FOOKABLOIE})
+ [[ -z ${tz} ]] && return 0
+ if [[ ${tz} == "FOOKABLOIE" ]] ; then
+ elog "You do not have TIMEZONE set in /etc/conf.d/clock."
+ if [[ ! -e ${ROOT}/etc/localtime ]] ; then
+ cp -f "${ROOT}"/usr/share/zoneinfo/Factory "${ROOT}"/etc/localtime
+ elog "Setting /etc/localtime to Factory."
+ else
+ elog "Skipping auto-update of /etc/localtime."
+ fi
+ return 0
fi
- return 0
fi
if [[ ! -e ${ROOT}/usr/share/zoneinfo/${tz} ]] ; then
- elog "You have an invalid TIMEZONE setting in /etc/conf.d/clock."
+ elog "You have an invalid TIMEZONE setting in ${src}"
elog "Your /etc/localtime has been reset to Factory; enjoy!"
tz="Factory"
fi