summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-11-13 20:06:25 +0000
committerMike Frysinger <vapier@gentoo.org>2011-11-13 20:06:25 +0000
commit2b8f6912386f402661b9f3e1e316fe16afb0db59 (patch)
treed3538c5baf896c8c9e1293818542d7533a183e49 /sys-libs
parentVersion bump. (diff)
downloadgentoo-2-2b8f6912386f402661b9f3e1e316fe16afb0db59.tar.gz
gentoo-2-2b8f6912386f402661b9f3e1e316fe16afb0db59.tar.bz2
gentoo-2-2b8f6912386f402661b9f3e1e316fe16afb0db59.zip
Drop old ebuilds (to lose USE=nocxx).
(Portage version: 2.2.0_alpha74/cvs/Linux x86_64)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/ncurses/ChangeLog6
-rw-r--r--sys-libs/ncurses/ncurses-5.6-r2.ebuild160
-rw-r--r--sys-libs/ncurses/ncurses-5.7-r3.ebuild173
-rw-r--r--sys-libs/ncurses/ncurses-5.7-r5.ebuild168
-rw-r--r--sys-libs/ncurses/ncurses-5.7-r6.ebuild168
5 files changed, 5 insertions, 670 deletions
diff --git a/sys-libs/ncurses/ChangeLog b/sys-libs/ncurses/ChangeLog
index 582097ccbbc9..2cf44bb58596 100644
--- a/sys-libs/ncurses/ChangeLog
+++ b/sys-libs/ncurses/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-libs/ncurses
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/ncurses/ChangeLog,v 1.189 2011/05/22 18:19:56 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/ncurses/ChangeLog,v 1.190 2011/11/13 20:06:25 vapier Exp $
+
+ 13 Nov 2011; Mike Frysinger <vapier@gentoo.org> -ncurses-5.6-r2.ebuild,
+ -ncurses-5.7-r3.ebuild, -ncurses-5.7-r5.ebuild, -ncurses-5.7-r6.ebuild:
+ Drop old ebuilds (to lose USE=nocxx).
22 May 2011; Kacper Kowalik <xarthisius@gentoo.org> ncurses-5.7-r7.ebuild:
ppc64 stable wrt #353437
diff --git a/sys-libs/ncurses/ncurses-5.6-r2.ebuild b/sys-libs/ncurses/ncurses-5.6-r2.ebuild
deleted file mode 100644
index 6d7f66d35410..000000000000
--- a/sys-libs/ncurses/ncurses-5.6-r2.ebuild
+++ /dev/null
@@ -1,160 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/ncurses/ncurses-5.6-r2.ebuild,v 1.14 2009/10/11 05:38:15 vapier Exp $
-
-inherit eutils flag-o-matic toolchain-funcs
-
-MY_PV=${PV:0:3}
-PV_SNAP=${PV:4}
-MY_P=${PN}-${MY_PV}
-DESCRIPTION="console display library"
-HOMEPAGE="http://www.gnu.org/software/ncurses/ http://dickey.his.com/ncurses/"
-SRC_URI="mirror://gnu/ncurses/${MY_P}.tar.gz
- ftp://invisible-island.net/ncurses/${PV}/${P}-coverity.patch.gz"
-
-LICENSE="MIT"
-SLOT="5"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
-IUSE="debug doc gpm minimal nocxx profile trace unicode"
-
-DEPEND="gpm? ( sys-libs/gpm )"
-
-S=${WORKDIR}/${MY_P}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- [[ -n ${PV_SNAP} ]] && epatch "${WORKDIR}"/${MY_P}-${PV_SNAP}-patch.sh
- epatch "${WORKDIR}"/${P}-coverity.patch
- epatch "${FILESDIR}"/${PN}-5.6-gfbsd.patch
- epatch "${FILESDIR}"/${PN}-5.6-build.patch #184700
-}
-
-src_compile() {
- export ac_cv_prog_AWK=gawk #259510
- tc-export BUILD_CC
-
- # Protect the user from themselves #115036
- unset TERMINFO
-
- local myconf=""
- use nocxx && myconf="${myconf} --without-cxx --without-cxx-binding"
-
- # First we build the regular ncurses ...
- mkdir "${WORKDIR}"/narrowc
- cd "${WORKDIR}"/narrowc
- do_compile ${myconf}
-
- # Then we build the UTF-8 version
- if use unicode ; then
- mkdir "${WORKDIR}"/widec
- cd "${WORKDIR}"/widec
- do_compile ${myconf} --enable-widec --includedir=/usr/include/ncursesw
- fi
-}
-do_compile() {
- ECONF_SOURCE=${S}
-
- # We need the basic terminfo files in /etc, bug #37026. We will
- # add '--with-terminfo-dirs' and then populate /etc/terminfo in
- # src_install() ...
- # The chtype/mmask-t settings below are to retain ABI compat
- # with ncurses-5.4 so dont change em !
- local conf_abi="
- --with-chtype=long \
- --with-mmask-t=long \
- --disable-ext-colors \
- --disable-ext-mouse \
- "
- econf \
- --libdir="/$(get_libdir)" \
- --with-terminfo-dirs="/etc/terminfo:/usr/share/terminfo" \
- --with-shared \
- $(use_with debug) \
- $(use_with profile) \
- $(use_with gpm) \
- --disable-termcap \
- --enable-symlinks \
- --with-rcs-ids \
- --with-manpage-format=normal \
- --enable-const \
- --enable-colorfgbg \
- --enable-echo \
- --without-ada \
- --enable-warnings \
- $(use_with debug assertions) \
- $(use_with !debug leaks) \
- $(use_with debug expanded) \
- $(use_with !debug macros) \
- $(use_with trace) \
- ${conf_abi} \
- "$@" \
- || die "configure failed"
-
- # A little hack to fix parallel builds ... they break when
- # generating sources so if we generate the sources first (in
- # non-parallel), we can then build the rest of the package
- # in parallel. This is not really a perf hit since the source
- # generation is quite small. -vapier
- emake -j1 sources || die "make sources failed"
- emake || die "make failed"
-}
-
-src_install() {
- # install unicode version second so that the binaries in /usr/bin
- # support both wide and narrow
- cd "${WORKDIR}"/narrowc
- emake DESTDIR="${D}" install || die "make narrowc install failed"
- if use unicode ; then
- cd "${WORKDIR}"/widec
- emake DESTDIR="${D}" install || die "make widec install failed"
- fi
-
- # Move static and extraneous ncurses libraries out of /lib
- dodir /usr/$(get_libdir)
- cd "${D}"/$(get_libdir)
- mv lib{form,menu,panel}.so* *.a "${D}"/usr/$(get_libdir)/
- gen_usr_ldscript lib{,n}curses.so
- if use unicode ; then
- mv lib{form,menu,panel}w.so* "${D}"/usr/$(get_libdir)/
- gen_usr_ldscript lib{,n}cursesw.so
- fi
-
- # We need the basic terminfo files in /etc, bug #37026
- einfo "Installing basic terminfo files in /etc..."
- for x in ansi console dumb linux rxvt screen sun vt{52,100,102,200,220} \
- xterm xterm-color xterm-xfree86
- do
- local termfile=$(find "${D}"/usr/share/terminfo/ -name "${x}" 2>/dev/null)
- local basedir=$(basename $(dirname "${termfile}"))
-
- if [[ -n ${termfile} ]] ; then
- dodir /etc/terminfo/${basedir}
- mv ${termfile} "${D}"/etc/terminfo/${basedir}/
- dosym ../../../../etc/terminfo/${basedir}/${x} \
- /usr/share/terminfo/${basedir}/${x}
- fi
- done
-
- # Build fails to create this ...
- dosym ../share/terminfo /usr/$(get_libdir)/terminfo
-
- echo "CONFIG_PROTECT_MASK=\"/etc/terminfo\"" > "${T}"/50ncurses
- doenvd "${T}"/50ncurses
-
- use minimal && rm -r "${D}"/usr/share/terminfo
- # Because ncurses5-config --terminfo returns the directory we keep it
- keepdir /usr/share/terminfo #245374
-
- cd "${S}"
- dodoc ANNOUNCE MANIFEST NEWS README* TO-DO doc/*.doc
- use doc && dohtml -r doc/html/
-}
-
-pkg_preinst() {
- use unicode || preserve_old_lib /$(get_libdir)/libncursesw.so.5
-}
-
-pkg_postinst() {
- use unicode || preserve_old_lib_notify /$(get_libdir)/libncursesw.so.5
-}
diff --git a/sys-libs/ncurses/ncurses-5.7-r3.ebuild b/sys-libs/ncurses/ncurses-5.7-r3.ebuild
deleted file mode 100644
index f60e989947a0..000000000000
--- a/sys-libs/ncurses/ncurses-5.7-r3.ebuild
+++ /dev/null
@@ -1,173 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/ncurses/ncurses-5.7-r3.ebuild,v 1.10 2010/03/06 23:12:41 vapier Exp $
-
-EAPI="1"
-inherit eutils flag-o-matic toolchain-funcs
-
-MY_PV=${PV:0:3}
-PV_SNAP=${PV:4}
-MY_P=${PN}-${MY_PV}
-DESCRIPTION="console display library"
-HOMEPAGE="http://www.gnu.org/software/ncurses/ http://dickey.his.com/ncurses/"
-SRC_URI="mirror://gnu/ncurses/${MY_P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="5"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd"
-IUSE="ada +cxx debug doc gpm minimal profile trace unicode"
-
-DEPEND="gpm? ( sys-libs/gpm )"
-# berkdb? ( sys-libs/db )"
-RDEPEND="!<x11-terms/rxvt-unicode-9.06-r3"
-
-S=${WORKDIR}/${MY_P}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- [[ -n ${PV_SNAP} ]] && epatch "${WORKDIR}"/${MY_P}-${PV_SNAP}-patch.sh
- epatch "${FILESDIR}"/${PN}-5.6-gfbsd.patch
- epatch "${FILESDIR}"/${PN}-5.7-emacs.patch #270527
- epatch "${FILESDIR}"/${PN}-5.7-nongnu.patch
- epatch "${FILESDIR}"/${PN}-5.7-tic-cross-detection.patch #288881
- epatch "${FILESDIR}"/${PN}-5.7-rxvt-unicode.patch #192083
- epatch "${FILESDIR}"/${P}-hashdb-open.patch #245370
- sed -i '/with_no_leaks=yes/s:=.*:=$enableval:' configure #305889
-}
-
-src_compile() {
- unset TERMINFO #115036
- tc-export BUILD_CC
- export BUILD_CPPFLAGS+=" -D_GNU_SOURCE" #214642
-
- # when cross-compiling, we need to build up our own tic
- # because people often don't keep matching host/target
- # ncurses versions #249363
- if tc-is-cross-compiler && ! ROOT=/ has_version ~sys-libs/${P} ; then
- make_flags="-C progs tic"
- CHOST=${CBUILD} \
- CFLAGS=${BUILD_CFLAGS} \
- CXXFLAGS=${BUILD_CXXFLAGS} \
- CPPFLAGS=${BUILD_CPPFLAGS} \
- LDFLAGS="${BUILD_LDFLAGS} -static" \
- do_compile cross --without-shared
- fi
-
- make_flags=""
- do_compile narrowc
- use unicode && do_compile widec --enable-widec --includedir=/usr/include/ncursesw
-}
-do_compile() {
- ECONF_SOURCE=${S}
-
- mkdir "${WORKDIR}"/$1
- cd "${WORKDIR}"/$1
- shift
-
- # The chtype/mmask-t settings below are to retain ABI compat
- # with ncurses-5.4 so dont change em !
- local conf_abi="
- --with-chtype=long \
- --with-mmask-t=long \
- --disable-ext-colors \
- --disable-ext-mouse \
- --without-pthread \
- --without-reentrant \
- "
- # We need the basic terminfo files in /etc, bug #37026. We will
- # add '--with-terminfo-dirs' and then populate /etc/terminfo in
- # src_install() ...
-# $(use_with berkdb hashed-db)
- econf \
- --libdir="/$(get_libdir)" \
- --with-terminfo-dirs="/etc/terminfo:/usr/share/terminfo" \
- --with-shared \
- --without-hashed-db \
- $(use_with ada) \
- $(use_with cxx) \
- $(use_with cxx cxx-binding) \
- $(use_with debug) \
- $(use_with profile) \
- $(use_with gpm) \
- --disable-termcap \
- --enable-symlinks \
- --with-rcs-ids \
- --with-manpage-format=normal \
- --enable-const \
- --enable-colorfgbg \
- --enable-echo \
- $(use_enable !ada warnings) \
- $(use_with debug assertions) \
- $(use_enable !debug leaks) \
- $(use_with debug expanded) \
- $(use_with !debug macros) \
- $(use_with trace) \
- ${conf_abi} \
- "$@" \
- || die "configure failed"
-
- # A little hack to fix parallel builds ... they break when
- # generating sources so if we generate the sources first (in
- # non-parallel), we can then build the rest of the package
- # in parallel. This is not really a perf hit since the source
- # generation is quite small. -vapier
- emake -j1 sources || die "make sources failed"
- emake ${make_flags} || die "make ${make_flags} failed"
-}
-
-src_install() {
- # use the cross-compiled tic (if need be) #249363
- export PATH=${WORKDIR}/cross/progs:${PATH}
-
- # install unicode version second so that the binaries in /usr/bin
- # support both wide and narrow
- cd "${WORKDIR}"/narrowc
- emake DESTDIR="${D}" install || die "make narrowc install failed"
- if use unicode ; then
- cd "${WORKDIR}"/widec
- emake DESTDIR="${D}" install || die "make widec install failed"
- fi
-
- # Move static and extraneous ncurses libraries out of /lib
- dodir /usr/$(get_libdir)
- cd "${D}"/$(get_libdir)
- mv lib{form,menu,panel}.so* *.a "${D}"/usr/$(get_libdir)/
- gen_usr_ldscript lib{,n}curses.so
- if use unicode ; then
- mv lib{form,menu,panel}w.so* "${D}"/usr/$(get_libdir)/
- gen_usr_ldscript libncursesw.so
- fi
-
-# if ! use berkdb ; then
- # We need the basic terminfo files in /etc, bug #37026
- einfo "Installing basic terminfo files in /etc..."
- for x in ansi console dumb linux rxvt rxvt-unicode screen sun vt{52,100,102,200,220} \
- xterm xterm-color xterm-xfree86
- do
- local termfile=$(find "${D}"/usr/share/terminfo/ -name "${x}" 2>/dev/null)
- local basedir=$(basename $(dirname "${termfile}"))
-
- if [[ -n ${termfile} ]] ; then
- dodir /etc/terminfo/${basedir}
- mv ${termfile} "${D}"/etc/terminfo/${basedir}/
- dosym ../../../../etc/terminfo/${basedir}/${x} \
- /usr/share/terminfo/${basedir}/${x}
- fi
- done
-
- # Build fails to create this ...
- dosym ../share/terminfo /usr/$(get_libdir)/terminfo
-# fi
-
- echo "CONFIG_PROTECT_MASK=\"/etc/terminfo\"" > "${T}"/50ncurses
- doenvd "${T}"/50ncurses
-
- use minimal && rm -r "${D}"/usr/share/terminfo*
- # Because ncurses5-config --terminfo returns the directory we keep it
- keepdir /usr/share/terminfo #245374
-
- cd "${S}"
- dodoc ANNOUNCE MANIFEST NEWS README* TO-DO doc/*.doc
- use doc && dohtml -r doc/html/
-}
diff --git a/sys-libs/ncurses/ncurses-5.7-r5.ebuild b/sys-libs/ncurses/ncurses-5.7-r5.ebuild
deleted file mode 100644
index 01805d8ce3cc..000000000000
--- a/sys-libs/ncurses/ncurses-5.7-r5.ebuild
+++ /dev/null
@@ -1,168 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/ncurses/ncurses-5.7-r5.ebuild,v 1.1 2010/07/07 19:25:28 vapier Exp $
-
-EAPI="1"
-inherit eutils flag-o-matic toolchain-funcs
-
-MY_PV=${PV:0:3}
-PV_SNAP=${PV:4}
-MY_P=${PN}-${MY_PV}
-DESCRIPTION="console display library"
-HOMEPAGE="http://www.gnu.org/software/ncurses/ http://dickey.his.com/ncurses/"
-SRC_URI="mirror://gnu/ncurses/${MY_P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="5"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
-IUSE="ada +cxx debug doc gpm minimal profile static-libs trace unicode"
-
-DEPEND="gpm? ( sys-libs/gpm )"
-# berkdb? ( sys-libs/db )"
-RDEPEND="!<x11-terms/rxvt-unicode-9.06-r3"
-
-S=${WORKDIR}/${MY_P}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- [[ -n ${PV_SNAP} ]] && epatch "${WORKDIR}"/${MY_P}-${PV_SNAP}-patch.sh
- epatch "${FILESDIR}"/${PN}-5.6-gfbsd.patch
- epatch "${FILESDIR}"/${PN}-5.7-emacs.patch #270527
- epatch "${FILESDIR}"/${PN}-5.7-nongnu.patch
- epatch "${FILESDIR}"/${PN}-5.7-tic-cross-detection.patch #288881
- epatch "${FILESDIR}"/${PN}-5.7-rxvt-unicode.patch #192083
- epatch "${FILESDIR}"/${P}-hashdb-open.patch #245370
- sed -i '/with_no_leaks=yes/s:=.*:=$enableval:' configure #305889
-}
-
-src_compile() {
- unset TERMINFO #115036
- tc-export BUILD_CC
- export BUILD_CPPFLAGS+=" -D_GNU_SOURCE" #214642
-
- # when cross-compiling, we need to build up our own tic
- # because people often don't keep matching host/target
- # ncurses versions #249363
- if tc-is-cross-compiler && ! ROOT=/ has_version ~sys-libs/${P} ; then
- make_flags="-C progs tic"
- CHOST=${CBUILD} \
- CFLAGS=${BUILD_CFLAGS} \
- CXXFLAGS=${BUILD_CXXFLAGS} \
- CPPFLAGS=${BUILD_CPPFLAGS} \
- LDFLAGS="${BUILD_LDFLAGS} -static" \
- do_compile cross --without-shared --with-normal
- fi
-
- make_flags=""
- do_compile narrowc
- use unicode && do_compile widec --enable-widec --includedir=/usr/include/ncursesw
-}
-do_compile() {
- ECONF_SOURCE=${S}
-
- mkdir "${WORKDIR}"/$1
- cd "${WORKDIR}"/$1
- shift
-
- # The chtype/mmask-t settings below are to retain ABI compat
- # with ncurses-5.4 so dont change em !
- local conf_abi="
- --with-chtype=long \
- --with-mmask-t=long \
- --disable-ext-colors \
- --disable-ext-mouse \
- --without-pthread \
- --without-reentrant \
- "
- # We need the basic terminfo files in /etc, bug #37026. We will
- # add '--with-terminfo-dirs' and then populate /etc/terminfo in
- # src_install() ...
-# $(use_with berkdb hashed-db)
- econf \
- --with-terminfo-dirs="/etc/terminfo:/usr/share/terminfo" \
- --with-shared \
- $(use_with static-libs normal) \
- --without-hashed-db \
- $(use_with ada) \
- $(use_with cxx) \
- $(use_with cxx cxx-binding) \
- $(use_with debug) \
- $(use_with profile) \
- $(use_with gpm) \
- --disable-termcap \
- --enable-symlinks \
- --with-rcs-ids \
- --with-manpage-format=normal \
- --enable-const \
- --enable-colorfgbg \
- --enable-echo \
- $(use_enable !ada warnings) \
- $(use_with debug assertions) \
- $(use_enable !debug leaks) \
- $(use_with debug expanded) \
- $(use_with !debug macros) \
- $(use_with trace) \
- ${conf_abi} \
- "$@" \
- || die "configure failed"
-
- # A little hack to fix parallel builds ... they break when
- # generating sources so if we generate the sources first (in
- # non-parallel), we can then build the rest of the package
- # in parallel. This is not really a perf hit since the source
- # generation is quite small. -vapier
- emake -j1 sources || die "make sources failed"
- emake ${make_flags} || die "make ${make_flags} failed"
-}
-
-src_install() {
- # use the cross-compiled tic (if need be) #249363
- export PATH=${WORKDIR}/cross/progs:${PATH}
-
- # install unicode version second so that the binaries in /usr/bin
- # support both wide and narrow
- cd "${WORKDIR}"/narrowc
- emake DESTDIR="${D}" install || die "make narrowc install failed"
- if use unicode ; then
- cd "${WORKDIR}"/widec
- emake DESTDIR="${D}" install || die "make widec install failed"
- fi
-
- # Move libncurses{,w} into /lib
- gen_usr_ldscript -a ncurses
- use unicode && gen_usr_ldscript -a ncursesw
- ln -sf libncurses.so "${D}"/usr/$(get_libdir)/libcurses.so
-
-# if ! use berkdb ; then
- # We need the basic terminfo files in /etc, bug #37026
- einfo "Installing basic terminfo files in /etc..."
- for x in ansi console dumb linux rxvt rxvt-unicode screen sun vt{52,100,102,200,220} \
- xterm xterm-color xterm-xfree86
- do
- local termfile=$(find "${D}"/usr/share/terminfo/ -name "${x}" 2>/dev/null)
- local basedir=$(basename $(dirname "${termfile}"))
-
- if [[ -n ${termfile} ]] ; then
- dodir /etc/terminfo/${basedir}
- mv ${termfile} "${D}"/etc/terminfo/${basedir}/
- dosym ../../../../etc/terminfo/${basedir}/${x} \
- /usr/share/terminfo/${basedir}/${x}
- fi
- done
-
- # Build fails to create this ...
- dosym ../share/terminfo /usr/$(get_libdir)/terminfo
-# fi
-
- echo "CONFIG_PROTECT_MASK=\"/etc/terminfo\"" > "${T}"/50ncurses
- doenvd "${T}"/50ncurses
-
- use minimal && rm -r "${D}"/usr/share/terminfo*
- # Because ncurses5-config --terminfo returns the directory we keep it
- keepdir /usr/share/terminfo #245374
-
- cd "${S}"
- dodoc ANNOUNCE MANIFEST NEWS README* TO-DO doc/*.doc
- use doc && dohtml -r doc/html/
-}
diff --git a/sys-libs/ncurses/ncurses-5.7-r6.ebuild b/sys-libs/ncurses/ncurses-5.7-r6.ebuild
deleted file mode 100644
index a824bcece0f4..000000000000
--- a/sys-libs/ncurses/ncurses-5.7-r6.ebuild
+++ /dev/null
@@ -1,168 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/ncurses/ncurses-5.7-r6.ebuild,v 1.1 2010/11/15 11:55:07 wired Exp $
-
-EAPI="1"
-inherit eutils flag-o-matic toolchain-funcs
-
-MY_PV=${PV:0:3}
-PV_SNAP=${PV:4}
-MY_P=${PN}-${MY_PV}
-DESCRIPTION="console display library"
-HOMEPAGE="http://www.gnu.org/software/ncurses/ http://dickey.his.com/ncurses/"
-SRC_URI="mirror://gnu/ncurses/${MY_P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="5"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
-IUSE="ada +cxx debug doc gpm minimal profile static-libs trace unicode"
-
-DEPEND="gpm? ( sys-libs/gpm )"
-# berkdb? ( sys-libs/db )"
-RDEPEND="!<x11-terms/rxvt-unicode-9.06-r3"
-
-S=${WORKDIR}/${MY_P}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- [[ -n ${PV_SNAP} ]] && epatch "${WORKDIR}"/${MY_P}-${PV_SNAP}-patch.sh
- epatch "${FILESDIR}"/${PN}-5.6-gfbsd.patch
- epatch "${FILESDIR}"/${PN}-5.7-emacs.patch #270527
- epatch "${FILESDIR}"/${PN}-5.7-nongnu.patch
- epatch "${FILESDIR}"/${PN}-5.7-tic-cross-detection.patch #288881
- epatch "${FILESDIR}"/${PN}-5.7-rxvt-unicode-9.09.patch #192083
- epatch "${FILESDIR}"/${P}-hashdb-open.patch #245370
- sed -i '/with_no_leaks=yes/s:=.*:=$enableval:' configure #305889
-}
-
-src_compile() {
- unset TERMINFO #115036
- tc-export BUILD_CC
- export BUILD_CPPFLAGS+=" -D_GNU_SOURCE" #214642
-
- # when cross-compiling, we need to build up our own tic
- # because people often don't keep matching host/target
- # ncurses versions #249363
- if tc-is-cross-compiler && ! ROOT=/ has_version ~sys-libs/${P} ; then
- make_flags="-C progs tic"
- CHOST=${CBUILD} \
- CFLAGS=${BUILD_CFLAGS} \
- CXXFLAGS=${BUILD_CXXFLAGS} \
- CPPFLAGS=${BUILD_CPPFLAGS} \
- LDFLAGS="${BUILD_LDFLAGS} -static" \
- do_compile cross --without-shared --with-normal
- fi
-
- make_flags=""
- do_compile narrowc
- use unicode && do_compile widec --enable-widec --includedir=/usr/include/ncursesw
-}
-do_compile() {
- ECONF_SOURCE=${S}
-
- mkdir "${WORKDIR}"/$1
- cd "${WORKDIR}"/$1
- shift
-
- # The chtype/mmask-t settings below are to retain ABI compat
- # with ncurses-5.4 so dont change em !
- local conf_abi="
- --with-chtype=long \
- --with-mmask-t=long \
- --disable-ext-colors \
- --disable-ext-mouse \
- --without-pthread \
- --without-reentrant \
- "
- # We need the basic terminfo files in /etc, bug #37026. We will
- # add '--with-terminfo-dirs' and then populate /etc/terminfo in
- # src_install() ...
-# $(use_with berkdb hashed-db)
- econf \
- --with-terminfo-dirs="/etc/terminfo:/usr/share/terminfo" \
- --with-shared \
- $(use_with static-libs normal) \
- --without-hashed-db \
- $(use_with ada) \
- $(use_with cxx) \
- $(use_with cxx cxx-binding) \
- $(use_with debug) \
- $(use_with profile) \
- $(use_with gpm) \
- --disable-termcap \
- --enable-symlinks \
- --with-rcs-ids \
- --with-manpage-format=normal \
- --enable-const \
- --enable-colorfgbg \
- --enable-echo \
- $(use_enable !ada warnings) \
- $(use_with debug assertions) \
- $(use_enable debug leaks) \
- $(use_with debug expanded) \
- $(use_with !debug macros) \
- $(use_with trace) \
- ${conf_abi} \
- "$@" \
- || die "configure failed"
-
- # A little hack to fix parallel builds ... they break when
- # generating sources so if we generate the sources first (in
- # non-parallel), we can then build the rest of the package
- # in parallel. This is not really a perf hit since the source
- # generation is quite small. -vapier
- emake -j1 sources || die "make sources failed"
- emake ${make_flags} || die "make ${make_flags} failed"
-}
-
-src_install() {
- # use the cross-compiled tic (if need be) #249363
- export PATH=${WORKDIR}/cross/progs:${PATH}
-
- # install unicode version second so that the binaries in /usr/bin
- # support both wide and narrow
- cd "${WORKDIR}"/narrowc
- emake DESTDIR="${D}" install || die "make narrowc install failed"
- if use unicode ; then
- cd "${WORKDIR}"/widec
- emake DESTDIR="${D}" install || die "make widec install failed"
- fi
-
- # Move libncurses{,w} into /lib
- gen_usr_ldscript -a ncurses
- use unicode && gen_usr_ldscript -a ncursesw
- ln -sf libncurses.so "${D}"/usr/$(get_libdir)/libcurses.so
-
-# if ! use berkdb ; then
- # We need the basic terminfo files in /etc, bug #37026
- einfo "Installing basic terminfo files in /etc..."
- for x in ansi console dumb linux rxvt rxvt-unicode screen sun vt{52,100,102,200,220} \
- xterm xterm-color xterm-xfree86
- do
- local termfile=$(find "${D}"/usr/share/terminfo/ -name "${x}" 2>/dev/null)
- local basedir=$(basename $(dirname "${termfile}"))
-
- if [[ -n ${termfile} ]] ; then
- dodir /etc/terminfo/${basedir}
- mv ${termfile} "${D}"/etc/terminfo/${basedir}/
- dosym ../../../../etc/terminfo/${basedir}/${x} \
- /usr/share/terminfo/${basedir}/${x}
- fi
- done
-
- # Build fails to create this ...
- dosym ../share/terminfo /usr/$(get_libdir)/terminfo
-# fi
-
- echo "CONFIG_PROTECT_MASK=\"/etc/terminfo\"" > "${T}"/50ncurses
- doenvd "${T}"/50ncurses
-
- use minimal && rm -r "${D}"/usr/share/terminfo*
- # Because ncurses5-config --terminfo returns the directory we keep it
- keepdir /usr/share/terminfo #245374
-
- cd "${S}"
- dodoc ANNOUNCE MANIFEST NEWS README* TO-DO doc/*.doc
- use doc && dohtml -r doc/html/
-}