summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-03-24 23:21:14 +0000
committerMike Frysinger <vapier@gentoo.org>2005-03-24 23:21:14 +0000
commit4a2d60213a81b5cd4fc7e81a4237f24b97b06bb1 (patch)
tree09ed33100119100fe96ac38e67b243307d53334b /sys-libs
parentinitial import (diff)
downloadgentoo-2-4a2d60213a81b5cd4fc7e81a4237f24b97b06bb1.tar.gz
gentoo-2-4a2d60213a81b5cd4fc7e81a4237f24b97b06bb1.tar.bz2
gentoo-2-4a2d60213a81b5cd4fc7e81a4237f24b97b06bb1.zip
make sure we dont break bootstrap because certain binaries dont exist just yet
(Portage version: 2.0.51.19)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/glibc/glibc-2.3.4.20041102-r1.ebuild3
-rw-r--r--sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild3
2 files changed, 4 insertions, 2 deletions
diff --git a/sys-libs/glibc/glibc-2.3.4.20041102-r1.ebuild b/sys-libs/glibc/glibc-2.3.4.20041102-r1.ebuild
index 90c1e1f330a2..66411e9aa745 100644
--- a/sys-libs/glibc/glibc-2.3.4.20041102-r1.ebuild
+++ b/sys-libs/glibc/glibc-2.3.4.20041102-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20041102-r1.ebuild,v 1.3 2005/03/23 21:18:24 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20041102-r1.ebuild,v 1.4 2005/03/24 23:21:14 vapier Exp $
inherit eutils multilib flag-o-matic toolchain-funcs versionator
@@ -1004,6 +1004,7 @@ EOF
doins ${FILESDIR}/2.3.4/host.conf
for x in ls ps date ; do
+ [[ -z $(type -p ${x}) ]] && continue
env LD_LIBRARY_PATH="${D}/$(get_libdir)" ${x} > /dev/null \
|| die "simple run test (${x}) failed"
done
diff --git a/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild b/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild
index f634b40e48ac..8c985fbf5eb5 100644
--- a/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild
+++ b/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild,v 1.30 2005/03/23 21:18:24 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild,v 1.31 2005/03/24 23:21:14 vapier Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -485,6 +485,7 @@ toolchain-glibc_src_install() {
doins ${FILESDIR}/2.3.4/host.conf
for x in ls ps date ; do
+ [[ -z $(type -p ${x}) ]] && continue
env LD_LIBRARY_PATH="${D}/$(get_libdir)" ${x} > /dev/null \
|| die "simple run test (${x}) failed"
done