summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-09-29 22:38:45 +0000
committerMike Frysinger <vapier@gentoo.org>2005-09-29 22:38:45 +0000
commit5ca3408cb565e655e794459562a252e0576ca02a (patch)
tree1084ecd33358a1e6f0de01a40d61b8554b1a1403 /sys-libs
parentthe gif configure option is just gif, not giflib (diff)
downloadgentoo-2-5ca3408cb565e655e794459562a252e0576ca02a.tar.gz
gentoo-2-5ca3408cb565e655e794459562a252e0576ca02a.tar.bz2
gentoo-2-5ca3408cb565e655e794459562a252e0576ca02a.zip
add mips to the nptl list and make sure we pass --without-fp for softfloat targets
(Portage version: 2.0.52-r1 http://www.bash.org/?136501 )
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/glibc/glibc-2.3.5-r1.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/sys-libs/glibc/glibc-2.3.5-r1.ebuild b/sys-libs/glibc/glibc-2.3.5-r1.ebuild
index af0886f18657..680abe8d6dd0 100644
--- a/sys-libs/glibc/glibc-2.3.5-r1.ebuild
+++ b/sys-libs/glibc/glibc-2.3.5-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.5-r1.ebuild,v 1.38 2005/09/28 23:57:58 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.5-r1.ebuild,v 1.39 2005/09/29 22:38:45 vapier Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -752,7 +752,7 @@ want_nptl() {
# Archs that can use NPTL
case $(tc-arch) in
- alpha|amd64|ia64|ppc|ppc64|s390|x86)
+ alpha|amd64|ia64|mips|ppc|ppc64|s390|x86)
return 0;
;;
sparc)
@@ -774,7 +774,7 @@ want_linuxthreads() {
want_tls() {
# Archs that can use TLS (Thread Local Storage)
case $(tc-arch) in
- alpha|amd64|ia64|ppc|ppc64|s390)
+ alpha|amd64|ia64|mips|ppc|ppc64|s390)
return 0;
;;
sparc)
@@ -859,6 +859,8 @@ glibc_do_configure() {
use glibc-omitfp && myconf="${myconf} --enable-omitfp"
+ [[ ${CTARGET} == *-softfloat-* ]] && myconf="${myconf} --without-fp"
+
if [ "$1" == "linuxthreads" ] ; then
if want_tls && [[ ${CTARGET} != i[45]86-* ]] ; then
myconf="${myconf} --with-tls"