summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-09-20 04:16:42 +0000
committerMike Frysinger <vapier@gentoo.org>2011-09-20 04:16:42 +0000
commit64c78ef32cec7fffb19a5034b87a2e414a0f9667 (patch)
tree3897d466063418b459304093d229c45b0f0d8678 /sys-libs
parentx86 stable wrt bug #382225 (diff)
downloadgentoo-2-64c78ef32cec7fffb19a5034b87a2e414a0f9667.tar.gz
gentoo-2-64c78ef32cec7fffb19a5034b87a2e414a0f9667.tar.bz2
gentoo-2-64c78ef32cec7fffb19a5034b87a2e414a0f9667.zip
Add patch from upstream so gdbm_compat links against gdbm #383743 by Alexandre Rostovtsev.
(Portage version: 2.2.0_alpha58/cvs/Linux x86_64)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/gdbm/ChangeLog9
-rw-r--r--sys-libs/gdbm/files/gdbm-1.9.1-compat-link.patch24
-rw-r--r--sys-libs/gdbm/gdbm-1.9.1-r1.ebuild70
3 files changed, 102 insertions, 1 deletions
diff --git a/sys-libs/gdbm/ChangeLog b/sys-libs/gdbm/ChangeLog
index 8582a0b7b232..b16554f7593c 100644
--- a/sys-libs/gdbm/ChangeLog
+++ b/sys-libs/gdbm/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-libs/gdbm
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/gdbm/ChangeLog,v 1.54 2011/09/19 04:28:07 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/gdbm/ChangeLog,v 1.55 2011/09/20 04:16:42 vapier Exp $
+
+*gdbm-1.9.1-r1 (20 Sep 2011)
+
+ 20 Sep 2011; Mike Frysinger <vapier@gentoo.org> +gdbm-1.9.1-r1.ebuild,
+ +files/gdbm-1.9.1-compat-link.patch:
+ Add patch from upstream so gdbm_compat links against gdbm #383743 by
+ Alexandre Rostovtsev.
*gdbm-1.9.1 (19 Sep 2011)
diff --git a/sys-libs/gdbm/files/gdbm-1.9.1-compat-link.patch b/sys-libs/gdbm/files/gdbm-1.9.1-compat-link.patch
new file mode 100644
index 000000000000..bc445294eb3a
--- /dev/null
+++ b/sys-libs/gdbm/files/gdbm-1.9.1-compat-link.patch
@@ -0,0 +1,24 @@
+fix from upstream
+https://bugs.gentoo.org/383743
+
+From ae9ea0011da4ba01e5639611d61c442af8d42817 Mon Sep 17 00:00:00 2001
+From: Sergey Poznyakoff <gray@gnu.org.ua>
+Date: Sun, 14 Aug 2011 20:17:54 +0000
+Subject: * compat/Makefile.am (libgdbm_compat_la_LIBADD): Link against libgdbm.
+
+2011-08-14 Sergey Poznyakoff <gray@gnu.org.ua>
+
+ * compat/Makefile.am (libgdbm_compat_la_LIBADD): Link against
+ libgdbm. Suggested by Adam Sampson.
+
+--- a/compat/Makefile.in
++++ b/compat/Makefile.in
+@@ -23,7 +23,7 @@
+ sed '$$!N;$$!N;$$!N;$$!N;s/\n/ /g'
+ am__installdirs = "$(DESTDIR)$(libdir)" "$(DESTDIR)$(includedir)"
+ LTLIBRARIES = $(lib_LTLIBRARIES)
+-libgdbm_compat_la_LIBADD =
++libgdbm_compat_la_LIBADD = ../src/libgdbm.la
+ am__objects_1 = dbminit.lo delete.lo fetch.lo store.lo seq.lo close.lo
+ am__objects_2 = dbmopen.lo dbmdelete.lo dbmerr.lo dbmfetch.lo \
+ dbmstore.lo dbmseq.lo dbmclose.lo dbmdirfno.lo dbmpagfno.lo \
diff --git a/sys-libs/gdbm/gdbm-1.9.1-r1.ebuild b/sys-libs/gdbm/gdbm-1.9.1-r1.ebuild
new file mode 100644
index 000000000000..8072b60d728e
--- /dev/null
+++ b/sys-libs/gdbm/gdbm-1.9.1-r1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/gdbm/gdbm-1.9.1-r1.ebuild,v 1.1 2011/09/20 04:16:42 vapier Exp $
+
+EAPI="2"
+
+inherit eutils libtool flag-o-matic
+
+EX_P="${PN}-1.8.3"
+DESCRIPTION="Standard GNU database libraries"
+HOMEPAGE="http://www.gnu.org/software/gdbm/gdbm.html"
+SRC_URI="mirror://gnu/gdbm/${P}.tar.gz
+ exporter? ( mirror://gnu/gdbm/${EX_P}.tar.gz )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="berkdb compat exporter static-libs"
+
+DEPEND="berkdb? ( sys-libs/db )"
+RDEPEND="${DEPEND}"
+
+EX_S="${WORKDIR}"/${EX_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-compat-link.patch #383743
+ elibtoolize
+}
+
+src_configure() {
+ use berkdb || export ac_cv_lib_dbm_main=no ac_cv_lib_ndbm_main=no
+
+ if use exporter ; then
+ pushd "${EX_S}" >/dev/null
+ append-lfs-flags
+ econf --disable-shared
+ popd >/dev/null
+ fi
+
+ econf \
+ --includedir=/usr/include/gdbm \
+ --with-gdbm183-libdir="${EX_S}/.libs" \
+ --with-gdbm183-includedir="${EX_S}" \
+ $(use_enable compat libgdbm-compat) \
+ $(use_enable exporter gdbm-export) \
+ $(use_enable static-libs static)
+}
+
+src_compile() {
+ if use exporter ; then
+ emake -C "${WORKDIR}"/${EX_P} libgdbm.la || die
+ fi
+
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ use static-libs || find "${D}" -name '*.la' -delete
+ mv "${D}"/usr/include/gdbm/gdbm.h "${D}"/usr/include/ || die
+ dodoc ChangeLog NEWS README
+}
+
+pkg_preinst() {
+ preserve_old_lib libgdbm{,_compat}.so.{2,3} #32510
+}
+
+pkg_postinst() {
+ preserve_old_lib_notify libgdbm{,_compat}.so.{2,3} #32510
+}