summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2013-01-02 00:51:16 +0000
committerMike Frysinger <vapier@gentoo.org>2013-01-02 00:51:16 +0000
commit7a34be4c2384ef5a6c3e358aa74aa521b00a21b6 (patch)
tree15503d182f2bf6dd9a89ea15c51dcd60f5485a20 /sys-libs
parentVersion bump (diff)
downloadgentoo-2-7a34be4c2384ef5a6c3e358aa74aa521b00a21b6.tar.gz
gentoo-2-7a34be4c2384ef5a6c3e358aa74aa521b00a21b6.tar.bz2
gentoo-2-7a34be4c2384ef5a6c3e358aa74aa521b00a21b6.zip
Add IUSE=nscd to control support for it.
(Portage version: 2.2.0_alpha144/cvs/Linux x86_64, signed Manifest commit with key FB7C4156)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/glibc/ChangeLog7
-rw-r--r--sys-libs/glibc/files/eblits/src_compile.eblit5
-rw-r--r--sys-libs/glibc/glibc-2.17.ebuild6
-rw-r--r--sys-libs/glibc/glibc-9999.ebuild6
-rw-r--r--sys-libs/glibc/metadata.xml1
5 files changed, 16 insertions, 9 deletions
diff --git a/sys-libs/glibc/ChangeLog b/sys-libs/glibc/ChangeLog
index c35f76db172c..01f43ccc9ae1 100644
--- a/sys-libs/glibc/ChangeLog
+++ b/sys-libs/glibc/ChangeLog
@@ -1,5 +1,10 @@
# ChangeLog for sys-libs/glibc
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.914 2012/12/30 17:16:50 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.915 2013/01/02 00:51:16 vapier Exp $
+
+ 02 Jan 2013; Mike Frysinger <vapier@gentoo.org>
+ files/eblits/src_compile.eblit, glibc-2.17.ebuild, glibc-9999.ebuild,
+ metadata.xml:
+ Add IUSE=nscd to control support for it.
30 Dec 2012; Ulrich Müller <ulm@gentoo.org> glibc-2.9_p20081201-r3.ebuild,
glibc-2.10.1-r1.ebuild, glibc-2.11.3.ebuild, glibc-2.12.1-r3.ebuild,
diff --git a/sys-libs/glibc/files/eblits/src_compile.eblit b/sys-libs/glibc/files/eblits/src_compile.eblit
index 4aea5175ca6c..c8941b8a40a5 100644
--- a/sys-libs/glibc/files/eblits/src_compile.eblit
+++ b/sys-libs/glibc/files/eblits/src_compile.eblit
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/files/eblits/src_compile.eblit,v 1.31 2012/12/28 19:00:51 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/files/eblits/src_compile.eblit,v 1.32 2013/01/02 00:51:16 vapier Exp $
glibc_do_configure() {
local myconf=()
@@ -85,6 +85,7 @@ glibc_do_configure() {
$(use_multiarch || echo --disable-multi-arch)
--enable-obsolete-rpc
$(in_iuse systemtap && use_enable systemtap)
+ $(in_iuse nscd && use_enable nscd)
${EXTRA_ECONF}
)
diff --git a/sys-libs/glibc/glibc-2.17.ebuild b/sys-libs/glibc/glibc-2.17.ebuild
index c832fb15f048..d16769714a2d 100644
--- a/sys-libs/glibc/glibc-2.17.ebuild
+++ b/sys-libs/glibc/glibc-2.17.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.17.ebuild,v 1.3 2012/12/30 17:16:50 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.17.ebuild,v 1.4 2013/01/02 00:51:16 vapier Exp $
inherit eutils versionator toolchain-funcs flag-o-matic gnuconfig multilib unpacker multiprocessing
@@ -27,7 +27,7 @@ esac
PATCH_VER="1" # Gentoo patchset
NPTL_KERN_VER=${NPTL_KERN_VER:-"2.6.16"} # min kernel version nptl requires
-IUSE="debug gd hardened multilib selinux systemtap profile vanilla crosscompile_opts_headers-only"
+IUSE="debug gd hardened multilib nscd selinux systemtap profile vanilla crosscompile_opts_headers-only"
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
diff --git a/sys-libs/glibc/glibc-9999.ebuild b/sys-libs/glibc/glibc-9999.ebuild
index eae0574b12dc..cc345013e806 100644
--- a/sys-libs/glibc/glibc-9999.ebuild
+++ b/sys-libs/glibc/glibc-9999.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-9999.ebuild,v 1.18 2012/12/30 17:16:50 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-9999.ebuild,v 1.19 2013/01/02 00:51:16 vapier Exp $
inherit eutils versionator toolchain-funcs flag-o-matic gnuconfig multilib unpacker multiprocessing
@@ -27,7 +27,7 @@ esac
PATCH_VER="" # Gentoo patchset
NPTL_KERN_VER=${NPTL_KERN_VER:-"2.6.16"} # min kernel version nptl requires
-IUSE="debug gd hardened multilib selinux systemtap profile vanilla crosscompile_opts_headers-only"
+IUSE="debug gd hardened multilib nscd selinux systemtap profile vanilla crosscompile_opts_headers-only"
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
diff --git a/sys-libs/glibc/metadata.xml b/sys-libs/glibc/metadata.xml
index ddf6fba83409..2c513844d61a 100644
--- a/sys-libs/glibc/metadata.xml
+++ b/sys-libs/glibc/metadata.xml
@@ -5,6 +5,7 @@
<use>
<flag name='gd'>build memusage and memusagestat tools</flag>
<flag name='linuxthreads'>Build linuxthreads support (only for kernels older than linux-2.6)</flag>
+ <flag name='nscd'>Build, and enable support for, the Name Service Cache Daemon</flag>
<flag name='systemtap'>enable systemtap static probe points</flag>
</use>
</pkgmetadata>