summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2005-06-16 12:06:52 +0000
committerMartin Schlemmer <azarah@gentoo.org>2005-06-16 12:06:52 +0000
commit89e4fe4233f1192e8de238c8bbe136dd7df7e93c (patch)
tree594d4ce80237c01689c2223b226232d3a0d4771f /sys-libs
parentversion bump (diff)
downloadgentoo-2-89e4fe4233f1192e8de238c8bbe136dd7df7e93c.tar.gz
gentoo-2-89e4fe4233f1192e8de238c8bbe136dd7df7e93c.tar.bz2
gentoo-2-89e4fe4233f1192e8de238c8bbe136dd7df7e93c.zip
Do not backup symlinks for the 'do not strip thread/ld.so libs' action, as
it causes issues (basically the 'mv -f' followed the symlink instead of it ...). (Portage version: 2.0.51.22-r1)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/glibc/ChangeLog8
-rw-r--r--sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild18
-rw-r--r--sys-libs/glibc/glibc-2.3.5.20050421.ebuild18
3 files changed, 29 insertions, 15 deletions
diff --git a/sys-libs/glibc/ChangeLog b/sys-libs/glibc/ChangeLog
index f8966bd5d3a9..1399d713865c 100644
--- a/sys-libs/glibc/ChangeLog
+++ b/sys-libs/glibc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-libs/glibc
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.350 2005/06/14 22:56:03 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.351 2005/06/16 12:06:52 azarah Exp $
+
+ 16 June 2005; Martin Schlemmer <azarah@gentoo.org>
+ glibc-2.3.4.20050125-r1.ebuild, glibc-2.3.5.20050421.ebuild:
+ Do not backup symlinks for the 'do not strip thread/ld.so libs' action, as
+ it causes issues (basically the 'mv -f' followed the symlink instead of
+ it ...).
14 Jun 2005; Mike Frysinger <vapier@gentoo.org> files/nscd:
Add a permission check to nscd init.d #96108 by Paul Ortyl.
diff --git a/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild b/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild
index d3715077f3cf..ab9b251b5d4d 100644
--- a/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild
+++ b/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild,v 1.50 2005/06/11 04:37:24 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild,v 1.51 2005/06/16 12:06:52 azarah Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -388,15 +388,19 @@ toolchain-glibc_src_install() {
rm -rf ${D}/nptl
fi
- # now, strip everything but the thread libs #46186
+ # Now, strip everything but the thread libs #46186, as well as the dynamic
+ # linker, else we cannot set breakpoints in shared libraries.
+ # Fix for ld-* by Lonnie Princehouse.
mkdir -p ${T}/thread-backup
- mv -f ${D}$(alt_libdir)/lib{pthread,thread_db}* ${T}/thread-backup/
- # Also, don't strip the dynamic linker, else we cannot set breakpoints
- # in shared libraries. Fix by Lonnie Princehouse.
- mv -f ${D}/$(get_libdir)/ld-* ${T}/thread-backup/
+ for x in ${D}$(alt_libdir)/lib{pthread,thread_db}* \
+ ${D}$(alt_libdir)/ld-* ; do
+ [[ -f ${x} ]] && mv -f ${x} ${T}/thread-backup/
+ done
if want_linuxthreads && want_nptl ; then
mkdir -p ${T}/thread-backup/tls
- mv -f ${D}$(alt_libdir)/tls/lib{pthread,thread_db}* ${T}/thread-backup/tls
+ for x in ${D}$(alt_libdir)/tls/lib{pthread,thread_db}* ; do
+ [[ -f ${x} ]] && mv -f ${T}/thread-backup/tls
+ done
fi
env -uRESTRICT CHOST=${CTARGET} prepallstrip
cp -a -- ${T}/thread-backup/* ${D}$(alt_libdir)/ || die
diff --git a/sys-libs/glibc/glibc-2.3.5.20050421.ebuild b/sys-libs/glibc/glibc-2.3.5.20050421.ebuild
index f650ee7cf57e..75e0f47b865b 100644
--- a/sys-libs/glibc/glibc-2.3.5.20050421.ebuild
+++ b/sys-libs/glibc/glibc-2.3.5.20050421.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.5.20050421.ebuild,v 1.16 2005/06/11 04:37:24 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.5.20050421.ebuild,v 1.17 2005/06/16 12:06:52 azarah Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -389,15 +389,19 @@ toolchain-glibc_src_install() {
rm -rf ${D}/nptl
fi
- # now, strip everything but the thread libs #46186
+ # Now, strip everything but the thread libs #46186, as well as the dynamic
+ # linker, else we cannot set breakpoints in shared libraries.
+ # Fix for ld-* by Lonnie Princehouse.
mkdir -p ${T}/thread-backup
- mv -f ${D}$(alt_libdir)/lib{pthread,thread_db}* ${T}/thread-backup/
- # Also, don't strip the dynamic linker, else we cannot set breakpoints
- # in shared libraries. Fix by Lonnie Princehouse.
- mv -f ${D}/$(get_libdir)/ld-* ${T}/thread-backup/
+ for x in ${D}$(alt_libdir)/lib{pthread,thread_db}* \
+ ${D}$(alt_libdir)/ld-* ; do
+ [[ -f ${x} ]] && mv -f ${x} ${T}/thread-backup/
+ done
if want_linuxthreads && want_nptl ; then
mkdir -p ${T}/thread-backup/tls
- mv -f ${D}$(alt_libdir)/tls/lib{pthread,thread_db}* ${T}/thread-backup/tls
+ for x in ${D}$(alt_libdir)/tls/lib{pthread,thread_db}* ; do
+ [[ -f ${x} ]] && mv -f ${T}/thread-backup/tls
+ done
fi
env -uRESTRICT CHOST=${CTARGET} prepallstrip
cp -a -- ${T}/thread-backup/* ${D}$(alt_libdir)/ || die