summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Rothe <corsair@gentoo.org>2005-02-07 08:25:28 +0000
committerMarkus Rothe <corsair@gentoo.org>2005-02-07 08:25:28 +0000
commitd98232ba96fd2b84cbf66e5e2ff0ebb769c33b90 (patch)
tree08829e58d57f9e727765ded7a430956b86ab2d15 /sys-libs
parentAdded support for XiG GL headers: glxext.h glxmd.h glxproto.h. (diff)
downloadgentoo-2-d98232ba96fd2b84cbf66e5e2ff0ebb769c33b90.tar.gz
gentoo-2-d98232ba96fd2b84cbf66e5e2ff0ebb769c33b90.tar.bz2
gentoo-2-d98232ba96fd2b84cbf66e5e2ff0ebb769c33b90.zip
Stable on ppc64
(Portage version: 2.0.51-r15)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/libstdc++-v3/ChangeLog7
-rw-r--r--sys-libs/libstdc++-v3/libstdc++-v3-3.3.3-r1.ebuild4
-rw-r--r--sys-libs/libstdc++-v3/libstdc++-v3-3.3.4.ebuild6
3 files changed, 10 insertions, 7 deletions
diff --git a/sys-libs/libstdc++-v3/ChangeLog b/sys-libs/libstdc++-v3/ChangeLog
index 719bf10287e7..6ad175f3214a 100644
--- a/sys-libs/libstdc++-v3/ChangeLog
+++ b/sys-libs/libstdc++-v3/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-libs/libstdc++-v3
-# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libstdc++-v3/ChangeLog,v 1.30 2004/11/22 03:22:20 tgall Exp $
+# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libstdc++-v3/ChangeLog,v 1.31 2005/02/07 08:25:28 corsair Exp $
+
+ 07 Feb 2005; Markus Rothe <corsair@gentoo.org> libstdc++-v3-3.3.4.ebuild:
+ Fix typo in ppc64 CFLAGS-filter
21 Nov 2004; Tom Gall <tgall@gentoo.org> libstdc++-v3-3.3.4.ebuild:
fix bug #70972 on ppc64
diff --git a/sys-libs/libstdc++-v3/libstdc++-v3-3.3.3-r1.ebuild b/sys-libs/libstdc++-v3/libstdc++-v3-3.3.3-r1.ebuild
index 0b9b9a9cc8f6..3e0ee4126300 100644
--- a/sys-libs/libstdc++-v3/libstdc++-v3-3.3.3-r1.ebuild
+++ b/sys-libs/libstdc++-v3/libstdc++-v3-3.3.3-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libstdc++-v3/libstdc++-v3-3.3.3-r1.ebuild,v 1.33 2004/11/11 09:33:09 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libstdc++-v3/libstdc++-v3-3.3.3-r1.ebuild,v 1.34 2005/02/07 08:25:28 corsair Exp $
inherit eutils flag-o-matic libtool gnuconfig versionator
diff --git a/sys-libs/libstdc++-v3/libstdc++-v3-3.3.4.ebuild b/sys-libs/libstdc++-v3/libstdc++-v3-3.3.4.ebuild
index 89a561788723..7b73395c9818 100644
--- a/sys-libs/libstdc++-v3/libstdc++-v3-3.3.4.ebuild
+++ b/sys-libs/libstdc++-v3/libstdc++-v3-3.3.4.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libstdc++-v3/libstdc++-v3-3.3.4.ebuild,v 1.10 2004/11/22 03:22:20 tgall Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libstdc++-v3/libstdc++-v3-3.3.4.ebuild,v 1.11 2005/02/07 08:25:28 corsair Exp $
inherit eutils flag-o-matic libtool gnuconfig versionator
@@ -67,7 +67,7 @@ do_filter_flags() {
# in gcc 3.3 there is a bug on ppc64 where if -mcpu is used
# the compiler incorrectly assumes the code you are about to build
# is 32 bit
- use ppc64 setting="`get-flag mcpu`"
+ use ppc64 && setting="`get-flag mcpu`"
[ ! -z "${setting}" ] && filter-flags -mcpu="${setting}"
# only allow the flags that we -know- are supported