summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Vermeulen <swift@gentoo.org>2013-03-29 09:20:07 +0000
committerSven Vermeulen <swift@gentoo.org>2013-03-29 09:20:07 +0000
commite95f50abd1b619b8ec2ae3e9b81e742dd994d600 (patch)
tree08b197d81f1f135ed31969c6d0a2bb465ae4dd92 /sys-libs
parentBump to latest update. (diff)
downloadgentoo-2-e95f50abd1b619b8ec2ae3e9b81e742dd994d600.tar.gz
gentoo-2-e95f50abd1b619b8ec2ae3e9b81e742dd994d600.tar.bz2
gentoo-2-e95f50abd1b619b8ec2ae3e9b81e742dd994d600.zip
Fix bugs #463410 and 462626
(Portage version: 2.1.11.52/cvs/Linux x86_64, signed Manifest commit with key 0xCDBA2FDB)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/libselinux/ChangeLog10
-rw-r--r--sys-libs/libselinux/libselinux-2.1.12-r3.ebuild129
2 files changed, 137 insertions, 2 deletions
diff --git a/sys-libs/libselinux/ChangeLog b/sys-libs/libselinux/ChangeLog
index c56d12d8762b..8595505e0cb4 100644
--- a/sys-libs/libselinux/ChangeLog
+++ b/sys-libs/libselinux/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-libs/libselinux
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libselinux/ChangeLog,v 1.93 2012/12/30 15:17:46 swift Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libselinux/ChangeLog,v 1.94 2013/03/29 09:20:07 swift Exp $
+
+*libselinux-2.1.12-r3 (29 Mar 2013)
+
+ 29 Mar 2013; Sven Vermeulen <swift@gentoo.org> +libselinux-2.1.12-r3.ebuild:
+ Fix error return codes (bug #462626) and Python3 failure if built with swig-1
+ (bug #463410)
30 Dec 2012; Sven Vermeulen libselinux-2.1.12-r2.ebuild:
Stabilize
diff --git a/sys-libs/libselinux/libselinux-2.1.12-r3.ebuild b/sys-libs/libselinux/libselinux-2.1.12-r3.ebuild
new file mode 100644
index 000000000000..807908454a15
--- /dev/null
+++ b/sys-libs/libselinux/libselinux-2.1.12-r3.ebuild
@@ -0,0 +1,129 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libselinux/libselinux-2.1.12-r3.ebuild,v 1.1 2013/03/29 09:20:07 swift Exp $
+
+EAPI="4"
+PYTHON_DEPEND="python? *"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.5 *-jython *-pypy-*"
+USE_RUBY="ruby18 ruby19"
+RUBY_OPTIONAL="yes"
+
+inherit multilib python toolchain-funcs eutils ruby-ng
+
+SEPOL_VER="2.1.8"
+
+DESCRIPTION="SELinux userland library"
+HOMEPAGE="http://userspace.selinuxproject.org"
+SRC_URI="http://userspace.selinuxproject.org/releases/20120924/${P}.tar.gz
+ http://dev.gentoo.org/~swift/patches/${PN}/patchbundle-${P}-r3.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="python ruby static-libs"
+
+RDEPEND=">=sys-libs/libsepol-${SEPOL_VER}
+ >=dev-libs/libpcre-8.30-r2[static-libs?]
+ ruby? ( $(ruby_implementations_depend) )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ ruby? ( >=dev-lang/swig-2.0.9 )
+ python? ( >=dev-lang/swig-2.0.9 )"
+
+S="${WORKDIR}/${P}"
+
+pkg_setup() {
+ if use python; then
+ python_pkg_setup
+ fi
+}
+
+src_unpack() {
+ default
+}
+
+src_prepare() {
+ # fix up paths for multilib
+ sed -i \
+ -e "/^LIBDIR/s/lib/$(get_libdir)/" \
+ -e "/^SHLIBDIR/s/lib/$(get_libdir)/" \
+ src/Makefile utils/Makefile || die
+
+ EPATCH_MULTI_MSG="Applying libselinux patches ... " \
+ EPATCH_SUFFIX="patch" \
+ EPATCH_SOURCE="${WORKDIR}/gentoo-patches" \
+ EPATCH_FORCE="yes" \
+ epatch
+
+ epatch_user
+}
+
+each_ruby_compile() {
+ local RUBYLIBVER=$(${RUBY} -e 'print RUBY_VERSION.split(".")[0..1].join(".")')
+ cd "${WORKDIR}/${P}"
+ cp -r src src-ruby-${RUBYLIBVER}
+ cd src-ruby-${RUBYLIBVER}
+
+ if [[ "${RUBYLIBVER}" == "1.8" ]]; then
+ emake CC="$(tc-getCC)" RUBY="${RUBY}" RUBYINC="-I$(ruby_get_hdrdir)" LDFLAGS="-fPIC $($(tc-getPKG_CONFIG) libpcre --libs) ${LDFLAGS}" rubywrap || die
+ else
+ emake CC="$(tc-getCC)" RUBY="${RUBY}" LDFLAGS="-fPIC $($(tc-getPKG_CONFIG) libpcre --libs) ${LDFLAGS}" rubywrap || die
+ fi
+}
+
+src_compile() {
+ tc-export RANLIB
+ emake \
+ AR="$(tc-getAR)" \
+ CC="$(tc-getCC)" \
+ LDFLAGS="-fPIC $($(tc-getPKG_CONFIG) libpcre --libs) ${LDFLAGS}" all || die
+
+ if use python; then
+ python_copy_sources src
+ building() {
+ emake CC="$(tc-getCC)" PYINC="-I$(python_get_includedir)" PYTHONLIBDIR="$(python_get_library -l)" PYPREFIX="python-$(python_get_version)" LDFLAGS="-fPIC $($(tc-getPKG_CONFIG) libpcre --libs) ${LDFLAGS}" pywrap
+ }
+ python_execute_function -s --source-dir src building
+ fi
+
+ if use ruby; then
+ ruby-ng_src_compile
+ fi
+}
+
+each_ruby_install() {
+ local RUBYLIBVER=$(${RUBY} -e 'print RUBY_VERSION.split(".")[0..1].join(".")')
+
+ cd "${WORKDIR}/${P}/src-ruby-${RUBYLIBVER}"
+ emake RUBY="${RUBY}" DESTDIR="${D}" install-rubywrap || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ if use python; then
+ installation() {
+ emake DESTDIR="${D}" PYLIBVER="python$(python_get_version)" PYPREFIX="python-$(python_get_version)" install-pywrap
+ }
+ python_execute_function -s --source-dir src installation
+ fi
+
+ if use ruby; then
+ ruby-ng_src_install
+ fi
+
+ use static-libs || rm "${D}"/usr/lib*/*.a
+}
+
+pkg_postinst() {
+ if use python; then
+ python_mod_optimize selinux
+ fi
+}
+
+pkg_postrm() {
+ if use python; then
+ python_mod_cleanup selinux
+ fi
+}