summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2007-11-25 06:08:17 +0000
committerAlon Bar-Lev <alonbl@gentoo.org>2007-11-25 06:08:17 +0000
commit0a3c1ce7018e211e15894eba43a434835f5d4439 (patch)
tree7137642a6af72e8be5538142211cf692aea02b9b /sys-power
parentVersion bump to 2.0.5_pre6 for testing. This version adds support for N32 on... (diff)
downloadgentoo-2-0a3c1ce7018e211e15894eba43a434835f5d4439.tar.gz
gentoo-2-0a3c1ce7018e211e15894eba43a434835f5d4439.tar.bz2
gentoo-2-0a3c1ce7018e211e15894eba43a434835f5d4439.zip
Fix X environment issue, bug#199806, thanks to Daniel Schömer
(Portage version: 2.1.3.19, RepoMan options: --force)
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/hibernate-script/ChangeLog8
-rw-r--r--sys-power/hibernate-script/files/digest-hibernate-script-1.97-r36
-rw-r--r--sys-power/hibernate-script/hibernate-script-1.97-r3.ebuild69
3 files changed, 82 insertions, 1 deletions
diff --git a/sys-power/hibernate-script/ChangeLog b/sys-power/hibernate-script/ChangeLog
index 7f2efcfde22b..db72a59fde96 100644
--- a/sys-power/hibernate-script/ChangeLog
+++ b/sys-power/hibernate-script/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-power/hibernate-script
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/hibernate-script/ChangeLog,v 1.71 2007/11/17 07:39:03 alonbl Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/hibernate-script/ChangeLog,v 1.72 2007/11/25 06:08:17 alonbl Exp $
+
+*hibernate-script-1.97-r3 (25 Nov 2007)
+
+ 25 Nov 2007; Alon Bar-Lev <alonbl@gentoo.org>
+ +hibernate-script-1.97-r3.ebuild:
+ Fix X environment issue, bug#199806, thanks to Daniel Schömer
*hibernate-script-1.97-r2 (17 Nov 2007)
diff --git a/sys-power/hibernate-script/files/digest-hibernate-script-1.97-r3 b/sys-power/hibernate-script/files/digest-hibernate-script-1.97-r3
new file mode 100644
index 000000000000..6dd3bfc300e4
--- /dev/null
+++ b/sys-power/hibernate-script/files/digest-hibernate-script-1.97-r3
@@ -0,0 +1,6 @@
+MD5 a6155e1e3d145a35fa0e5c1485a7341e hibernate-script-1.97-patches-4.tar.bz2 3280
+RMD160 b1c048ef4275b5f643a0da1049315746185b1982 hibernate-script-1.97-patches-4.tar.bz2 3280
+SHA256 fd220135f7c3920fa61fecb4a240bb51fd22a5b9a606e65f3b2439ef6ab177ec hibernate-script-1.97-patches-4.tar.bz2 3280
+MD5 c3551238a2fe8bbe7b0e20322d8e02a5 hibernate-script-1.97.tar.gz 81504
+RMD160 6346a098f0892e6cffd547b0b7d042a51f298bb2 hibernate-script-1.97.tar.gz 81504
+SHA256 8374bedc80206a6708c10d9814b92bebed3d9e4966c01c2d086e9e5b5646827c hibernate-script-1.97.tar.gz 81504
diff --git a/sys-power/hibernate-script/hibernate-script-1.97-r3.ebuild b/sys-power/hibernate-script/hibernate-script-1.97-r3.ebuild
new file mode 100644
index 000000000000..207de08855a4
--- /dev/null
+++ b/sys-power/hibernate-script/hibernate-script-1.97-r3.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-power/hibernate-script/hibernate-script-1.97-r3.ebuild,v 1.1 2007/11/25 06:08:17 alonbl Exp $
+
+inherit eutils
+
+PATCH_VERSION="4"
+
+DESCRIPTION="Hibernate script supporting multiple suspend methods"
+HOMEPAGE="http://www.tuxonice.net/"
+SRC_URI="http://www.tuxonice.net/downloads/all/${P}.tar.gz
+ mirror://gentoo/${P}-patches-${PATCH_VERSION}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+
+IUSE="vim-syntax"
+
+DEPEND=""
+RDEPEND="!<media-gfx/splashutils-1.5.2"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Our patches
+ epatch "${WORKDIR}"/patches/*.patch
+}
+
+src_install() {
+ BASE_DIR="${D}" \
+ DISTRIBUTION="gentoo" \
+ PREFIX="/usr" \
+ MAN_DIR="${D}/usr/share/man" \
+ "${S}/install.sh" || die "Install failed"
+
+ # hibernate-ram will default to using ram.conf
+ dosym /usr/sbin/hibernate /usr/sbin/hibernate-ram
+
+ newinitd "${S}"/init.d/hibernate-cleanup.sh hibernate-cleanup
+
+ # other ebuilds can install scriplets to this dir
+ keepdir /etc/hibernate/scriptlets.d/
+
+ if use vim-syntax; then
+ insinto /usr/share/vim/vimfiles/syntax
+ doins hibernate.vim
+ fi
+
+ dodoc CHANGELOG README SCRIPTLET-API hibernate.vim
+
+ insinto /etc/logrotate.d
+ newins "${S}"/logrotate.d-hibernate-script hibernate-script
+}
+
+pkg_postinst() {
+ elog
+ elog "You should run the following command to invalidate suspend"
+ elog "images on a clean boot."
+ elog
+ elog " # rc-update add hibernate-cleanup boot"
+ elog
+ elog "See /usr/share/doc/${PF}/README.* for further details."
+ elog
+ elog "Please note that you will need to manually emerge any utilities"
+ elog "(radeontool, vbetool, ...) enabled in the configuration files,"
+ elog "should you wish to use them."
+}