summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2007-09-12 22:54:47 +0000
committerAlon Bar-Lev <alonbl@gentoo.org>2007-09-12 22:54:47 +0000
commit1f71ad37aa48629318d461dcfb4afcdd5eeee4d2 (patch)
treecd3fb9dc9c5605abade578483b17de7ebe3ec4ea /sys-power
parentRemove a few more dead masks. (diff)
downloadgentoo-2-1f71ad37aa48629318d461dcfb4afcdd5eeee4d2.tar.gz
gentoo-2-1f71ad37aa48629318d461dcfb4afcdd5eeee4d2.tar.bz2
gentoo-2-1f71ad37aa48629318d461dcfb4afcdd5eeee4d2.zip
Sync some patches from upstream
(Portage version: 2.1.3.9)
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/hibernate-script/ChangeLog8
-rw-r--r--sys-power/hibernate-script/files/digest-hibernate-script-1.96-r16
-rw-r--r--sys-power/hibernate-script/hibernate-script-1.96-r1.ebuild72
3 files changed, 85 insertions, 1 deletions
diff --git a/sys-power/hibernate-script/ChangeLog b/sys-power/hibernate-script/ChangeLog
index a7d3e73eda72..1adb4e8cb8fa 100644
--- a/sys-power/hibernate-script/ChangeLog
+++ b/sys-power/hibernate-script/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-power/hibernate-script
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/hibernate-script/ChangeLog,v 1.62 2007/07/17 03:58:38 alonbl Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/hibernate-script/ChangeLog,v 1.63 2007/09/12 22:54:46 alonbl Exp $
+
+*hibernate-script-1.96-r1 (12 Sep 2007)
+
+ 12 Sep 2007; Alon Bar-Lev <alonbl@gentoo.org>
+ +hibernate-script-1.96-r1.ebuild:
+ Sync some patches from upstream
*hibernate-script-1.96 (17 Jul 2007)
diff --git a/sys-power/hibernate-script/files/digest-hibernate-script-1.96-r1 b/sys-power/hibernate-script/files/digest-hibernate-script-1.96-r1
new file mode 100644
index 000000000000..6cbe150b3d56
--- /dev/null
+++ b/sys-power/hibernate-script/files/digest-hibernate-script-1.96-r1
@@ -0,0 +1,6 @@
+MD5 acb6efbcac82d00ea757f67ae3a7e993 hibernate-script-1.96-patches-2.tar.bz2 4254
+RMD160 89493fde6655201da028bacbe73e8b0c9390167f hibernate-script-1.96-patches-2.tar.bz2 4254
+SHA256 bef31573f00bd08330660b45f272409356abaab498abd34a4b48f868841d379d hibernate-script-1.96-patches-2.tar.bz2 4254
+MD5 1ca5fc5505131c0fa08cfcc1caf39b0f hibernate-script-1.96.tar.gz 77958
+RMD160 d0542e0f5e96a27d8b40ab64a72abe74a89f0419 hibernate-script-1.96.tar.gz 77958
+SHA256 b5b155808864d0f8351d002c01805c1ec02f5573698efc49e91ad703fbe96f4b hibernate-script-1.96.tar.gz 77958
diff --git a/sys-power/hibernate-script/hibernate-script-1.96-r1.ebuild b/sys-power/hibernate-script/hibernate-script-1.96-r1.ebuild
new file mode 100644
index 000000000000..ee8cb153808e
--- /dev/null
+++ b/sys-power/hibernate-script/hibernate-script-1.96-r1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-power/hibernate-script/hibernate-script-1.96-r1.ebuild,v 1.1 2007/09/12 22:54:46 alonbl Exp $
+
+inherit eutils
+
+PATCH_VERSION="2"
+
+DESCRIPTION="Hibernate script supporting multiple suspend methods"
+HOMEPAGE="http://www.tuxonice.net/"
+SRC_URI="http://www.tuxonice.net/downloads/all/${P}.tar.gz
+ mirror://gentoo/${P}-patches-${PATCH_VERSION}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="logrotate vim-syntax"
+
+DEPEND="sys-apps/sed"
+RDEPEND="logrotate? ( app-admin/logrotate )
+ !<media-gfx/splashutils-1.5.2"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Our patches
+ epatch "${WORKDIR}"/patches/*.patch
+}
+
+src_install() {
+ BASE_DIR="${D}" \
+ DISTRIBUTION="gentoo" \
+ PREFIX="/usr" \
+ MAN_DIR="${D}/usr/share/man" \
+ "${S}/install.sh" || die "Install failed"
+
+ # hibernate-ram will default to using ram.conf
+ dosym /usr/sbin/hibernate /usr/sbin/hibernate-ram
+
+ newinitd "${S}"/init.d/hibernate-cleanup.sh hibernate-cleanup
+
+ # other ebuilds can install scriplets to this dir
+ keepdir /etc/hibernate/scriptlets.d/
+
+ if use vim-syntax; then
+ insinto /usr/share/vim/vimfiles/syntax
+ doins hibernate.vim
+ fi
+
+ dodoc CHANGELOG README SCRIPTLET-API hibernate.vim
+
+ if use logrotate; then
+ insinto /etc/logrotate.d
+ newins "${S}"/logrotate.d-hibernate-script hibernate-script
+ fi
+}
+
+pkg_postinst() {
+ elog
+ elog "If you run suspend2, you should run the following command to"
+ elog "invalidate suspend images on a clean boot."
+ elog
+ elog " # rc-update add hibernate-cleanup boot"
+ elog
+ elog "See /usr/share/doc/${PF}/README.* for further details."
+ elog
+ elog "Please note that you will need to manually emerge any utilities"
+ elog "(radeontool, vbetool, ...) enabled in the configuration files,"
+ elog "should you wish to use them."
+}