summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2012-11-22 15:00:37 +0000
committerRick Farina <zerochaos@gentoo.org>2012-11-22 15:00:37 +0000
commit23cbcac935db2cef25ab6c9600e8f69ee1f95619 (patch)
tree4ec71faead7c0207555c6e1d4eadea3777b4b642 /sys-power
parentMove chown/chmod to src_install, where they belong, bug #444183 (diff)
downloadgentoo-2-23cbcac935db2cef25ab6c9600e8f69ee1f95619.tar.gz
gentoo-2-23cbcac935db2cef25ab6c9600e8f69ee1f95619.tar.bz2
gentoo-2-23cbcac935db2cef25ab6c9600e8f69ee1f95619.zip
SND_HDA_POWER_SAVE deprecated in kernel 3.7.0 so we conditionalize the check
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key DD11F94A)
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/powertop/ChangeLog6
-rw-r--r--sys-power/powertop/powertop-2.1-r1.ebuild8
-rw-r--r--sys-power/powertop/powertop-9999.ebuild8
3 files changed, 15 insertions, 7 deletions
diff --git a/sys-power/powertop/ChangeLog b/sys-power/powertop/ChangeLog
index ea2f1c91642f..87140e3c1a73 100644
--- a/sys-power/powertop/ChangeLog
+++ b/sys-power/powertop/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-power/powertop
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/powertop/ChangeLog,v 1.69 2012/11/18 11:44:09 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/powertop/ChangeLog,v 1.70 2012/11/22 15:00:37 zerochaos Exp $
+
+ 22 Nov 2012; Rick Farina <zerochaos@gentoo.org> powertop-2.1-r1.ebuild,
+ powertop-9999.ebuild:
+ SND_HDA_POWER_SAVE deprecated in kernel 3.7.0 so we conditionalize the check
18 Nov 2012; Pacho Ramos <pacho@gentoo.org> metadata.xml:
Drop mobile herd as talked in gentoo-dev ML
diff --git a/sys-power/powertop/powertop-2.1-r1.ebuild b/sys-power/powertop/powertop-2.1-r1.ebuild
index eef7d68a79cf..e51421791703 100644
--- a/sys-power/powertop/powertop-2.1-r1.ebuild
+++ b/sys-power/powertop/powertop-2.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/powertop/powertop-2.1-r1.ebuild,v 1.8 2012/09/20 03:26:51 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/powertop/powertop-2.1-r1.ebuild,v 1.9 2012/11/22 15:00:37 zerochaos Exp $
EAPI="4"
@@ -57,7 +57,10 @@ pkg_setup() {
~EVENT_POWER_TRACING_DEPRECATED
~TRACING
"
- linux_chkconfig_present SND_HDA_INTEL && CONFIG_CHECK+="~SND_HDA_POWER_SAVE"
+ if kernel_is -lt 3 7 0; then
+ linux_chkconfig_present SND_HDA_INTEL && CONFIG_CHECK+="~SND_HDA_POWER_SAVE"
+ linux_chkconfig_present SND_HDA_INTEL && ERROR_KERNEL_SND_HDA_POWER_SAVE="SND_HDA_POWER_SAVE should be enabled in the kernel for full powertop function"
+ fi
ERROR_KERNEL_X86_MSR="X86_MSR is not enabled in the kernel, you almost certainly need it"
ERROR_KERNEL_DEBUG_FS="DEBUG_FS is not enabled in the kernel, you almost certainly need it"
ERROR_KERNEL_PERF_EVENTS="PERF_EVENTS should be enabled in the kernel for full powertop function"
@@ -67,7 +70,6 @@ pkg_setup() {
ERROR_KERNEL_HPET_TIMER="HPET_TIMER should be enabled in the kernel for full powertop function"
ERROR_KERNEL_CPU_FREQ_STAT="CPU_FREQ_STAT should be enabled in the kernel for full powertop function"
ERROR_KERNEL_CPU_FREQ_GOV_ONDEMAND="CPU_FREQ_GOV_ONDEMAND should be enabled in the kernel for full powertop function"
- linux_chkconfig_present SND_HDA_INTEL && ERROR_KERNEL_SND_HDA_POWER_SAVE="SND_HDA_POWER_SAVE should be enabled in the kernel for full powertop function"
ERROR_KERNEL_USB_SUSPEND="USB_SUSPEND should be enabled in the kernel for full powertop function"
ERROR_KERNEL_FTRACE="FTRACE needs to be turned on to enable BLK_DEV_IO_TRACE"
ERROR_KERNEL_BLK_DEV_IO_TRACE="BLK_DEV_IO_TRACE needs to be turned on to enable TIMER_STATS, TRACING and EVENT_POWER_TRACING_DEPRECATED"
diff --git a/sys-power/powertop/powertop-9999.ebuild b/sys-power/powertop/powertop-9999.ebuild
index 97e2a60b83e2..ba7570238b3e 100644
--- a/sys-power/powertop/powertop-9999.ebuild
+++ b/sys-power/powertop/powertop-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/powertop/powertop-9999.ebuild,v 1.15 2012/09/20 03:26:51 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/powertop/powertop-9999.ebuild,v 1.16 2012/11/22 15:00:37 zerochaos Exp $
EAPI="4"
@@ -57,7 +57,10 @@ pkg_setup() {
~EVENT_POWER_TRACING_DEPRECATED
~TRACING
"
- linux_chkconfig_present SND_HDA_INTEL && CONFIG_CHECK+="~SND_HDA_POWER_SAVE"
+ if kernel_is -lt 3 7 0; then
+ linux_chkconfig_present SND_HDA_INTEL && CONFIG_CHECK+="~SND_HDA_POWER_SAVE"
+ linux_chkconfig_present SND_HDA_INTEL && ERROR_KERNEL_SND_HDA_POWER_SAVE="SND_HDA_POWER_SAVE should be enabled in the kernel for full powertop function"
+ fi
ERROR_KERNEL_X86_MSR="X86_MSR is not enabled in the kernel, you almost certainly need it"
ERROR_KERNEL_DEBUG_FS="DEBUG_FS is not enabled in the kernel, you almost certainly need it"
ERROR_KERNEL_PERF_EVENTS="PERF_EVENTS should be enabled in the kernel for full powertop function"
@@ -67,7 +70,6 @@ pkg_setup() {
ERROR_KERNEL_HPET_TIMER="HPET_TIMER should be enabled in the kernel for full powertop function"
ERROR_KERNEL_CPU_FREQ_STAT="CPU_FREQ_STAT should be enabled in the kernel for full powertop function"
ERROR_KERNEL_CPU_FREQ_GOV_ONDEMAND="CPU_FREQ_GOV_ONDEMAND should be enabled in the kernel for full powertop function"
- linux_chkconfig_present SND_HDA_INTEL && ERROR_KERNEL_SND_HDA_POWER_SAVE="SND_HDA_POWER_SAVE should be enabled in the kernel for full powertop function"
ERROR_KERNEL_USB_SUSPEND="USB_SUSPEND should be enabled in the kernel for full powertop function"
ERROR_KERNEL_FTRACE="FTRACE needs to be turned on to enable BLK_DEV_IO_TRACE"
ERROR_KERNEL_BLK_DEV_IO_TRACE="BLK_DEV_IO_TRACE needs to be turned on to enable TIMER_STATS, TRACING and EVENT_POWER_TRACING_DEPRECATED"