summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2015-07-31 04:09:39 +0000
committerJason Zaman <perfinion@gentoo.org>2015-07-31 04:09:39 +0000
commit64f232c1da6abf6edbb91a0ef49e0360bf5005af (patch)
tree5881ede83b9a1c116050f2ecf309923a2b059392 /sys-power
parentversion bump, proxy for Pavel Sanda (diff)
downloadgentoo-2-64f232c1da6abf6edbb91a0ef49e0360bf5005af.tar.gz
gentoo-2-64f232c1da6abf6edbb91a0ef49e0360bf5005af.tar.bz2
gentoo-2-64f232c1da6abf6edbb91a0ef49e0360bf5005af.zip
CONFIG_PM_RUNTIME was renamed to CONFIG_PM in kernel 3.19
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 0x7EF137EC935B0EAF)
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/powertop/ChangeLog7
-rw-r--r--sys-power/powertop/powertop-2.5.ebuild15
-rw-r--r--sys-power/powertop/powertop-2.6.ebuild13
-rw-r--r--sys-power/powertop/powertop-2.7-r1.ebuild13
-rw-r--r--sys-power/powertop/powertop-2.7-r2.ebuild13
-rw-r--r--sys-power/powertop/powertop-2.7.ebuild15
-rw-r--r--sys-power/powertop/powertop-9999.ebuild15
7 files changed, 69 insertions, 22 deletions
diff --git a/sys-power/powertop/ChangeLog b/sys-power/powertop/ChangeLog
index eebd77c8334e..2477878ec239 100644
--- a/sys-power/powertop/ChangeLog
+++ b/sys-power/powertop/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-power/powertop
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/powertop/ChangeLog,v 1.111 2015/07/08 11:53:58 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/powertop/ChangeLog,v 1.112 2015/07/31 04:09:39 perfinion Exp $
+
+ 31 Jul 2015; Jason Zaman <perfinion@gentoo.org> powertop-2.5.ebuild,
+ powertop-2.6.ebuild, powertop-2.7-r1.ebuild, powertop-2.7-r2.ebuild,
+ powertop-2.7.ebuild, powertop-9999.ebuild:
+ CONFIG_PM_RUNTIME was renamed to CONFIG_PM in kernel 3.19
*powertop-2.7-r2 (08 Jul 2015)
diff --git a/sys-power/powertop/powertop-2.5.ebuild b/sys-power/powertop/powertop-2.5.ebuild
index 4d7331ddd378..0526155c6ba4 100644
--- a/sys-power/powertop/powertop-2.5.ebuild
+++ b/sys-power/powertop/powertop-2.5.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/powertop/powertop-2.5.ebuild,v 1.6 2014/03/12 10:18:06 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/powertop/powertop-2.5.ebuild,v 1.7 2015/07/31 04:09:39 perfinion Exp $
EAPI="5"
@@ -50,7 +50,6 @@ pkg_setup() {
~HPET_TIMER
~CPU_FREQ_STAT
~CPU_FREQ_GOV_ONDEMAND
- ~PM_RUNTIME
~FTRACE
~BLK_DEV_IO_TRACE
~TIMER_STATS
@@ -65,7 +64,6 @@ pkg_setup() {
ERROR_KERNEL_HPET_TIMER="HPET_TIMER should be enabled in the kernel for full powertop function"
ERROR_KERNEL_CPU_FREQ_STAT="CPU_FREQ_STAT should be enabled in the kernel for full powertop function"
ERROR_KERNEL_CPU_FREQ_GOV_ONDEMAND="CPU_FREQ_GOV_ONDEMAND should be enabled in the kernel for full powertop function"
- ERROR_KERNEL_PM_RUNTIME="PM_RUNTIME should be enabled in the kernel for full powertop function"
ERROR_KERNEL_FTRACE="FTRACE needs to be turned on to enable BLK_DEV_IO_TRACE"
ERROR_KERNEL_BLK_DEV_IO_TRACE="BLK_DEV_IO_TRACE needs to be turned on to enable TIMER_STATS, TRACING and EVENT_POWER_TRACING_DEPRECATED"
ERROR_KERNEL_TIMER_STATS="TIMER_STATS should be enabled in the kernel for full powertop function"
@@ -84,6 +82,15 @@ pkg_setup() {
ERROR_KERNEL_EVENT_POWER_TRACING_DEPRECATED="EVENT_POWER_TRACING_DEPRECATED should be enabled in the kernel for full powertop function"
check_extra_config
fi
+ if kernel_is -lt 3 19; then
+ CONFIG_CHECK="~PM_RUNTIME"
+ ERROR_KERNEL_PM_RUNTIME="PM_RUNTIME should be enabled in the kernel for full powertop function"
+ check_extra_config
+ else
+ CONFIG_CHECK="~PM"
+ ERROR_KERNEL_PM="PM should be enabled in the kernel for full powertop function"
+ check_extra_config
+ fi
fi
}
diff --git a/sys-power/powertop/powertop-2.6.ebuild b/sys-power/powertop/powertop-2.6.ebuild
index 38e677f386f7..9445ef54079e 100644
--- a/sys-power/powertop/powertop-2.6.ebuild
+++ b/sys-power/powertop/powertop-2.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/powertop/powertop-2.6.ebuild,v 1.5 2015/03/02 09:33:37 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/powertop/powertop-2.6.ebuild,v 1.6 2015/07/31 04:09:39 perfinion Exp $
EAPI="5"
@@ -52,7 +52,6 @@ pkg_setup() {
~HPET_TIMER
~CPU_FREQ_STAT
~CPU_FREQ_GOV_ONDEMAND
- ~PM_RUNTIME
~FTRACE
~BLK_DEV_IO_TRACE
~TIMER_STATS
@@ -67,7 +66,6 @@ pkg_setup() {
ERROR_KERNEL_HPET_TIMER="HPET_TIMER should be enabled in the kernel for full powertop function"
ERROR_KERNEL_CPU_FREQ_STAT="CPU_FREQ_STAT should be enabled in the kernel for full powertop function"
ERROR_KERNEL_CPU_FREQ_GOV_ONDEMAND="CPU_FREQ_GOV_ONDEMAND should be enabled in the kernel for full powertop function"
- ERROR_KERNEL_PM_RUNTIME="PM_RUNTIME should be enabled in the kernel for full powertop function"
ERROR_KERNEL_FTRACE="FTRACE needs to be turned on to enable BLK_DEV_IO_TRACE"
ERROR_KERNEL_BLK_DEV_IO_TRACE="BLK_DEV_IO_TRACE needs to be turned on to enable TIMER_STATS, TRACING and EVENT_POWER_TRACING_DEPRECATED"
ERROR_KERNEL_TIMER_STATS="TIMER_STATS should be enabled in the kernel for full powertop function"
@@ -86,6 +84,15 @@ pkg_setup() {
ERROR_KERNEL_EVENT_POWER_TRACING_DEPRECATED="EVENT_POWER_TRACING_DEPRECATED should be enabled in the kernel for full powertop function"
check_extra_config
fi
+ if kernel_is -lt 3 19; then
+ CONFIG_CHECK="~PM_RUNTIME"
+ ERROR_KERNEL_PM_RUNTIME="PM_RUNTIME should be enabled in the kernel for full powertop function"
+ check_extra_config
+ else
+ CONFIG_CHECK="~PM"
+ ERROR_KERNEL_PM="PM should be enabled in the kernel for full powertop function"
+ check_extra_config
+ fi
fi
}
diff --git a/sys-power/powertop/powertop-2.7-r1.ebuild b/sys-power/powertop/powertop-2.7-r1.ebuild
index ac5759ebdc1c..f0c0062e2dda 100644
--- a/sys-power/powertop/powertop-2.7-r1.ebuild
+++ b/sys-power/powertop/powertop-2.7-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/powertop/powertop-2.7-r1.ebuild,v 1.2 2015/03/02 22:25:47 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/powertop/powertop-2.7-r1.ebuild,v 1.3 2015/07/31 04:09:39 perfinion Exp $
EAPI="5"
@@ -50,7 +50,6 @@ pkg_setup() {
~HPET_TIMER
~CPU_FREQ_STAT
~CPU_FREQ_GOV_ONDEMAND
- ~PM_RUNTIME
~FTRACE
~BLK_DEV_IO_TRACE
~TIMER_STATS
@@ -65,7 +64,6 @@ pkg_setup() {
ERROR_KERNEL_HPET_TIMER="HPET_TIMER should be enabled in the kernel for full powertop function"
ERROR_KERNEL_CPU_FREQ_STAT="CPU_FREQ_STAT should be enabled in the kernel for full powertop function"
ERROR_KERNEL_CPU_FREQ_GOV_ONDEMAND="CPU_FREQ_GOV_ONDEMAND should be enabled in the kernel for full powertop function"
- ERROR_KERNEL_PM_RUNTIME="PM_RUNTIME should be enabled in the kernel for full powertop function"
ERROR_KERNEL_FTRACE="FTRACE needs to be turned on to enable BLK_DEV_IO_TRACE"
ERROR_KERNEL_BLK_DEV_IO_TRACE="BLK_DEV_IO_TRACE needs to be turned on to enable TIMER_STATS, TRACING and EVENT_POWER_TRACING_DEPRECATED"
ERROR_KERNEL_TIMER_STATS="TIMER_STATS should be enabled in the kernel for full powertop function"
@@ -84,6 +82,15 @@ pkg_setup() {
ERROR_KERNEL_EVENT_POWER_TRACING_DEPRECATED="EVENT_POWER_TRACING_DEPRECATED should be enabled in the kernel for full powertop function"
check_extra_config
fi
+ if kernel_is -lt 3 19; then
+ CONFIG_CHECK="~PM_RUNTIME"
+ ERROR_KERNEL_PM_RUNTIME="PM_RUNTIME should be enabled in the kernel for full powertop function"
+ check_extra_config
+ else
+ CONFIG_CHECK="~PM"
+ ERROR_KERNEL_PM="PM should be enabled in the kernel for full powertop function"
+ check_extra_config
+ fi
fi
}
diff --git a/sys-power/powertop/powertop-2.7-r2.ebuild b/sys-power/powertop/powertop-2.7-r2.ebuild
index 819fa4ed63ea..e9744212722d 100644
--- a/sys-power/powertop/powertop-2.7-r2.ebuild
+++ b/sys-power/powertop/powertop-2.7-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/powertop/powertop-2.7-r2.ebuild,v 1.1 2015/07/08 11:53:58 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/powertop/powertop-2.7-r2.ebuild,v 1.2 2015/07/31 04:09:39 perfinion Exp $
EAPI="5"
@@ -50,7 +50,6 @@ pkg_setup() {
~HPET_TIMER
~CPU_FREQ_STAT
~CPU_FREQ_GOV_ONDEMAND
- ~PM_RUNTIME
~FTRACE
~BLK_DEV_IO_TRACE
~TIMER_STATS
@@ -65,7 +64,6 @@ pkg_setup() {
ERROR_KERNEL_HPET_TIMER="HPET_TIMER should be enabled in the kernel for full powertop function"
ERROR_KERNEL_CPU_FREQ_STAT="CPU_FREQ_STAT should be enabled in the kernel for full powertop function"
ERROR_KERNEL_CPU_FREQ_GOV_ONDEMAND="CPU_FREQ_GOV_ONDEMAND should be enabled in the kernel for full powertop function"
- ERROR_KERNEL_PM_RUNTIME="PM_RUNTIME should be enabled in the kernel for full powertop function"
ERROR_KERNEL_FTRACE="FTRACE needs to be turned on to enable BLK_DEV_IO_TRACE"
ERROR_KERNEL_BLK_DEV_IO_TRACE="BLK_DEV_IO_TRACE needs to be turned on to enable TIMER_STATS, TRACING and EVENT_POWER_TRACING_DEPRECATED"
ERROR_KERNEL_TIMER_STATS="TIMER_STATS should be enabled in the kernel for full powertop function"
@@ -84,6 +82,15 @@ pkg_setup() {
ERROR_KERNEL_EVENT_POWER_TRACING_DEPRECATED="EVENT_POWER_TRACING_DEPRECATED should be enabled in the kernel for full powertop function"
check_extra_config
fi
+ if kernel_is -lt 3 19; then
+ CONFIG_CHECK="~PM_RUNTIME"
+ ERROR_KERNEL_PM_RUNTIME="PM_RUNTIME should be enabled in the kernel for full powertop function"
+ check_extra_config
+ else
+ CONFIG_CHECK="~PM"
+ ERROR_KERNEL_PM="PM should be enabled in the kernel for full powertop function"
+ check_extra_config
+ fi
fi
}
diff --git a/sys-power/powertop/powertop-2.7.ebuild b/sys-power/powertop/powertop-2.7.ebuild
index ca86528a60b7..45b7b0ec8515 100644
--- a/sys-power/powertop/powertop-2.7.ebuild
+++ b/sys-power/powertop/powertop-2.7.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/powertop/powertop-2.7.ebuild,v 1.1 2014/11/24 21:24:59 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/powertop/powertop-2.7.ebuild,v 1.2 2015/07/31 04:09:39 perfinion Exp $
EAPI="5"
@@ -50,7 +50,6 @@ pkg_setup() {
~HPET_TIMER
~CPU_FREQ_STAT
~CPU_FREQ_GOV_ONDEMAND
- ~PM_RUNTIME
~FTRACE
~BLK_DEV_IO_TRACE
~TIMER_STATS
@@ -65,7 +64,6 @@ pkg_setup() {
ERROR_KERNEL_HPET_TIMER="HPET_TIMER should be enabled in the kernel for full powertop function"
ERROR_KERNEL_CPU_FREQ_STAT="CPU_FREQ_STAT should be enabled in the kernel for full powertop function"
ERROR_KERNEL_CPU_FREQ_GOV_ONDEMAND="CPU_FREQ_GOV_ONDEMAND should be enabled in the kernel for full powertop function"
- ERROR_KERNEL_PM_RUNTIME="PM_RUNTIME should be enabled in the kernel for full powertop function"
ERROR_KERNEL_FTRACE="FTRACE needs to be turned on to enable BLK_DEV_IO_TRACE"
ERROR_KERNEL_BLK_DEV_IO_TRACE="BLK_DEV_IO_TRACE needs to be turned on to enable TIMER_STATS, TRACING and EVENT_POWER_TRACING_DEPRECATED"
ERROR_KERNEL_TIMER_STATS="TIMER_STATS should be enabled in the kernel for full powertop function"
@@ -84,6 +82,15 @@ pkg_setup() {
ERROR_KERNEL_EVENT_POWER_TRACING_DEPRECATED="EVENT_POWER_TRACING_DEPRECATED should be enabled in the kernel for full powertop function"
check_extra_config
fi
+ if kernel_is -lt 3 19; then
+ CONFIG_CHECK="~PM_RUNTIME"
+ ERROR_KERNEL_PM_RUNTIME="PM_RUNTIME should be enabled in the kernel for full powertop function"
+ check_extra_config
+ else
+ CONFIG_CHECK="~PM"
+ ERROR_KERNEL_PM="PM should be enabled in the kernel for full powertop function"
+ check_extra_config
+ fi
fi
}
diff --git a/sys-power/powertop/powertop-9999.ebuild b/sys-power/powertop/powertop-9999.ebuild
index 591a2db1b5c2..951e00bd6ba5 100644
--- a/sys-power/powertop/powertop-9999.ebuild
+++ b/sys-power/powertop/powertop-9999.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/powertop/powertop-9999.ebuild,v 1.28 2014/05/30 14:29:49 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/powertop/powertop-9999.ebuild,v 1.29 2015/07/31 04:09:39 perfinion Exp $
EAPI="5"
@@ -50,7 +50,6 @@ pkg_setup() {
~HPET_TIMER
~CPU_FREQ_STAT
~CPU_FREQ_GOV_ONDEMAND
- ~PM_RUNTIME
~FTRACE
~BLK_DEV_IO_TRACE
~TIMER_STATS
@@ -65,7 +64,6 @@ pkg_setup() {
ERROR_KERNEL_HPET_TIMER="HPET_TIMER should be enabled in the kernel for full powertop function"
ERROR_KERNEL_CPU_FREQ_STAT="CPU_FREQ_STAT should be enabled in the kernel for full powertop function"
ERROR_KERNEL_CPU_FREQ_GOV_ONDEMAND="CPU_FREQ_GOV_ONDEMAND should be enabled in the kernel for full powertop function"
- ERROR_KERNEL_PM_RUNTIME="PM_RUNTIME should be enabled in the kernel for full powertop function"
ERROR_KERNEL_FTRACE="FTRACE needs to be turned on to enable BLK_DEV_IO_TRACE"
ERROR_KERNEL_BLK_DEV_IO_TRACE="BLK_DEV_IO_TRACE needs to be turned on to enable TIMER_STATS, TRACING and EVENT_POWER_TRACING_DEPRECATED"
ERROR_KERNEL_TIMER_STATS="TIMER_STATS should be enabled in the kernel for full powertop function"
@@ -84,6 +82,15 @@ pkg_setup() {
ERROR_KERNEL_EVENT_POWER_TRACING_DEPRECATED="EVENT_POWER_TRACING_DEPRECATED should be enabled in the kernel for full powertop function"
check_extra_config
fi
+ if kernel_is -lt 3 19; then
+ CONFIG_CHECK="~PM_RUNTIME"
+ ERROR_KERNEL_PM_RUNTIME="PM_RUNTIME should be enabled in the kernel for full powertop function"
+ check_extra_config
+ else
+ CONFIG_CHECK="~PM"
+ ERROR_KERNEL_PM="PM should be enabled in the kernel for full powertop function"
+ check_extra_config
+ fi
fi
}