summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHenrik Brix Andersen <brix@gentoo.org>2006-06-05 08:56:59 +0000
committerHenrik Brix Andersen <brix@gentoo.org>2006-06-05 08:56:59 +0000
commitc698fdc4d00183f7fc7b277a2461dd3312e0a457 (patch)
tree6120cf3548f640261c262c0a0ff2502a4d8114c7 /sys-power
parentPrefer to call ifort over ifc, when using the ifc profile. (diff)
downloadgentoo-2-c698fdc4d00183f7fc7b277a2461dd3312e0a457.tar.gz
gentoo-2-c698fdc4d00183f7fc7b277a2461dd3312e0a457.tar.bz2
gentoo-2-c698fdc4d00183f7fc7b277a2461dd3312e0a457.zip
Fix compilation with parallel make, bug #135521.
(Portage version: 2.0.54-r2)
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/cpufrequtils/ChangeLog6
-rw-r--r--sys-power/cpufrequtils/cpufrequtils-002.ebuild11
-rw-r--r--sys-power/cpufrequtils/files/cpufrequtils-002-parallel-make.patch12
3 files changed, 26 insertions, 3 deletions
diff --git a/sys-power/cpufrequtils/ChangeLog b/sys-power/cpufrequtils/ChangeLog
index e2a83f814b8a..59e4d6e46836 100644
--- a/sys-power/cpufrequtils/ChangeLog
+++ b/sys-power/cpufrequtils/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-power/cpufrequtils
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/cpufrequtils/ChangeLog,v 1.23 2006/06/01 12:02:01 brix Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/cpufrequtils/ChangeLog,v 1.24 2006/06/05 08:56:59 brix Exp $
+
+ 05 Jun 2006; Henrik Brix Andersen <brix@gentoo.org>
+ +files/cpufrequtils-002-parallel-make.patch, cpufrequtils-002.ebuild:
+ Fix compilation with parallel make, bug #135521.
*cpufrequtils-002 (01 Jun 2006)
diff --git a/sys-power/cpufrequtils/cpufrequtils-002.ebuild b/sys-power/cpufrequtils/cpufrequtils-002.ebuild
index 4866704aeda5..0646db48a3b0 100644
--- a/sys-power/cpufrequtils/cpufrequtils-002.ebuild
+++ b/sys-power/cpufrequtils/cpufrequtils-002.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/cpufrequtils/cpufrequtils-002.ebuild,v 1.1 2006/06/01 12:02:01 brix Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/cpufrequtils/cpufrequtils-002.ebuild,v 1.2 2006/06/05 08:56:59 brix Exp $
-inherit toolchain-funcs multilib
+inherit eutils toolchain-funcs multilib
DESCRIPTION="Userspace utilities for the Linux kernel cpufreq subsystem"
HOMEPAGE="http://www.kernel.org/pub/linux/utils/kernel/cpufreq/cpufrequtils.html"
@@ -15,6 +15,13 @@ KEYWORDS="~amd64 ~ppc ~sparc ~x86"
IUSE="debug nls"
DEPEND="sys-fs/sysfsutils"
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ epatch ${FILESDIR}/${P}-parallel-make.patch
+}
+
src_compile() {
local debug=false nls=false
diff --git a/sys-power/cpufrequtils/files/cpufrequtils-002-parallel-make.patch b/sys-power/cpufrequtils/files/cpufrequtils-002-parallel-make.patch
new file mode 100644
index 000000000000..5f92fa18e633
--- /dev/null
+++ b/sys-power/cpufrequtils/files/cpufrequtils-002-parallel-make.patch
@@ -0,0 +1,12 @@
+diff -urp cpufrequtils-002/Makefile cpufrequtils-002-parallel-make/Makefile
+--- cpufrequtils-002/Makefile 2006-06-01 10:54:41.000000000 +0200
++++ cpufrequtils-002-parallel-make/Makefile 2006-06-05 00:14:53.000000000 +0200
+@@ -189,7 +189,7 @@ libcpufreq.la: $(LIB_OBJS) $(LIB_HEADERS
+
+ libcpufreq: libcpufreq.la
+
+-cpufreq-%: $(UTIL_OBJS)
++cpufreq-%: libcpufreq.la $(UTIL_OBJS)
+ $(QUIET) $(CC) $(CFLAGDEF) $(CFLAGS) -g -I. -I./lib/ -c -o utils/$@.o utils/$*.c
+ $(QUIET) $(CC) $(CFLAGDEF) $(CFLAGS) -g -I./lib/ -L. -L./.libs/ -lcpufreq -o $@ utils/$@.o
+ $(QUIET) $(STRIPCMD) $@