summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2012-09-10 20:18:44 +0000
committerRick Farina <zerochaos@gentoo.org>2012-09-10 20:18:44 +0000
commitf1b34a05a84707a664de8397a694ecea63f08817 (patch)
tree0cf12cd271bdc75f68b19d2785c413e48bdf27a4 /sys-power
parentDrop multilib. (diff)
downloadgentoo-2-f1b34a05a84707a664de8397a694ecea63f08817.tar.gz
gentoo-2-f1b34a05a84707a664de8397a694ecea63f08817.tar.bz2
gentoo-2-f1b34a05a84707a664de8397a694ecea63f08817.zip
properly check required kernel options, based on bug #414803
(Portage version: 2.1.11.14/cvs/Linux x86_64)
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/powertop/ChangeLog7
-rw-r--r--sys-power/powertop/powertop-2.1-r1.ebuild77
2 files changed, 83 insertions, 1 deletions
diff --git a/sys-power/powertop/ChangeLog b/sys-power/powertop/ChangeLog
index 5b0379b0b377..f4f27ece7392 100644
--- a/sys-power/powertop/ChangeLog
+++ b/sys-power/powertop/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-power/powertop
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/powertop/ChangeLog,v 1.59 2012/09/07 11:48:13 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/powertop/ChangeLog,v 1.60 2012/09/10 20:18:44 zerochaos Exp $
+
+*powertop-2.1-r1 (10 Sep 2012)
+
+ 10 Sep 2012; Rick Farina <zerochaos@gentoo.org> +powertop-2.1-r1.ebuild:
+ properly check required kernel options, based on bug #414803
07 Sep 2012; Sergey Popov <pinkbyte@gentoo.org> powertop-2.1.ebuild:
Revert back src_configure logic and ncurses dependency, make it correct.
diff --git a/sys-power/powertop/powertop-2.1-r1.ebuild b/sys-power/powertop/powertop-2.1-r1.ebuild
new file mode 100644
index 000000000000..0e59d4d11930
--- /dev/null
+++ b/sys-power/powertop/powertop-2.1-r1.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-power/powertop/powertop-2.1-r1.ebuild,v 1.1 2012/09/10 20:18:44 zerochaos Exp $
+
+EAPI="4"
+
+inherit eutils linux-info
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://github.com/fenrus75/powertop.git"
+ inherit git-2
+ SRC_URI=""
+else
+ SRC_URI="https://01.org/powertop/sites/default/files/downloads/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+DESCRIPTION="tool that helps you find what software is using the most power"
+HOMEPAGE="https://01.org/powertop/ http://www.lesswatts.org/projects/powertop/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="unicode"
+
+COMMON_DEPEND="
+ dev-libs/libnl:3
+ sys-apps/pciutils
+ sys-devel/gettext
+ sys-libs/ncurses[unicode?]
+ sys-libs/zlib
+"
+
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig
+"
+RDEPEND="
+ ${COMMON_DEPEND}
+ x11-apps/xset
+"
+
+DOCS=( TODO README )
+
+pkg_setup() {
+ CONFIG_CHECK="
+ X86_MSR
+ DEBUG_FS
+ ~PERF_EVENTS
+ ~TRACEPOINTS
+ ~NO_HZ
+ ~HIGH_RES_TIMERS
+ ~HPET_TIMER
+ ~ACPI_PROCFS_POWER
+ ~CPU_FREQ_STAT
+ ~CPU_FREQ_GOV_ONDEMAND
+ ~SND_HDA_POWER_SAVE
+ ~USB_SUSPEND
+ ~TIMER_STATS
+ ~EVENT_POWER_TRACING_DEPRECATED
+ ~TRACING
+ "
+ linux-info_pkg_setup
+}
+
+src_configure() {
+ export ac_cv_search_delwin=$(usex unicode -lncursesw -lncurses)
+ default
+}
+
+src_compile() {
+ #the clean is needed because the 2.1 tarball had object files in src/tuning/
+ emake clean
+ emake
+}
+
+src_install() {
+ default
+ keepdir /var/cache/powertop
+}