summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2009-09-30 01:17:18 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2009-09-30 01:17:18 +0000
commitf30946ada4de778eb08ce53cc24c4c3140f5da5e (patch)
tree4ed973687c64eb9862f474da88db2d4246c67b92 /sys-power
parentMove check_dvd function from games-ut2k4mod.eclass to here (diff)
downloadgentoo-2-f30946ada4de778eb08ce53cc24c4c3140f5da5e.tar.gz
gentoo-2-f30946ada4de778eb08ce53cc24c4c3140f5da5e.tar.bz2
gentoo-2-f30946ada4de778eb08ce53cc24c4c3140f5da5e.zip
Version bump. Also fix bug #286499 for Turkish locales.
(Portage version: 2.2_rc42/cvs/Linux x86_64)
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/iasl/ChangeLog8
-rw-r--r--sys-power/iasl/files/iasl-locale.patch11
-rw-r--r--sys-power/iasl/iasl-20090903.ebuild127
3 files changed, 145 insertions, 1 deletions
diff --git a/sys-power/iasl/ChangeLog b/sys-power/iasl/ChangeLog
index 94ed4790e059..5b95c42c4b7c 100644
--- a/sys-power/iasl/ChangeLog
+++ b/sys-power/iasl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-power/iasl
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/iasl/ChangeLog,v 1.27 2009/07/31 06:47:10 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/iasl/ChangeLog,v 1.28 2009/09/30 01:17:18 robbat2 Exp $
+
+*iasl-20090903 (30 Sep 2009)
+
+ 30 Sep 2009; Robin H. Johnson <robbat2@gentoo.org> +iasl-20090903.ebuild,
+ +files/iasl-locale.patch:
+ Version bump. Also fix bug #286499 for Turkish locales.
31 Jul 2009; Robin H. Johnson <robbat2@gentoo.org> iasl-20080514.ebuild,
iasl-20080701.ebuild, iasl-20090123.ebuild, iasl-20090521.ebuild:
diff --git a/sys-power/iasl/files/iasl-locale.patch b/sys-power/iasl/files/iasl-locale.patch
new file mode 100644
index 000000000000..5b9bd618dcbf
--- /dev/null
+++ b/sys-power/iasl/files/iasl-locale.patch
@@ -0,0 +1,11 @@
+--- acpica-unix/compiler/Makefile
++++ acpica-unix/compiler/Makefile
+@@ -97,7 +97,7 @@
+ #YACC= yacc
+ YACC= bison
+ YFLAGS+= -v -d
+-LEX= flex
++LEX= LC_ALL=C flex
+ LFLAGS+= -i
+
+ #.if $(YACC) == "bison"
diff --git a/sys-power/iasl/iasl-20090903.ebuild b/sys-power/iasl/iasl-20090903.ebuild
new file mode 100644
index 000000000000..a3512f2b5081
--- /dev/null
+++ b/sys-power/iasl/iasl-20090903.ebuild
@@ -0,0 +1,127 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-power/iasl/iasl-20090903.ebuild,v 1.1 2009/09/30 01:17:18 robbat2 Exp $
+
+inherit toolchain-funcs flag-o-matic eutils
+
+MY_PN=acpica-unix
+MY_P=${MY_PN}-${PV}
+MY_TESTS_P=${MY_PN/ca/tests}-${PV}
+DESCRIPTION="Intel ACPI Source Language (ASL) compiler"
+HOMEPAGE="http://www.intel.com/technology/iapc/acpi/"
+SRC_URI="http://www.acpica.org/download/${MY_P}.tar.gz
+ test? ( http://www.acpica.org/download/${MY_TESTS_P}.tar.gz )"
+
+LICENSE="iASL"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+
+IUSE="test"
+DEPEND="sys-devel/bison
+ sys-devel/flex"
+
+RDEPEND=""
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+ if use test
+ then
+ ewarn 'You have selected USE="test". This will install the test results'
+ ewarn "into /usr/share/${PF}/, compressed as a tarball."
+ ewarn 'The tests themselves will only rarely die, but the test results'
+ ewarn 'are interesting for arch testing. The tests may take quite some'
+ ewarn 'time to complete.'
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/iasl-20080701-parallelmake.patch
+ epatch "${FILESDIR}"/iasl-locale.patch
+
+ sed -i -e 's:LDFLAGS=:LDLIBS+=:' \
+ "${S}"/compiler/Makefile || die "unable to fix compiler Makefile"
+}
+
+src_compile() {
+ local target bin
+ append-flags -fno-strict-aliasing
+
+ for target in compiler tools/acpisrc tools/acpixtract tools/acpiexec
+ do
+ einfo "Compiling in ${target}/"
+ cd "${S}"/${target}
+ case "${target}" in
+ compiler) bin=iasl;;
+ *) bin=${target#*/};;
+ esac
+
+ emake CC="$(tc-getCC)" || die "emake in ${target} failed"
+ einfo "Finished compiling ${target}"
+
+ mv ${bin} "${T}" || die "mv ${bin} failed"
+ einfo "Finished moving ${bin}"
+
+ make clean || die "make clean in ${target} failed"
+ einfo "Finished cleaning ${target}"
+
+ echo ${bin} >>"${T}"/binlist
+ done
+ einfo "$(<"${T}"/binlist)"
+}
+
+src_test() {
+ aslts_test
+ #aapits_test
+ #The aapits test currently fails, missing include probably.
+}
+
+src_install() {
+ local bin
+ for bin in $(<"${T}"/binlist) ; do
+ dobin "${T}"/${bin}
+ done
+ dodoc README changes.txt
+ if use test ; then
+ tb="${T}"/testresults.tar.bz2
+ export ASLTSDIR="$(<"${T}"/asltdir)"
+ ebegin "Creating Test Tarball"
+ tar -cjf "${tb}" -C "${ASLTSDIR}"/tmp/RESULTS . || die "tar failed"
+ eend $?
+ dodir /usr/share/${PF}
+ insinto /usr/share/${PF}
+ doins ${tb} || die "doins testresults.tar.bz2 failed"
+ fi
+
+}
+
+aslts_test() {
+ export ASL="${T}"/iasl \
+ acpiexec="${T}"/acpiexec \
+ ASLTSDIR="${WORKDIR}/${MY_TESTS_P}"/tests/aslts
+ export PATH="${PATH}:${ASLTSDIR}/bin"
+ echo "$ASLTSDIR" >"${T}"/asltdir
+ cd "${ASLTSDIR}"
+ edos2unix $(find . -type 'f') || die "edos2unix failed in aslts"
+ make install || die "make install aslts test failed"
+ chmod +x $(find bin/ ! -regex 'ERROR_OPCODES|HOW_TO_USE|README' ) || die "chmod bin +x failed"
+
+ #The below Do commands runs the tests twice and then dies if the results aren't
+ #Identical.
+ Do 1 || die "failed Do 1"
+ Do 2 || die "failed Do 2"
+}
+
+aapits_test() {
+ mv "${WORKDIR}/${MY_TESTS_P}/tests/aapits" "${S}/tools/" || die "mv failed"
+ cd "${S}/tools/aapits" || die "cannot find ${S}/tools/aapits"
+ edos2unix $(find . -type 'f') || die "edos2unix failed in aapits"
+ chmod +x $(find bin/ | sed -r -e '/\/[A-Z_]+$/d') || die "chmod bin +x failed"
+ make || die "make in aapits failed"
+ cd asl || die "cd asl failed"
+ make || die "make in asl failed"
+ cd ../bin
+ ./aapitsrun || die "aapitsrun failed"
+}