summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2013-02-26 20:31:49 +0000
committerAnthony G. Basile <blueness@gentoo.org>2013-02-26 20:31:49 +0000
commit63bf500c882959057919b2baa3a2b811ad8e22ec (patch)
tree3a340f66c8e0d04caac97c51ebc5274a1a9d3f94 /sys-process/at
parentAdd kernel-3.8 compatibity patch from upstream (#458508 by Philipp Leonhardt)... (diff)
downloadgentoo-2-63bf500c882959057919b2baa3a2b811ad8e22ec.tar.gz
gentoo-2-63bf500c882959057919b2baa3a2b811ad8e22ec.tar.bz2
gentoo-2-63bf500c882959057919b2baa3a2b811ad8e22ec.zip
non-maintainer commit: fix getloadavg for uclibc
(Portage version: 2.1.11.50/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'sys-process/at')
-rw-r--r--sys-process/at/ChangeLog8
-rw-r--r--sys-process/at/at-3.1.13-r2.ebuild81
-rw-r--r--sys-process/at/files/at-3.1.13-getloadavg.patch19
3 files changed, 107 insertions, 1 deletions
diff --git a/sys-process/at/ChangeLog b/sys-process/at/ChangeLog
index ddb5c7d9b167..869384db41ca 100644
--- a/sys-process/at/ChangeLog
+++ b/sys-process/at/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-process/at
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/at/ChangeLog,v 1.43 2013/02/18 17:57:48 swift Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/at/ChangeLog,v 1.44 2013/02/26 20:31:49 blueness Exp $
+
+*at-3.1.13-r2 (26 Feb 2013)
+
+ 26 Feb 2013; Anthony G. Basile <blueness@gentoo.org> +at-3.1.13-r2.ebuild,
+ +files/at-3.1.13-getloadavg.patch:
+ non-maintainer commit: fix getloadavg for uclibc
18 Feb 2013; Sven Vermeulen <swift@gentoo.org> at-3.1.10.2-r1.ebuild,
at-3.1.10.2-r2.ebuild, at-3.1.13.ebuild, at-3.1.13-r1.ebuild:
diff --git a/sys-process/at/at-3.1.13-r2.ebuild b/sys-process/at/at-3.1.13-r2.ebuild
new file mode 100644
index 000000000000..0b801b6bdc65
--- /dev/null
+++ b/sys-process/at/at-3.1.13-r2.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/at/at-3.1.13-r2.ebuild,v 1.1 2013/02/26 20:31:49 blueness Exp $
+
+EAPI=4
+
+inherit autotools eutils flag-o-matic pam
+
+DESCRIPTION="Queues jobs for later execution"
+HOMEPAGE="http://packages.qa.debian.org/a/at.html"
+SRC_URI="mirror://debian/pool/main/a/at/${PN}_${PV}.orig.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="pam selinux"
+
+DEPEND="virtual/mta
+ >=sys-devel/autoconf-2.64
+ sys-devel/bison
+ >=sys-devel/flex-2.5.4a
+ pam? ( virtual/pam )
+ selinux? ( sec-policy/selinux-at )"
+RDEPEND="virtual/mta
+ virtual/logger
+ selinux? ( sec-policy/selinux-at )"
+
+pkg_setup() {
+ enewgroup at 25
+ enewuser at 25 -1 /var/spool/at/atjobs at
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-3.1.8-more-deny.patch
+ epatch "${FILESDIR}"/${PN}-3.1.13-Makefile.patch
+ # fix parallel make issues, bug #244884
+ epatch "${FILESDIR}"/${PN}-3.1.10.2-Makefile.in-parallel-make-fix.patch
+ epatch "${FILESDIR}"/${P}-configure.in-fix-PAM-automagick-dep.patch
+ # Fix parallel make issue (bug #408375)
+ epatch "${FILESDIR}"/${PN}-3.1.13-parallel-make-fix.patch
+ epatch "${FILESDIR}"/${PN}-3.1.13-getloadavg.patch
+
+ eautoconf
+}
+
+src_configure() {
+ use pam || my_conf="--without-pam"
+ econf \
+ --sysconfdir=/etc/at \
+ --with-jobdir=/var/spool/at/atjobs \
+ --with-atspool=/var/spool/at/atspool \
+ --with-etcdir=/etc/at \
+ --with-daemon_username=at \
+ --with-daemon_groupname=at \
+ ${my_conf}
+}
+
+src_install() {
+ emake install IROOT="${D}" || die
+
+ newinitd "${FILESDIR}"/atd.rc6 atd
+ newconfd "${FILESDIR}"/atd.confd atd
+ newpamd "${FILESDIR}"/at.pamd-3.1.13-r1 atd
+
+ # Preserve existing .SEQ files (bug #386625)
+ local seq_file="${ROOT}/var/spool/at/atjobs/.SEQ"
+ if [ -f "${seq_file}" ] ; then
+ einfo "Preserving existing .SEQ file (bug #386625)."
+ cp -p "${seq_file}" "${D}"/var/spool/at/atjobs/ || die
+ fi
+}
+
+pkg_postinst() {
+ einfo "Forcing correct permissions on /var/spool/at"
+ chown at:at "${ROOT}/var/spool/at/atjobs"
+ chmod 1770 "${ROOT}/var/spool/at/atjobs"
+ chown at:at "${ROOT}/var/spool/at/atjobs/.SEQ"
+ chmod 0600 "${ROOT}/var/spool/at/atjobs/.SEQ"
+ chown at:at "${ROOT}/var/spool/at/atspool"
+ chmod 1770 "${ROOT}/var/spool/at/atspool"
+}
diff --git a/sys-process/at/files/at-3.1.13-getloadavg.patch b/sys-process/at/files/at-3.1.13-getloadavg.patch
new file mode 100644
index 000000000000..7de085dcd84b
--- /dev/null
+++ b/sys-process/at/files/at-3.1.13-getloadavg.patch
@@ -0,0 +1,19 @@
+diff --git a/getloadavg.c b/getloadavg.c
+index cf5869f..c7e2b27 100644
+--- a/getloadavg.c
++++ b/getloadavg.c
+@@ -69,8 +69,12 @@ Boston, MA 02110-1301 USA */
+ #include <config.h>
+ #endif
+
+-#include "lisp.h"
+-#include "sysfile.h" /* for encapsulated open, close, read, write */
++#include <sys/types.h>
++#include <sys/stat.h>
++#include <fcntl.h>
++
++//#include "lisp.h"
++//#include "sysfile.h" /* for encapsulated open, close, read, write */
+
+ #ifndef HAVE_GETLOADAVG
+