summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCiaran McCreesh <ciaranm@gentoo.org>2005-03-03 16:24:36 +0000
committerCiaran McCreesh <ciaranm@gentoo.org>2005-03-03 16:24:36 +0000
commit86f7834b66822cea5ba58278dbc50a1e069033c3 (patch)
treec1b283011fcbc5fd13f569e594f927b470310c5a /sys-process/psmisc/psmisc-21.5.ebuild
parentMoved sys-apps/watchpid to sys-process/watchpid (diff)
downloadgentoo-2-86f7834b66822cea5ba58278dbc50a1e069033c3.tar.gz
gentoo-2-86f7834b66822cea5ba58278dbc50a1e069033c3.tar.bz2
gentoo-2-86f7834b66822cea5ba58278dbc50a1e069033c3.zip
Moved from sys-apps/psmisc to sys-process/psmisc.
Diffstat (limited to 'sys-process/psmisc/psmisc-21.5.ebuild')
-rw-r--r--sys-process/psmisc/psmisc-21.5.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/sys-process/psmisc/psmisc-21.5.ebuild b/sys-process/psmisc/psmisc-21.5.ebuild
new file mode 100644
index 000000000000..bbe221e646f5
--- /dev/null
+++ b/sys-process/psmisc/psmisc-21.5.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/psmisc/psmisc-21.5.ebuild,v 1.1 2005/03/03 16:24:36 ciaranm Exp $
+
+inherit eutils
+
+SELINUX_PATCH="${P}-selinux.diff.bz2"
+
+DESCRIPTION="A set of tools that use the proc filesystem"
+HOMEPAGE="http://psmisc.sourceforge.net/"
+SRC_URI="mirror://sourceforge/psmisc/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm hppa ia64 ~mips ~ppc ~ppc64 s390 sh sparc x86"
+IUSE="nls selinux"
+
+RDEPEND=">=sys-libs/ncurses-5.2-r2
+ selinux? ( sys-libs/libselinux )"
+DEPEND="${RDEPEND}
+ sys-devel/libtool
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ if use selinux; then
+ epatch ${FILESDIR}/${SELINUX_PATCH}
+ libtoolize --copy --force
+ fi
+ epunt_cxx #73632
+}
+
+src_compile() {
+ econf \
+ --bindir=/bin \
+ $(use_enable selinux) \
+ $(use_enable nls) \
+ || die
+ emake || die
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die
+
+ # Some packages expect these to use /usr, others to use /
+ dodir /usr/bin
+ cd "${D}"/bin
+ for f in * ; do
+ dosym /bin/${f} /usr/bin/${f}
+ done
+
+ dodoc AUTHORS ChangeLog NEWS README
+}