summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWolfram Schlich <wschlich@gentoo.org>2007-11-24 01:55:11 +0000
committerWolfram Schlich <wschlich@gentoo.org>2007-11-24 01:55:11 +0000
commit5a20bbb2cade1435e23d0b5b9c7b1f5529c7553b (patch)
treea59e5c2c1d73b6c77c6c702aaadac2f672e3fb17 /sys-process
parentremove emul-* mask (diff)
downloadgentoo-2-5a20bbb2cade1435e23d0b5b9c7b1f5529c7553b.tar.gz
gentoo-2-5a20bbb2cade1435e23d0b5b9c7b1f5529c7553b.tar.bz2
gentoo-2-5a20bbb2cade1435e23d0b5b9c7b1f5529c7553b.zip
version bump
(Portage version: 2.1.3.19)
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/htop/ChangeLog7
-rw-r--r--sys-process/htop/files/digest-htop-0.73
-rw-r--r--sys-process/htop/htop-0.7.ebuild35
3 files changed, 44 insertions, 1 deletions
diff --git a/sys-process/htop/ChangeLog b/sys-process/htop/ChangeLog
index 3f03efabbb7c..1d76119b698c 100644
--- a/sys-process/htop/ChangeLog
+++ b/sys-process/htop/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-process/htop
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/htop/ChangeLog,v 1.48 2007/10/04 04:04:35 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/htop/ChangeLog,v 1.49 2007/11/24 01:55:10 wschlich Exp $
+
+*htop-0.7 (24 Nov 2007)
+
+ 24 Nov 2007; Wolfram Schlich <wschlich@gentoo.org> +htop-0.7.ebuild:
+ version bump
04 Oct 2007; Jeroen Roovers <jer@gentoo.org> htop-0.6.6.ebuild:
Stable for HPPA (bug #194016).
diff --git a/sys-process/htop/files/digest-htop-0.7 b/sys-process/htop/files/digest-htop-0.7
new file mode 100644
index 000000000000..13064eb50a6b
--- /dev/null
+++ b/sys-process/htop/files/digest-htop-0.7
@@ -0,0 +1,3 @@
+MD5 4afc961fa709167e1b434682897991f9 htop-0.7.tar.gz 143896
+RMD160 0f7606dfd143512e53414d346893f5a7799a8652 htop-0.7.tar.gz 143896
+SHA256 1361f4f0b92d7e6bdac25a4b7ee138a7ee83b5a9368820f5aa518051ca82862b htop-0.7.tar.gz 143896
diff --git a/sys-process/htop/htop-0.7.ebuild b/sys-process/htop/htop-0.7.ebuild
new file mode 100644
index 000000000000..af6cc71b0193
--- /dev/null
+++ b/sys-process/htop/htop-0.7.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/htop/htop-0.7.ebuild,v 1.1 2007/11/24 01:55:10 wschlich Exp $
+
+inherit flag-o-matic
+
+IUSE="debug"
+DESCRIPTION="interactive process viewer"
+HOMEPAGE="http://htop.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+DEPEND="sys-libs/ncurses"
+
+pkg_setup() {
+ if use elibc_FreeBSD ; then
+ elog
+ elog "htop needs /proc mounted to work, to mount it type"
+ elog "mount -t linprocfs none /proc"
+ elog "or uncomment the example in /etc/fstab"
+ elog
+ fi
+}
+
+src_compile() {
+ useq debug && append-flags -O -ggdb -DDEBUG
+ econf || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc README ChangeLog TODO
+}