summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2005-03-21 03:47:19 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2005-03-21 03:47:19 +0000
commit86013f5df4d9f0d6ee602fe30d2cbd334f87b1e1 (patch)
treebc24a3fb79f11fda054106872c592546f1b68ec7 /sys-process
parentAdded ~sparc keyword. (diff)
downloadgentoo-2-86013f5df4d9f0d6ee602fe30d2cbd334f87b1e1.tar.gz
gentoo-2-86013f5df4d9f0d6ee602fe30d2cbd334f87b1e1.tar.bz2
gentoo-2-86013f5df4d9f0d6ee602fe30d2cbd334f87b1e1.zip
Bug #79665, provide a new acct build that works with v3 acct format and is also backwards compatible. Also do not provide the "last" binary anymore, as it is provided by sysvinit.
(Portage version: 2.0.51.19)
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/acct/ChangeLog10
-rw-r--r--sys-process/acct/Manifest6
-rw-r--r--sys-process/acct/acct-6.3.5-r1.ebuild33
-rw-r--r--sys-process/acct/files/acct.rc69
-rw-r--r--sys-process/acct/files/digest-acct-6.3.5-r11
5 files changed, 56 insertions, 3 deletions
diff --git a/sys-process/acct/ChangeLog b/sys-process/acct/ChangeLog
index a2172bd0bcdf..1b11097606cc 100644
--- a/sys-process/acct/ChangeLog
+++ b/sys-process/acct/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-process/acct
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/acct/ChangeLog,v 1.3 2005/03/03 23:35:24 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/acct/ChangeLog,v 1.4 2005/03/21 03:47:19 robbat2 Exp $
+
+*acct-6.3.5-r1 (20 Mar 2005)
+
+ 20 Mar 2005; Robin H. Johnson <robbat2@gentoo.org> files/acct.rc6,
+ +acct-6.3.5-r1.ebuild:
+ Bug #79665, provide a new acct build that works with v3 acct format and is
+ also backwards compatible. Also do not provide the "last" binary anymore, as
+ it is provided by sysvinit.
03 Mar 2005; Mike Frysinger <vapier@gentoo.org> acct-6.3.5.ebuild:
Dont install ansi2knr.1 since we dont install ansi2knr #83876 by Mike Nerone.
diff --git a/sys-process/acct/Manifest b/sys-process/acct/Manifest
index 1a560cdfed1d..47240adaf16e 100644
--- a/sys-process/acct/Manifest
+++ b/sys-process/acct/Manifest
@@ -1,6 +1,8 @@
-MD5 dae561a3bee38a3873a19ff5f42e9a1b ChangeLog 1357
MD5 5d5683e33db42299f13857dd11b5090b acct-6.3.5.ebuild 864
+MD5 2222500f1db333df456cdfddae235321 acct-6.3.5-r1.ebuild 1106
+MD5 dae561a3bee38a3873a19ff5f42e9a1b ChangeLog 1357
MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
-MD5 2dbe3e38c54e479bccb31fa6c30f28b6 files/acct-6.3.5-gentoo.diff 371
MD5 1e626acad5540fee59e05067baccf551 files/acct.rc6 232
+MD5 679163b80cdf41047198cb6bb75c6408 files/digest-acct-6.3.5-r1 70
MD5 296bdfcb1fa7634f32846c4f1caee788 files/digest-acct-6.3.5 67
+MD5 2dbe3e38c54e479bccb31fa6c30f28b6 files/acct-6.3.5-gentoo.diff 371
diff --git a/sys-process/acct/acct-6.3.5-r1.ebuild b/sys-process/acct/acct-6.3.5-r1.ebuild
new file mode 100644
index 000000000000..336eded313d5
--- /dev/null
+++ b/sys-process/acct/acct-6.3.5-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/acct/acct-6.3.5-r1.ebuild,v 1.1 2005/03/21 03:47:19 robbat2 Exp $
+
+inherit eutils
+
+PATCH_VER="ts02-11"
+MY_P=${P}-${PATCH_VER}
+DESCRIPTION="GNU system accounting utilities"
+HOMEPAGE="http://www.gnu.org/directory/acct.html"
+SRC_URI="http://www.physik3.uni-rostock.de/tim/kernel/utils/acct/${MY_P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86 ~ppc"
+IUSE=""
+DEPEND="virtual/libc"
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ econf --enable-linux-multiformat || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ into /usr
+ dobin ac lastcomm || die "dobin failed"
+ dosbin dump-utmp dump-acct accton sa || die "dosbin failed"
+ doinfo accounting.info
+ doman {ac,lastcomm}.1 {accton,sa}.8
+ dodoc AUTHORS ChangeLog INSTALL NEWS README ToDo
+ keepdir /var/account
+ newinitd "${FILESDIR}"/acct.rc6 acct
+}
diff --git a/sys-process/acct/files/acct.rc6 b/sys-process/acct/files/acct.rc6
index 4fd46e6259a9..0c81485ab50d 100644
--- a/sys-process/acct/files/acct.rc6
+++ b/sys-process/acct/files/acct.rc6
@@ -1,4 +1,11 @@
#!/sbin/runscript
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/acct/files/acct.rc6,v 1.2 2005/03/21 03:47:19 robbat2 Exp $
+
+depend() {
+ need localmount
+}
start() {
ebegin "Starting accounting"
@@ -13,3 +20,5 @@ stop() {
/usr/sbin/accton
eend $?
}
+
+# vim:ts=4 sw=4:
diff --git a/sys-process/acct/files/digest-acct-6.3.5-r1 b/sys-process/acct/files/digest-acct-6.3.5-r1
new file mode 100644
index 000000000000..ab900f0bc236
--- /dev/null
+++ b/sys-process/acct/files/digest-acct-6.3.5-r1
@@ -0,0 +1 @@
+MD5 e2b9a9b04aaa5813a94472b38d9a8357 acct-6.3.5-ts02-11.tar.gz 307681