summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-02-07 21:38:55 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-02-07 21:38:55 +0000
commit9ec7ed52832681afc3df23f8bc7c4938b460c23f (patch)
treea6e4563f26615ae301d0d840db4b5879d0de9484 /sys-process
parentAdded upstream build fix for newer gcc/kde versions (bug 353751) (diff)
downloadgentoo-2-9ec7ed52832681afc3df23f8bc7c4938b460c23f.tar.gz
gentoo-2-9ec7ed52832681afc3df23f8bc7c4938b460c23f.tar.bz2
gentoo-2-9ec7ed52832681afc3df23f8bc7c4938b460c23f.zip
Support installation for multiple Python ABIs (bug #316965).
(Portage version: 2.2.0_alpha21_p2/cvs/Linux x86_64)
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/audit/ChangeLog6
-rw-r--r--sys-process/audit/audit-2.0.5.ebuild39
2 files changed, 42 insertions, 3 deletions
diff --git a/sys-process/audit/ChangeLog b/sys-process/audit/ChangeLog
index 439ff0b9364b..c536d283d6bd 100644
--- a/sys-process/audit/ChangeLog
+++ b/sys-process/audit/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-process/audit
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/audit/ChangeLog,v 1.63 2011/02/07 21:00:11 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/audit/ChangeLog,v 1.64 2011/02/07 21:38:55 arfrever Exp $
+
+ 07 Feb 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ audit-2.0.5.ebuild:
+ Support installation for multiple Python ABIs (bug #316965).
07 Feb 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
audit-2.0.5.ebuild, +files/audit-2.0.5-python.patch:
diff --git a/sys-process/audit/audit-2.0.5.ebuild b/sys-process/audit/audit-2.0.5.ebuild
index 77a406a4add4..0f72abf14624 100644
--- a/sys-process/audit/audit-2.0.5.ebuild
+++ b/sys-process/audit/audit-2.0.5.ebuild
@@ -1,9 +1,11 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/audit/audit-2.0.5.ebuild,v 1.2 2011/02/07 21:00:11 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/audit/audit-2.0.5.ebuild,v 1.3 2011/02/07 21:38:55 arfrever Exp $
EAPI="3"
PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
inherit autotools multilib toolchain-funcs python linux-info
@@ -31,8 +33,8 @@ CONFIG_CHECK="~AUDIT"
pkg_setup() {
linux-info_pkg_setup
- python_set_active_version 2
python_pkg_setup
+ PYTHON_DIRS="bindings/python swig"
}
src_prepare() {
@@ -67,6 +69,10 @@ src_prepare() {
# Don't build static version of Python module.
epatch "${FILESDIR}"/${P}-python.patch
+ # Python bindings are built/installed manually.
+ sed -e "/^SUBDIRS =/s/ python//" -i bindings/Makefile.am
+ sed -e "/^SUBDIRS =/s/ swig//" -i Makefile.am
+
# Regenerate autotooling
eautoreconf
@@ -83,8 +89,37 @@ src_configure() {
econf --sbindir=/sbin $(use_with prelude)
}
+src_compile() {
+ default
+
+ python_copy_sources ${PYTHON_DIRS}
+
+ building() {
+ emake \
+ PYTHON_VERSION="$(python_get_version)" \
+ pyexecdir="$(python_get_sitedir)"
+ }
+ local dir
+ for dir in ${PYTHON_DIRS}; do
+ python_execute_function -s --source-dir ${dir} building
+ done
+}
+
src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
+
+ installation() {
+ emake \
+ DESTDIR="${D}" \
+ PYTHON_VERSION="$(python_get_version)" \
+ pyexecdir="$(python_get_sitedir)" \
+ install
+ }
+ local dir
+ for dir in ${PYTHON_DIRS}; do
+ python_execute_function -s --source-dir ${dir} installation
+ done
+
dodoc AUTHORS ChangeLog README* THANKS TODO
docinto contrib
dodoc contrib/*