summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-10-30 23:28:19 +0000
committerMike Frysinger <vapier@gentoo.org>2011-10-30 23:28:19 +0000
commitec2044854b94dd13a558f02960d7675699d38f31 (patch)
treed5264854a52c9eabc659e1d62eab3ba32828986b /sys-process
parentAdd workaround for qmake misbehaviour, bug 388675 (diff)
downloadgentoo-2-ec2044854b94dd13a558f02960d7675699d38f31.tar.gz
gentoo-2-ec2044854b94dd13a558f02960d7675699d38f31.tar.bz2
gentoo-2-ec2044854b94dd13a558f02960d7675699d38f31.zip
Add fix from upstream #388555 by Lars Wendler (Polynomial-C).
(Portage version: 2.2.0_alpha71/cvs/Linux x86_64)
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/lsof/ChangeLog8
-rw-r--r--sys-process/lsof/files/lsof-4.85-arg.c.patch30
-rw-r--r--sys-process/lsof/lsof-4.85-r1.ebuild76
3 files changed, 113 insertions, 1 deletions
diff --git a/sys-process/lsof/ChangeLog b/sys-process/lsof/ChangeLog
index 62893845abaa..ceddff4c636b 100644
--- a/sys-process/lsof/ChangeLog
+++ b/sys-process/lsof/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-process/lsof
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/lsof/ChangeLog,v 1.80 2011/09/29 03:15:30 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/lsof/ChangeLog,v 1.81 2011/10/30 23:28:18 vapier Exp $
+
+*lsof-4.85-r1 (30 Oct 2011)
+
+ 30 Oct 2011; Mike Frysinger <vapier@gentoo.org> +lsof-4.85-r1.ebuild,
+ +files/lsof-4.85-arg.c.patch:
+ Add fix from upstream #388555 by Lars Wendler (Polynomial-C).
*lsof-4.85 (29 Sep 2011)
diff --git a/sys-process/lsof/files/lsof-4.85-arg.c.patch b/sys-process/lsof/files/lsof-4.85-arg.c.patch
new file mode 100644
index 000000000000..98838cd772f3
--- /dev/null
+++ b/sys-process/lsof/files/lsof-4.85-arg.c.patch
@@ -0,0 +1,30 @@
+arg.c.patch Patches: lsof_4.85_src/arg.c
+
+ Importance: major for all dialects supporting
+ the +|-e option (e.g., Linux)
+
+ Function: this patch corrects a bug in the
+ accumulation of multiple +|-e
+ option values
+
+*** /tmp/T0iAaaeo Thu Oct 20 14:08:43 2011
+--- arg.c Thu Oct 20 14:03:49 2011
+***************
+*** 778,785 ****
+ ep->pathl = i;
+ ep->rdlnk = rdlnk;
+ ep->mp = (struct mounts *)NULL;
+! if (!(ep->next = Efsysl))
+! Efsysl = ep;
+ return(0);
+ }
+ #endif /* defined(HASEOPT) */
+--- 778,785 ----
+ ep->pathl = i;
+ ep->rdlnk = rdlnk;
+ ep->mp = (struct mounts *)NULL;
+! ep->next = Efsysl;
+! Efsysl = ep;
+ return(0);
+ }
+ #endif /* defined(HASEOPT) */
diff --git a/sys-process/lsof/lsof-4.85-r1.ebuild b/sys-process/lsof/lsof-4.85-r1.ebuild
new file mode 100644
index 000000000000..d77bc7818538
--- /dev/null
+++ b/sys-process/lsof/lsof-4.85-r1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/lsof/lsof-4.85-r1.ebuild,v 1.1 2011/10/30 23:28:18 vapier Exp $
+
+EAPI="2"
+
+inherit eutils flag-o-matic toolchain-funcs
+
+MY_P=${P/-/_}
+DESCRIPTION="Lists open files for running Unix processes"
+HOMEPAGE="ftp://lsof.itap.purdue.edu/pub/tools/unix/lsof/"
+SRC_URI="ftp://lsof.itap.purdue.edu/pub/tools/unix/lsof/${MY_P}.tar.bz2
+ ftp://vic.cc.purdue.edu/pub/tools/unix/lsof/${MY_P}.tar.bz2
+ ftp://ftp.cerias.purdue.edu/pub/tools/unix/sysutils/lsof/${MY_P}.tar.bz2"
+
+LICENSE="lsof"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="ipv6 rpc selinux static"
+
+RDEPEND="rpc? ( net-libs/libtirpc )
+ selinux? ( sys-libs/libselinux )"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}/${MY_P}_src
+
+src_unpack() {
+ unpack ${A}
+ cd ${MY_P}
+ unpack ./${MY_P}_src.tar
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-arg.c.patch #388555
+ # convert `test -r header.h` into a compile test
+ sed -i -r \
+ -e 's:test -r \$\{LSOF_INCLUDE\}/([[:alnum:]/._]*):echo "#include <\1>" | ${LSOF_CC} ${LSOF_CFGF} -E - >/dev/null 2>\&1:' \
+ -e 's:grep (.*) \$\{LSOF_INCLUDE\}/([[:alnum:]/._]*):echo "#include <\2>" | ${LSOF_CC} ${LSOF_CFGF} -E -P -dD - 2>/dev/null | grep \1:' \
+ Configure || die
+}
+
+target() { usex kernel_FreeBSD freebsd linux ; }
+src_configure() {
+ use static && append-ldflags -static
+
+ append-cppflags $(usex rpc "$($(tc-getPKG_CONFIG) libtirpc --cflags)" -DHASNOTRPC)
+ append-cppflags $(usex ipv6 -{D,U}HASIPv6)
+
+ export LSOF_CFGL="${CFLAGS} ${LDFLAGS} \
+ $(use rpc && $(tc-getPKG_CONFIG) libtirpc --libs)"
+
+ # Set LSOF_INCLUDE to a dummy location so the script doesn't poke
+ # around in it and mix /usr/include paths with cross-compile/etc.
+ touch .neverInv
+ LINUX_HASSELINUX=$(usex selinux y n) \
+ LSOF_INCLUDE=${T} \
+ LSOF_CC=$(tc-getCC) \
+ LSOF_AR="$(tc-getAR) rc" \
+ LSOF_RANLIB=$(tc-getRANLIB) \
+ LSOF_CFGF="${CFLAGS} ${CPPFLAGS}" \
+ ./Configure -n $(target) || die
+}
+
+src_compile() {
+ emake DEBUG="" all || die
+}
+
+src_install() {
+ dobin lsof || die
+
+ insinto /usr/share/lsof/scripts
+ doins scripts/* || die
+
+ doman lsof.8 || die
+ dodoc 00*
+}