summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-06-21 08:01:42 +0000
committerJustin Lecher <jlec@gentoo.org>2011-06-21 08:01:42 +0000
commit26da454308712e62a9d9ba8102cdd60fa2016ea8 (patch)
treee4956d79bee06c116268634fdc65c3840f93da5d /virtual/fortran
parentmask =app-crypt/heimdal-1.5_pre* (diff)
downloadgentoo-2-26da454308712e62a9d9ba8102cdd60fa2016ea8.tar.gz
gentoo-2-26da454308712e62a9d9ba8102cdd60fa2016ea8.tar.bz2
gentoo-2-26da454308712e62a9d9ba8102cdd60fa2016ea8.zip
Added openmp support
(Portage version: 2.2.0_alpha41/cvs/Linux x86_64)
Diffstat (limited to 'virtual/fortran')
-rw-r--r--virtual/fortran/ChangeLog5
-rw-r--r--virtual/fortran/fortran-0.ebuild9
2 files changed, 10 insertions, 4 deletions
diff --git a/virtual/fortran/ChangeLog b/virtual/fortran/ChangeLog
index d8cbbc123004..3993ab6e7ce9 100644
--- a/virtual/fortran/ChangeLog
+++ b/virtual/fortran/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for virtual/fortran
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/virtual/fortran/ChangeLog,v 1.3 2011/05/28 11:17:51 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/virtual/fortran/ChangeLog,v 1.4 2011/06/21 08:01:42 jlec Exp $
+
+ 21 Jun 2011; Justin Lecher <jlec@gentoo.org> fortran-0.ebuild:
+ Added openmp support
28 May 2011; Justin Lecher <jlec@gentoo.org> fortran-0.ebuild:
Compiler is needed at build and runtime
diff --git a/virtual/fortran/fortran-0.ebuild b/virtual/fortran/fortran-0.ebuild
index d11ab7152ab2..4bf8fe643f78 100644
--- a/virtual/fortran/fortran-0.ebuild
+++ b/virtual/fortran/fortran-0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/virtual/fortran/fortran-0.ebuild,v 1.3 2011/05/28 11:17:51 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/virtual/fortran/fortran-0.ebuild,v 1.4 2011/06/21 08:01:42 jlec Exp $
EAPI="4"
@@ -11,7 +11,10 @@ SRC_URI=""
SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 ~m68k ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
LICENSE=""
-IUSE=""
+IUSE="openmp"
-RDEPEND="|| ( sys-devel/gcc[fortran] sys-devel/gcc-apple[fortran] dev-lang/ifc )"
+RDEPEND="
+ || ( sys-devel/gcc[fortran] sys-devel/gcc-apple[fortran] dev-lang/ifc dev-lang/ekopath-bin )
+ openmp? (
+ || ( sys-devel/gcc[fortran,openmp?] sys-devel/gcc-apple[fortran,openmp?] dev-lang/ifc dev-lang/ekopath-bin ) )"
DEPEND="${RDEPEND}"