summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-09-13 21:41:27 +0000
committerMichał Górny <mgorny@gentoo.org>2013-09-13 21:41:27 +0000
commit8e86ed63158865518e6229a610f7a89d22fab2dd (patch)
tree5257db85cda892826070dac868fb62a266f04cdf /virtual
parentAutomake-1.13 fix, bug #467910. (diff)
downloadgentoo-2-8e86ed63158865518e6229a610f7a89d22fab2dd.tar.gz
gentoo-2-8e86ed63158865518e6229a610f7a89d22fab2dd.tar.bz2
gentoo-2-8e86ed63158865518e6229a610f7a89d22fab2dd.zip
Use python_gen_cond_dep and python_gen_usedep. This guarantees clean upgrade after disabling old implementations.
(Portage version: 2.2.4/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'virtual')
-rw-r--r--virtual/python-argparse/ChangeLog7
-rw-r--r--virtual/python-argparse/python-argparse-0.ebuild21
-rw-r--r--virtual/python-argparse/python-argparse-1.ebuild7
3 files changed, 13 insertions, 22 deletions
diff --git a/virtual/python-argparse/ChangeLog b/virtual/python-argparse/ChangeLog
index 9f2290f53bec..98e9674d6bbc 100644
--- a/virtual/python-argparse/ChangeLog
+++ b/virtual/python-argparse/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for virtual/python-argparse
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/virtual/python-argparse/ChangeLog,v 1.13 2013/09/05 19:33:16 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/virtual/python-argparse/ChangeLog,v 1.14 2013/09/13 21:41:27 mgorny Exp $
+
+ 13 Sep 2013; Michał Górny <mgorny@gentoo.org> python-argparse-0.ebuild,
+ python-argparse-1.ebuild:
+ Use python_gen_cond_dep and python_gen_usedep. This guarantees clean upgrade
+ after disabling old implementations.
05 Sep 2013; Michał Górny <mgorny@gentoo.org> python-argparse-0.ebuild,
python-argparse-1.ebuild:
diff --git a/virtual/python-argparse/python-argparse-0.ebuild b/virtual/python-argparse/python-argparse-0.ebuild
index 63de114c3c66..98afeacefa5c 100644
--- a/virtual/python-argparse/python-argparse-0.ebuild
+++ b/virtual/python-argparse/python-argparse-0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/virtual/python-argparse/python-argparse-0.ebuild,v 1.5 2013/09/05 19:33:16 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/virtual/python-argparse/python-argparse-0.ebuild,v 1.6 2013/09/13 21:41:27 mgorny Exp $
EAPI=5
PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
@@ -15,20 +15,5 @@ SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x86-solaris"
IUSE=""
-setup_globals() {
- local i
-
- RDEPEND=
- for i in "${PYTHON_COMPAT[@]}"; do
- case "${i}" in
- python2_5|python2_6|python3_1|jython2_5)
- # Note: add USE-deps when dev-python/argparse starts
- # supporting PYTHON_TARGETS
- RDEPEND+=" python_targets_${i}? ( dev-python/argparse )"
- ;;
- *)
- ;;
- esac
- done
-}
-setup_globals
+RDEPEND="${PYTHON_DEPS}
+ $(python_gen_cond_dep "dev-python/argparse" python2_6)"
diff --git a/virtual/python-argparse/python-argparse-1.ebuild b/virtual/python-argparse/python-argparse-1.ebuild
index b59de33158ec..633e5e6e7891 100644
--- a/virtual/python-argparse/python-argparse-1.ebuild
+++ b/virtual/python-argparse/python-argparse-1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/virtual/python-argparse/python-argparse-1.ebuild,v 1.12 2013/09/05 19:33:16 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/virtual/python-argparse/python-argparse-1.ebuild,v 1.13 2013/09/13 21:41:27 mgorny Exp $
EAPI=5
PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy2_0 )
@@ -16,5 +16,6 @@ KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~ppc-aix ~
IUSE=""
RDEPEND="${PYTHON_DEPS}
- python_targets_python2_6? (
- dev-python/argparse[python_targets_python2_6] )"
+ $(python_gen_cond_dep \
+ "dev-python/argparse[$(python_gen_usedep python2_6)]" \
+ python2_6)"