summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2009-03-09 18:02:04 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2009-03-09 18:02:04 +0000
commita1b058e5cc3ea62dbc8d7ca5fdeb860a743d935b (patch)
treef50c44872dbc9963198116f575ca3f8d542bb5bf /www-apache/mod_dnssd/mod_dnssd-0.5.ebuild
parentRemove old versions. (diff)
downloadgentoo-2-a1b058e5cc3ea62dbc8d7ca5fdeb860a743d935b.tar.gz
gentoo-2-a1b058e5cc3ea62dbc8d7ca5fdeb860a743d935b.tar.bz2
gentoo-2-a1b058e5cc3ea62dbc8d7ca5fdeb860a743d935b.zip
Migrate to EAPI 2.
(Portage version: 2.2_rc20/cvs/Linux 2.6.29-rc6 i686)
Diffstat (limited to 'www-apache/mod_dnssd/mod_dnssd-0.5.ebuild')
-rw-r--r--www-apache/mod_dnssd/mod_dnssd-0.5.ebuild16
1 files changed, 5 insertions, 11 deletions
diff --git a/www-apache/mod_dnssd/mod_dnssd-0.5.ebuild b/www-apache/mod_dnssd/mod_dnssd-0.5.ebuild
index 832f66fe87c9..5a24b9a53522 100644
--- a/www-apache/mod_dnssd/mod_dnssd-0.5.ebuild
+++ b/www-apache/mod_dnssd/mod_dnssd-0.5.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_dnssd/mod_dnssd-0.5.ebuild,v 1.3 2009/01/01 14:21:43 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_dnssd/mod_dnssd-0.5.ebuild,v 1.4 2009/03/09 18:02:04 betelgeuse Exp $
+
+EAPI="2"
inherit apache-module eutils
@@ -14,7 +16,7 @@ LICENSE="BSD"
SLOT="0"
IUSE="doc"
-DEPEND="net-dns/avahi"
+DEPEND="net-dns/avahi[dbus]"
RDEPEND="${DEPEND}"
APACHE2_MOD_CONF="80_${PN}"
@@ -22,14 +24,6 @@ APACHE2_MOD_DEFINE="DNSSD"
need_apache2
-pkg_setup() {
- if ! built_with_use net-dns/avahi dbus; then
- eerror "net-dns/avahi needs USE=dbus"
- die "net-dns/avahi needs USE=dbus"
- fi
-}
-
-src_compile() {
+src_configure() {
econf --with-apxs=${APXS} --disable-lynx || die "econf failed"
- emake || die "emake failed"
}