summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Thomson <wltjr@gentoo.org>2007-03-08 16:04:50 +0000
committerWilliam Thomson <wltjr@gentoo.org>2007-03-08 16:04:50 +0000
commitf8f56d4074a33418eb021f79dd460acf99216279 (patch)
tree87843554dfcb47de60f044ef584b41362cf12f1d /www-apache/mod_jk/mod_jk-1.2.21-r2.ebuild
parentRecommit Manifest that was broken by cvs problems. (diff)
downloadgentoo-2-f8f56d4074a33418eb021f79dd460acf99216279.tar.gz
gentoo-2-f8f56d4074a33418eb021f79dd460acf99216279.tar.bz2
gentoo-2-f8f56d4074a33418eb021f79dd460acf99216279.zip
Removed versions that have a security vulnerability per bug #169433. Corrected file path issue with modules conf file.
(Portage version: 2.1.2.1)
Diffstat (limited to 'www-apache/mod_jk/mod_jk-1.2.21-r2.ebuild')
-rw-r--r--www-apache/mod_jk/mod_jk-1.2.21-r2.ebuild70
1 files changed, 70 insertions, 0 deletions
diff --git a/www-apache/mod_jk/mod_jk-1.2.21-r2.ebuild b/www-apache/mod_jk/mod_jk-1.2.21-r2.ebuild
new file mode 100644
index 000000000000..4725486dcde6
--- /dev/null
+++ b/www-apache/mod_jk/mod_jk-1.2.21-r2.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_jk/mod_jk-1.2.21-r2.ebuild,v 1.1 2007/03/08 16:04:50 wltjr Exp $
+
+inherit apache-module autotools
+
+MY_P="tomcat-connectors-${PV}-src"
+
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DESCRIPTION="JK module for connecting Tomcat and Apache using the ajp13 protocol."
+HOMEPAGE="http://tomcat.apache.org/connectors-doc/"
+SRC_URI="mirror://apache/tomcat/tomcat-connectors/jk/source/jk-${PV}/${MY_P}.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+
+S="${WORKDIR}/${MY_P}/native"
+
+APACHE1_MOD_FILE="${S}/apache-1.3/${PN}.so"
+APACHE1_MOD_CONF="88_${PN}"
+APACHE1_MOD_DEFINE="JK"
+
+APACHE2_MOD_FILE="${S}/apache-2.0/${PN}.so"
+APACHE2_MOD_CONF="88_${PN}"
+APACHE2_MOD_DEFINE="JK"
+
+DOCFILES="CHANGES.txt README"
+
+need_apache
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ eautoreconf
+}
+
+src_compile() {
+ local apxs
+ use apache2 && apxs="${APXS2}"
+ use apache2 || apxs="${APXS1}"
+
+ econf \
+ --with-apxs=${apxs} \
+ --with-apr-config=/usr/bin/apr-config \
+ || die "econf failed"
+ emake LIBTOOL="/bin/sh $(pwd)/libtool --silent" || die "emake failed"
+}
+
+src_install() {
+ # install the workers.properties file
+ insinto "${APACHE_CONFDIR}"
+ doins "${FILESDIR}/jk-workers.properties"
+
+ # call the nifty default src_install :-)
+ apache-module_src_install
+
+ if ! use apache2 ; then
+ sed -i -e 's:/apache2/:/apache/:' "${D}${APACHE_CONFDIR}/modules.d/88_${PN}.conf" \
+ || die "Could not update jk-workers.properties for apache"
+ fi
+}
+
+pkg_postinst() {
+ elog "Tomcat is not a dependency of mod_jk any longer, if you intend"
+ elog "to use it with Tomcat, you have to merge www-servers/tomcat on"
+ elog "your own."
+}