summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2011-09-06 16:42:52 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2011-09-06 16:42:52 +0000
commit07e6fb14bd7a016a672baa8c941e4a76d0d58a90 (patch)
tree993f0658f606220f02c515457f96767e26039bb2 /www-apache
parentVersion bump. (diff)
downloadgentoo-2-07e6fb14bd7a016a672baa8c941e4a76d0d58a90.tar.gz
gentoo-2-07e6fb14bd7a016a672baa8c941e4a76d0d58a90.tar.bz2
gentoo-2-07e6fb14bd7a016a672baa8c941e4a76d0d58a90.zip
Version bump.
(Portage version: 2.1.10.13/cvs/Linux x86_64)
Diffstat (limited to 'www-apache')
-rw-r--r--www-apache/mod_caucho/ChangeLog8
-rw-r--r--www-apache/mod_caucho/mod_caucho-4.0.22.ebuild48
2 files changed, 55 insertions, 1 deletions
diff --git a/www-apache/mod_caucho/ChangeLog b/www-apache/mod_caucho/ChangeLog
index ffa7ba6a625b..f4febaf979a8 100644
--- a/www-apache/mod_caucho/ChangeLog
+++ b/www-apache/mod_caucho/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-apache/mod_caucho
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_caucho/ChangeLog,v 1.60 2011/03/15 20:13:40 nelchael Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_caucho/ChangeLog,v 1.61 2011/09/06 16:42:52 nelchael Exp $
+
+*mod_caucho-4.0.22 (06 Sep 2011)
+
+ 06 Sep 2011; Krzysztof Pawlik <nelchael@gentoo.org>
+ +mod_caucho-4.0.22.ebuild:
+ Version bump.
*mod_caucho-4.0.15 (15 Mar 2011)
diff --git a/www-apache/mod_caucho/mod_caucho-4.0.22.ebuild b/www-apache/mod_caucho/mod_caucho-4.0.22.ebuild
new file mode 100644
index 000000000000..ef8a8f2d3c85
--- /dev/null
+++ b/www-apache/mod_caucho/mod_caucho-4.0.22.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_caucho/mod_caucho-4.0.22.ebuild,v 1.1 2011/09/06 16:42:52 nelchael Exp $
+
+EAPI="2"
+
+inherit eutils apache-module autotools
+
+DESCRIPTION="mod_caucho connects Resin and Apache2."
+HOMEPAGE="http://www.caucho.com/"
+SRC_URI="http://www.caucho.com/download/resin-${PV}-src.zip
+ mirror://gentoo/resin-gentoo-patches-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="${DEPEND}
+ app-arch/unzip"
+RDEPEND=""
+
+S="${WORKDIR}/resin-${PV}"
+
+# See apache-module.eclass for more information.
+APACHE2_MOD_CONF="88_${PN}"
+APACHE2_MOD_DEFINE="CAUCHO"
+APACHE2_MOD_FILE="${S}/modules/c/src/apache2/.libs/${PN}.so"
+
+need_apache2
+
+src_prepare() {
+ for i in "${WORKDIR}"/${PV}/mod_caucho-*; do
+ epatch "${i}"
+ done
+
+ mkdir m4
+ eautoreconf
+ chmod 755 ./configure
+}
+
+src_configure() {
+ econf --with-apxs=${APXS} || die "econf failed"
+}
+
+src_compile() {
+ emake -C "${S}/modules/c/src/apache2/" || die "emake failed"
+}