summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Dibb <beandog@gentoo.org>2011-10-14 16:58:23 +0000
committerSteve Dibb <beandog@gentoo.org>2011-10-14 16:58:23 +0000
commit133eee1f8650fabe92c233cbc0516289705a3763 (patch)
treeff97c44c2117e60e82fb5a4ed9bc4ff4dd5dae00 /www-apache
parentdrop mask for lightdm. Time to broader testing (diff)
downloadgentoo-2-133eee1f8650fabe92c233cbc0516289705a3763.tar.gz
gentoo-2-133eee1f8650fabe92c233cbc0516289705a3763.tar.bz2
gentoo-2-133eee1f8650fabe92c233cbc0516289705a3763.zip
Version bump, bug 355151
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'www-apache')
-rw-r--r--www-apache/mod_jk/ChangeLog9
-rw-r--r--www-apache/mod_jk/mod_jk-1.2.32.ebuild75
2 files changed, 82 insertions, 2 deletions
diff --git a/www-apache/mod_jk/ChangeLog b/www-apache/mod_jk/ChangeLog
index 8e75fb9ee207..0be678343d8c 100644
--- a/www-apache/mod_jk/ChangeLog
+++ b/www-apache/mod_jk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-apache/mod_jk
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_jk/ChangeLog,v 1.68 2010/10/24 14:43:15 ranger Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_jk/ChangeLog,v 1.69 2011/10/14 16:58:23 beandog Exp $
+
+*mod_jk-1.2.32 (14 Oct 2011)
+
+ 14 Oct 2011; Steve Dibb <beandog@gentoo.org> +mod_jk-1.2.32.ebuild:
+ Version bump, bug 355151
24 Oct 2010; Brent Baude <ranger@gentoo.org> mod_jk-1.2.30.ebuild:
Marking mod_jk-1.2.30 ppc for bug 315561
diff --git a/www-apache/mod_jk/mod_jk-1.2.32.ebuild b/www-apache/mod_jk/mod_jk-1.2.32.ebuild
new file mode 100644
index 000000000000..7bbf08b92764
--- /dev/null
+++ b/www-apache/mod_jk/mod_jk-1.2.32.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_jk/mod_jk-1.2.32.ebuild,v 1.1 2011/10/14 16:58:23 beandog Exp $
+
+EAPI="2"
+
+inherit apache-module java-pkg-2
+
+MY_P="tomcat-connectors-${PV}-src"
+
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DESCRIPTION="JK module for connecting Tomcat and Apache using the ajp13 protocol."
+HOMEPAGE="http://tomcat.apache.org/connectors-doc/"
+SRC_URI="mirror://apache/tomcat/tomcat-connectors/jk/${MY_P}.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+S="${WORKDIR}/${MY_P}/native"
+
+APACHE2_MOD_FILE="${S}/apache-2.0/${PN}.so"
+APACHE2_MOD_CONF="88_${PN}"
+APACHE2_MOD_DEFINE="JK"
+
+DOCFILES="CHANGES"
+CONF_DIR="${WORKDIR}/${MY_P}/conf"
+
+DEPEND=">=virtual/jdk-1.4"
+RDEPEND=""
+
+need_apache
+
+pkg_setup() {
+ java-pkg-2_pkg_setup
+}
+
+src_configure() {
+ econf \
+ --with-apxs=${APXS} \
+ --with-apr-config=/usr/bin/apr-config \
+ || die "econf failed"
+}
+
+src_compile() {
+ emake LIBTOOL="/bin/sh $(pwd)/libtool --silent" || die "emake failed"
+}
+
+src_install() {
+ # install the workers.properties file
+ insinto "${APACHE_CONFDIR}"
+ newins "${CONF_DIR}/workers.properties.minimal" \
+ jk-workers-minimal.properties || die
+ newins "${CONF_DIR}/workers.properties" \
+ jk-workers.properties || die
+ doins "${CONF_DIR}/uriworkermap.properties" || die
+
+ # call the nifty default src_install :-)
+ apache-module_src_install
+}
+
+pkg_postinst() {
+ elog "Tomcat is not a dependency of mod_jk any longer, if you intend"
+ elog "to use it with Tomcat, you have to merge www-servers/tomcat on"
+ elog "your own."
+
+ elog "Advanced Directives and Options can be found at: "
+ elog "http://tomcat.apache.org/connectors-doc/reference/workers.html"
+
+ elog ""
+ elog "JNI Worker Deprecation:"
+ elog "Workers of type jni are broken since a long time."
+ elog "Since there is no more use for them, they have been deprecated now,"
+ elog "and will be removed in a future release."
+}